[Alt-Tab] Hover on alt-tab easily bumped

Bug #1215630 reported by Robert Ancell on 2013-08-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Brandon Schaefer
unity (Ubuntu)
High
Brandon Schaefer

Bug Description

At some point the alt-tab application switcher seems to have gained support for mouse hover. This means if you have the mouse in the middle of the screen and then bump it while doing an alt-tab you can easily select the wrong application.

To reproduce:
1. hold alt down
2. press tab
3. Move mouse to the left of the switcher on the edge of an application icon
4. Press tab a few times
5. Move the mouse a little bit across between two icons

Expected result:
The selected icon doesn't change
Observed result:
The icon under the mouse is selected

This is particularly bad when the icons concertina under the mouse. Then basically any mouse movement will un-concertina them and select the wrong icon.

-----------------------------------
Desired resolution:

- when the alt-tab mode is entered, the pointer should be desensitised so that is no action is taken until the pointer has moved more than a certain distance in any direction
- To start with try using a value that nothing happens until the pointer moves more than 3 pixels in any direction. Then see how this feels, and adjust this value as appropriate to get the best feel.

Related branches

Robert Ancell (robert-ancell) wrote :

Right, I've seen the problem as well... Soo a couple possible solutions:

1) Don't count small differences in mouse movement. ie. if the mouse only changed 1-2 pixels don't select the icon.
2) Don't have the mouse change the selection of the icon until it is clicked.

Adding design to weigh in.

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
milestone: none → 7.1.1
John Lea (johnlea) on 2013-08-23
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
importance: Medium → High
Changed in ayatana-design:
status: New → Fix Committed
tags: added: udp
summary: - Hover on alt-tab easily bumped
+ [Alt-Tab] Hover on alt-tab easily bumped
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Robert Ancell (robert-ancell) wrote :

The change is an improvement, but you still can move the mouse one pixel and the focus will jump if the pointer is over icons that have concertina-ed during the alt-tab.

@Rebert,

Confirmed, looks like ill have to detect what a bump vs a mouse move really is. Thanks for testing it out!

Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
tags: added: rls-w-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers