unity-panel-service not running in non-upstart-sessions on Saucy (including guest session)

Bug #1214504 reported by Carla Sella
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Fix Released
High
Robert Ancell
Unity
Invalid
High
Ted Gould
lightdm (Ubuntu)
Fix Released
High
Unassigned
unity (Ubuntu)
Invalid
High
Ted Gould

Bug Description

When changing to guest session on Saucy, you do not get the session gear indicator so to go back to a users session or logout or shutdown, all the indicators are missing in the top bar.
See attached screenshot.
The only way to get out of guest session once you are in, is CTRL+ALT+F1 and reboot on command line.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: lightdm 1.7.9-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-3.6-generic 3.11.0-rc6
Uname: Linux 3.11.0-3-generic x86_64
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
Date: Tue Aug 20 19:41:01 2013
InstallationDate: Installed on 2013-03-28 (144 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130328)
LightdmConfig:
 [SeatDefaults]
 user-session=ubuntu
 type=unity
 greeter-session=unity-greeter
MarkForUpload: True
SourcePackage: lightdm
UpgradeStatus: Upgraded to saucy on 2013-05-19 (93 days ago)

Related branches

Revision history for this message
Carla Sella (carla-sella) wrote :
Revision history for this message
Carla Sella (carla-sella) wrote :

Verified this happens both with Xmir and Xorg.

Revision history for this message
Sebastien Bacher (seb128) wrote :

thanks, that's an unity bug, you can use ctrl-alt-del to bring the logout dialog though

affects: lightdm (Ubuntu) → unity (Ubuntu)
summary: - missing session gear indicator in guest profile on Saucy
+ missing indicators in guest profile on Saucy
Revision history for this message
Sebastien Bacher (seb128) wrote : Re: unity-panel-service not running in non-upstart-sessions on Saucy

Seems like the issue is that unity-panel-service is not running in guest session, those don't seem to use upstart...likely a bug there

summary: - missing indicators in guest profile on Saucy
+ unity-panel-service not running in non-upstart-sessions on Saucy
Changed in unity (Ubuntu):
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
summary: unity-panel-service not running in non-upstart-sessions on Saucy
+ (including guest session)
Revision history for this message
Sebastien Bacher (seb128) wrote :

having it also affect lightdm, seems like DESKTOP_SESSION is not set in guest session, which leads to the issue

Revision history for this message
Stephen M. Webb (bregma) wrote :

Attatching a process status listing demontrating the problem.

Revision history for this message
Stephen M. Webb (bregma) wrote :

Further relevant information:

o Logging in with the Guest account from LightDM works OK
o Logging in with a user account works fine, then switching to the Guest account using the Gear indicator results in the described problem
o Logging in as Guest from LightDM then switching to the user account using the Gear indicator results in bug #1196314 and sometimes other indicator crashes, but otherwise works OK

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Ted Gould (ted)
Changed in lightdm:
status: New → Triaged
importance: Undecided → High
Changed in lightdm (Ubuntu):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Confirmed this is a regression in lightdm 1.7

Changed in lightdm:
assignee: nobody → Robert Ancell (robert-ancell)
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:lightdm at revision None, scheduled for release in lightdm, milestone Unknown

Changed in lightdm:
status: Triaged → Fix Committed
Changed in lightdm:
milestone: none → 1.7.18
status: Fix Committed → Fix Released
Changed in lightdm (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.7.18-0ubuntu1

---------------
lightdm (1.7.18-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Set session environment variables for guest sessions (1.7 regression).
      (LP: #1214504)
    - Don't fail writing X authority if reading it had an error. (LP: #1234400)
    - Update environment variables that we pass to Mir.
 -- Robert Ancell <email address hidden> Mon, 07 Oct 2013 11:57:02 +1300

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Ted Gould (ted)
Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers