Ubuntu

Unity Dash, left mouse button starts preview instead of directly the application

Reported by Fabio Marconi on 2013-06-09
190
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Ubuntu Manual Tests
High
Unassigned
Unity
High
Pawel Stolowski
unity (Ubuntu)
High
Pawel Stolowski

Bug Description

Left clicking on an application must launch that application.
Left clicking anything else must open the preview.

Release of Ubuntu:13.10
Package Version: unity 7.0.0daily13.06.07-0ubuntu1
Expected Results: app is started
Actual Results: preview is started

TESTCASE
-Open Dash
-Click an app
-Preview will open instead to launch the app

ProblemType: BugDistroRelease: Ubuntu 13.10
Package: unity 7.0.0daily13.06.07-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sun Jun 9 08:33:30 2013
DistUpgraded: 2013-05-01 20:34:06,287 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 open-vm-tools, 2013.04.16, 3.9.0-3-generic, x86_64: installed
 open-vm-tools, 2013.04.16, 3.9.0-4-generic, x86_64: installed
 vboxhost, 4.2.12, 3.9.0-2-generic, x86_64: installed
 vboxhost, 4.2.12, 3.9.0-3-generic, x86_64: installed
 vboxhost, 4.2.12, 3.9.0-4-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0042] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
InstallationDate: Installed on 2012-10-12 (239 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20121011)
MachineType: Gigabyte Technology Co., Ltd. H55M-S2H
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-13-generic root=UUID=874a505d-d121-4029-b543-ef8ce5fb9498 ro quiet splash vt.handoff=7SourcePackage: unity
UpgradeStatus: Upgraded to saucy on 2013-05-01 (38 days ago)
dmi.bios.date: 08/20/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7
dmi.board.name: H55M-S2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd08/20/2010:svnGigabyteTechnologyCo.,Ltd.:pnH55M-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnH55M-S2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: H55M-S2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.45-2ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.3-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.3-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.9-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Sun Jun 9 07:08:49 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input USB Keyboard KEYBOARD, id 8
 input USB Keyboard KEYBOARD, id 9
 input PIXART USB OPTICAL MOUSE MOUSE, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu10
xserver.video_driver: intel

Related branches

lp:~stolowski/unity/no-click-preview-for-apps
Merged into lp:unity at revision 3412
PS Jenkins bot: Approve (continuous-integration) on 2013-07-08
Brandon Schaefer: Approve on 2013-07-05
Unity Team: Pending requested 2013-07-03
Fabio Marconi (fabiomarconi) wrote :
description: updated
Exalm (exalm) wrote :

dconf write /com/canonical/unity/double-click-activate false

Seems to be an intended thing, but it's very confusing behavior.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Jason Robinson (jaywink) wrote :

Surely this _cannot_ be a design thing? It completely breaks app launching via the dash if it is...

Xavier Guillot (valeryan-24) wrote :

I also hope it is a bug, not a feature. Because now we always need one mouse click more + some cursor moving, just to launch an application !

Like Gnome, always more and more clicks, that's not usable ; and for some apps that I run every day but do not put on Unity dock (no more place and just a few minutes of use), I don't need to see every time the description, I know it.

Moreover, that's why we have several mouse buttons, no ? The previous behavior was : right click showed the preview, left one directly started the app.

Now it's too long : I used to type the first letters of the program, then used Enter key if icon was on the left, or left button to select my soft and immediately run it, I'm loosing some time with this new rule...

At least, if Ubuntu dev want to keep this configuration, please for common users put the option not only in dconf (which is unknown for most) but clearly in the System settings - Apparence.

summary: - dash, start preview instead the app
+ Unity Dash, left mouse button starts preview instead of directly the
+ application
eric (obrowny06) wrote :

I agree, I hardly understand this new behavior...
I understand they want the preview to be discovered and that the right click may seem hidden for newcomers but this should be fixed another way.
To launch an app from the dash, you need to double-click. or single click, move the mouse and click again.
From the launcher, a single click launches the app. Two different ways to do the same thing looks incoherent to me.

Most users won't discover that they can double click !

Maybe a slide in ubiquity could be enough to teach the right clic ?
Maybe a pop up menu could tell "right click for details" ?

Please fix this :-)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1189088

tags: added: package-qa-testing
nuttzo33 (slucas1979) wrote :

I agree with eric, you don't double click to open the apps from the launcher so you would expect the dash to be the same.

I think a slide with a basic unity introduction that pops up whenever a new user logs in for the first time is the way to go.

I think i could do a rough slide using a screen record utility despite never doing one before so why doesn't ubuntu include one?

Jason Robinson (jaywink) wrote :

Does anyone have any idea whether this is a bug or a design decision?

Xavier Guillot (valeryan-24) wrote :

According to a Unity developer on Ubuntu French forum, this is not a bug, but a design team decision:
http://forum.ubuntu-fr.org/viewtopic.php?pid=13824941#p13824941

IMHO it is a bad one. Canonical wants to unify Touch and desktop apps / appearance, it's fine, but please do not forget that on a computer we have the mouse (with several buttons) and let us use it with all functionalities !

Moreover, even since 13.04 where Dash is much faster, on some computers the app description is very long to open, so we are loosing time at each program startup.

Single click to launch from Unity dock, double from Dash which is a big change comparing to previous versions, this is not a complete uniform user experience...

Fabio Marconi (fabiomarconi) wrote :

Sound really stupid at me that Ubuntu cannot understand if it is placed on a desktopè or on touch device and set the Unity behavior in consequence.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ayatana-design:
status: New → Confirmed
tags: added: usability
Fabio Marconi (fabiomarconi) wrote :

Hallo John
I subscribe to clarify what's happening with this ^^.
Thanks
Fabio

Craig Hrabal (crhrabal) wrote :

I think, perhaps, a better solution would be to open web-based things in preview by default, and to open application-based things in a new application. That way, when utilizing smart scopes, you can view things on the web in the previews, but for application-management purposes, the users chooses when and when not to use preview.

Jason Robinson (jaywink) wrote :

This (http://www.omgubuntu.co.uk/2013/06/the-new-click-behaviour-in-the-dash) post by OMG! Ubuntu cleared a lot of thoughts for myself. Unsubscribing as this isn't really a bug but a design decision. Let's hope it will be a good one for Ubuntu. Personally will use the configuration option to change it to as it is in 13.04 :)

John Lea (johnlea) on 2013-06-17
Changed in ayatana-design:
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Won't Fix
John Lea (johnlea) wrote :

As discussed above, this change aligns the Dash interactions between pointer and touch. We will be testing this change (hence the gconf key) and then reviewing the best way forward in light of the testing results but for now this change aligns the pointer and touch interactions.

Yes there are tradeoffs, but double clicking to launch using a mouse/trackpad is a design pattern that has been about for many, many years.

Lets see how the testing goes.

John Lea (johnlea) wrote :

Marking "won't fix" for now.

christian (chmathieu) wrote :

Ok, the argument is valid, but. . . .

PLEASE, PLEASE, PLEASE, do not remove the settings for this feature !

description: updated
Nicholas Skaggs (nskaggs) wrote :

Depending on the outcome, the manual testcases for ubuntu need to be updated to confirm this behavoir

Changed in ubuntu-manual-tests:
status: New → Confirmed
Changed in ubuntu-manual-tests:
importance: Undecided → High
psypher (psypher246) wrote :

single left click/tap, launch app, long touch/single right click open preview. this is not a good change, please make something simpler as default and add the ability to change to something else as an option.

Goal was to preview everything other than apps. Left click on an
installed app should just launch it.

Mark

Omer Akram (om26er) on 2013-07-01
Changed in unity (Ubuntu):
status: Won't Fix → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → 7.1.0
description: updated
Xavier Guillot (valeryan-24) wrote :

Great news that the bug will be corrected for installed programs and left click launch them directly.

A little remark : having preview by default for all other cases (online search...) is logical.

For documents, even if behavior is also changed, it is coherent with global user experience as Dash will be used both for search on name, activity (Zeitgeist) and content (with Recoll lens for example). So preview is useful if we don't know where the file is stored, as we can open the right folder from Dash with this document selected in Nautilus, or send by mail, or just open the document.

But for the folders, it seems incomplete : we only have folder icon and the "Open" button, so preveiw is not very useful. I suggest adding some options and buttons, like:

- Properties: it would open Nautilus properties window with information on content, location, free space... Size and number of elements are already displayed in preview, perhaps location could be, too (also for documents).

- Copy: to copy the folder which could be then pasted

- Backup: save the folder in Ubuntu One or open Deja Dup for adding it to the configuration...

Last, for documents, with images or pdf in the Dash preview we have a thumbnail of the photo or first page real content, will it ba also available in the future for text, LibreOffice, video files ?

Sorry, this is not completely related to current bug, more perhaps for the hundred papercuts projects, but this discussion and modification of preview made me think to that.

Changed in unity:
assignee: nobody → Pawel Stolowski (stolowski)
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package unity - 7.0.2+13.10.20130723.1-0ubuntu1

---------------
unity (7.0.2+13.10.20130723.1-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/control:
    - build-depend on xserver-xorg-video-dummy and libgl1-mesa-dri
    - build-depend on libnux-4.0-dev (>= 4.0.2+13.10.20130718.1)

  [ Michal Hruby ]
  * When requesting a channel from scopes, use the DIFF flag, which will
    cause scopes machinery to do a diff between the old and new model
    states, so results that didn't change will stay in the model -
    previously they would be removed and re-added.
  * Reset the connected property when scope disappears.
  * Added getter for content-type property to Category class.
  * Manually merged lp:~mhr3/unity/fix-ap-preview-tests
  * Preload results after removal, as they might got moved into a
    visible position.
  * Fix scope-related tests. (LP: #1199961)

  [ Brandon Schaefer ]
  * Correctly set back the filter scroll views state when
    leaving/entering the scope view. (LP: #1175666)
  * Don't calculate the velocity if dtime is 0. This way we don't get a
    huge velocity on the initial barrier hit. (LP: #1199050)
  * Show desktop now only works for individual workspaces. Also if any
    new windows are opened, or one is restored on that workspace then
    the next Show desktop will minimize those. The only time windows are
    restored are when no new windows have been mapped, and no windows
    have been restored for that workspace only. (LP: #966030)

  [ Marco Trevisan (Treviño) ]
  * CMake: re-enable DBus Tests, excluding TestScope* This exclusion is
    due to lp:1199961 to be fixed ASAP. (LP: #1199961, #1199962)
  * TestGtest: Addedd TestPanelService and new tests to
    TestStaticCairoText, removed test-unit Improved the u-p-s stability
    and refactored a little its initialization to allow testing with
    only mock indicators. (LP: #1200748)
  * GLibDBusServer: set the proper destroy function when resetting the
    InterfaceInfo ptr.

  [ Didier Roche ]
  * Adjust CMake setup to account for new GMock version. . (LP:
    #1185265)

  [ Chris Townsend ]
  * Modify the Launcher icon of an installing app to display
    "Installing..." instead of always saying "Waiting to install". (LP:
    #966189)

  [ Thomas Voß ]
  * Adjust CMake setup to account for new GMock version. . (LP:
    #1185265)

  [ Nick Dedekind ]
  * Removed the legal link and icon from the dash. .
  * Reverted r3415 "remove legal link" -
  * Removed the legal icon, again.

  [ Manuel de la Pena ]
  * Fix the introspection so that QA can work with autopilot. (LP:
    #1185486)

  [ Charles Kerr ]
  * in panel-service.c's load_indicators_from_indicator_files(), plug a
    GDir leak.

  [ Pawel Stolowski ]
  * Activate (installed) applications on single left-click in Home and
    Applications scopes view. (LP: #1189088)

  [ Andrea Azzarone ]
  * Define/Init UnityWindow::cWindow. (LP: #1203129)

  [ Jeremy Bicha ]
  * Drop unnecessary python-gconf dependency.

  [ Łukasz 'sil2100' Zemczak ]
  * Disable the TestAnimationOpacity test, as it's failing on powerpc.

  [ Ubuntu daily release ]
  * Automatic snapshot from ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released
Fabio Marconi (fabiomarconi) wrote :

Fix verified.
Thanks again one time guys.
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: done verification
tags: added: verification-done
removed: done verification
Changed in ubuntu-manual-tests:
status: Confirmed → Fix Released
Sb (sb56637) wrote :

Oh no, for files PLEASE don't force an extra step on users just to open a known file. Left clicking should ALWAYS open anything clicked, and right clicking should ALWAYS preview it. It would be terribly clumsy to have to wade through previews of files that are already well known to the user when he just wants to open the stinking file.

Mark Shuttleworth (sabdfl) wrote :

Sb, we have extensive user testing to rely on which revealed that in
many cases users have a few variations of a file. The preview mechanism
helps to differentiate between those. I understand your position but
it's based on a simplistic first-pass view. The guidance is that click
launches installed apps and previews everything else.

Mark

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers