compiz crashed with SIGSEGV in g_object_unref() from unity::bamf::Application::~Application()

Bug #1181717 reported by Lockal on 2013-05-19
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Marco Trevisan (Treviño)
Unity
Fix Released
Critical
Andrea Azzarone
unity (Ubuntu)
Critical
Andrea Azzarone
Raring
Undecided
Unassigned
Saucy
Critical
Andrea Azzarone

Bug Description

When logging in, Unity does not finish loading. No indicators appear but the desktop icons will.

Not sure how to reproduce, but the stack trace may indicate in which circumstances it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: unity 7.0.0daily13.04.18~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-2.6-generic 3.9.2
Uname: Linux 3.9.0-2-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.10.1-0ubuntu1
Architecture: amd64
Date: Sun May 19 14:45:22 2013
ExecutablePath: /usr/bin/compiz
InstallationDate: Installed on 2012-02-05 (468 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
MarkForUpload: True
ProcCmdline: compiz --replace
SegvAnalysis:
 Segfault happened at: 0x7f4f9e8aae04 <g_object_unref+20>: cmpq $0x50,(%rax)
 PC (0x7f4f9e8aae04) ok
 source "$0x50" ok
 destination "(%rax)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 g_object_unref (_object=0x202eae0) at /build/buildd/glib2.0-2.37.0/./gobject/gobject.c:3081
 unity::bamf::Application::~Application() () from /usr/lib/compiz/libunityshell.so
 unity::bamf::Application::~Application() () from /usr/lib/compiz/libunityshell.so
 std::_Sp_counted_base<(__gnu_cxx::_Lock_policy)2>::_M_release() () from /usr/lib/compiz/libunityshell.so
 unity::launcher::ApplicationLauncherIcon::~ApplicationLauncherIcon() () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in g_object_unref()
UpgradeStatus: Upgraded to saucy on 2013-05-19 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Lockal (lockal) wrote :
Lockal (lockal) on 2013-05-19
information type: Private → Public

StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /tmp/apport_sandbox_HjAs9U/usr/lib/gcc-snapshot/lib/libstdc++.so.6
 ?? ()
 unity::bamf::Application::~Application() () from /tmp/apport_sandbox_HjAs9U/usr/lib/compiz/libunityshell.so

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
tags: added: need-amd64-retrace

StacktraceTop:
 g_object_unref (_object=0x202eae0) at /build/buildd/glib2.0-2.37.0/./gobject/gobject.c:3081
 unity::bamf::Application::~Application() () from /tmp/apport_sandbox_CwYyxj/usr/lib/compiz/libunityshell.so
 unity::bamf::Application::~Application() () from /tmp/apport_sandbox_CwYyxj/usr/lib/compiz/libunityshell.so
 std::_Sp_counted_base<(__gnu_cxx::_Lock_policy)2>::_M_release() () from /tmp/apport_sandbox_CwYyxj/usr/lib/compiz/libunityshell.so
 unity::launcher::ApplicationLauncherIcon::~ApplicationLauncherIcon() () from /tmp/apport_sandbox_CwYyxj/usr/lib/compiz/libunityshell.so

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Package: unity 7.0.0daily13.04.18~13.04-0ubuntu1
ProcCmdline: compiz --sm-client-id 1094a19fdf1aaee48f136505634181450900000038250047

tags: removed: apport-failed-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1181717

tags: added: iso-testing
Steve Langasek (vorlon) wrote :

Bumping this to critical; compiz has been completely unstable for me in saucy, crashing multiple times per day.

Changed in unity (Ubuntu):
importance: Medium → Critical
Steve Langasek (vorlon) wrote :

Some analysis on #ubuntu-devel today suggests this may be a reference counting bug somewhere in the unity stack that has been exposed by refcount fixes in the new version of glib2.0 found in saucy.

Colin Watson points out a similar issue was fixed in ubiquity 2.15.3.

ubiquity (2.15.3) saucy; urgency=low

  * Increment reference count on address before returning it from
    ubiquity_mock_resolver_lookup_by_name_finish, fixing a segfault in the
    test suite.

 -- Colin Watson <email address hidden> Wed, 15 May 2013 22:22:07 +0100

Steve Langasek (vorlon) wrote :

On errors.ubuntu.com this is <https://errors.ubuntu.com/problem/10d5e9a86a0f811a645c6fd60ca2dc94bf3c0462>, the second most frequent crash on 13.10.

Steve Langasek (vorlon) wrote :

(It is *also* <https://errors.ubuntu.com/problem/54c4289bbf826142a957109bf9ae182b1e0c3f5b>, the fourth most frequent crash on 13.10.)

Fabio Marconi (fabiomarconi) wrote :

Same behavior of Steve:
StacktraceTop:
 g_object_unref (_object=0x375a390) at /build/buildd/glib2.0-2.37.0/./gobject/gobject.c:3081
 ~View (this=0x310b1e8, __in_chrg=<optimized out>) at /build/buildd/unity-7.0.0daily13.04.18~13.04/unity-shared/../unity-shared/BamfApplicationManager.h:34
 unity::bamf::Application::~Application (this=0x310b010, __in_chrg=<optimized out>) at /build/buildd/unity-7.0.0daily13.04.18~13.04/unity-shared/../unity-shared/BamfApplicationManager.h:105
 unity::bamf::Application::~Application (this=0x310b010, __in_chrg=<optimized out>) at /build/buildd/unity-7.0.0daily13.04.18~13.04/unity-shared/../unity-shared/BamfApplicationManager.h:105
 std::_Sp_counted_base<(__gnu_cxx::_Lock_policy)2>::_M_release (this=0x3846080) at /usr/include/c++/4.7/bits/shared_ptr_base.h:147
Tags: saucy saucy ubuntu compiz-0.9
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Andrea Cimitan (cimi) wrote :

I can reproduce it systematically refreshing the gmail page in firefox with unity webapp. Maybe it triggers some bamf destructions thus the crash

Andrea Azzarone (azzar1) on 2013-05-29
Changed in unity:
importance: Undecided → Critical
status: New → Triaged
Andrea Cimitan (cimi) wrote :

FYI it's unrelated to webapps because I think I just had it without (didn't check with the stacktrace, but sounds the same bug)

Stephen M. Webb (bregma) on 2013-05-30
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2013-06-01
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Saucy):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 7.1.0
Changed in unity (Ubuntu Saucy):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-06-01
Changed in unity (Ubuntu Saucy):
status: In Progress → Fix Committed
summary: - compiz crashed with SIGSEGV in g_object_unref()
+ compiz crashed with SIGSEGV in g_object_unref() from
+ unity::bamf::Application::~Application()
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu Saucy):
status: Fix Committed → Fix Released
Changed in bamf:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 0.5.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision 547, scheduled for release in bamf, milestone 0.5.0

Changed in bamf:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Raring):
status: New → Confirmed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released

Fix Released in Bamf BAMF 0.5.0.

Changed in bamf:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers