fcitx often fails to work in dash with Unity

Bug #1175669 reported by Boyuan Yang on 2013-05-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Brandon Schaefer
Unity
Invalid
Medium
Brandon Schaefer
nux (Ubuntu)
Medium
Brandon Schaefer
Saucy
Undecided
Unassigned
unity (Ubuntu)
Medium
Brandon Schaefer

Bug Description

The input method "fcitx' is supposed to work with Unity dash in raring,but it is not working well.
This happens *only* when I set the launcher to hide as default.
When I press Super to open the dash and begin to type characters into dash or HUD display (by pressing left alt),sometimes I can activate the input method.In more cases,there aren't any response when pressing "ctrl+space".Sometimes I can't type anything into dash.

I've asked a developer of fcitx ("csslayer") but he said he knew nothing about it.He said it could be a bug of unity and suggested me to report the bug here.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 7.0.0daily13.04.18~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu May 2 23:51:07 2013
InstallationDate: Installed on 2012-05-01 (365 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: Upgraded to raring on 2013-04-03 (28 days ago)

Related branches

Boyuan Yang (hosiet) wrote :
Boyuan Yang (hosiet) on 2013-05-03
description: updated
metalbrick (metalbrick) wrote :

This affects me too.
And one of the debug output of unity goes like this,

"ERROR 2013-05-12 00:54:41 unity.glib-gobject <unknown>:0 g_object_unref: assertion `G_IS_OBJECT (object)' failed"

When Fcitx is not running the problem won't occur, I think this is no simply a bug of unity.

csslayer (wengxt) wrote :

it seems that this bug can be triggered easily if launcher is set to autohide.

So there might be a focus related bug in unity. Like launcher grab the focus from the dash, so xim doesn't work correctly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-08-12
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Brandon Schaefer (brandontschaefer)
milestone: none → 7.1.3
Stephen M. Webb (bregma) on 2013-10-10
Changed in unity:
milestone: 7.1.3 → 7.2.0

@ccslayer

This is what im thinking...as the launcher use to steal the X focus from the Dash/Hud... so if its missing possibly something else is stealing X focus. Though since XIM support landed the Dash/Hud should be the ones with X focus. Will take a look into it.

Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress

Also i can only get the dash to fail, the hud works for me.

Problem was when the launcher was hidden, an async message saying the dash opened was coming through. The dash would enable input, setting X focus, and XIC focus. When the async message got to the launcher, it being hidden, then has to reveal it self and when it does that it needs to enable its input window so it accepts drag and drop from the dash and events work on it.

The solution now, make sure we sync xevent focus and XIC focus. That is, if a window is shown in nux it would change the XIC, but xevents are still being sent to the dashes window (well really generated for), which the XIC and the xevent would become out of sync. This means XFilterEvent would just return instead of passing the event to the current IM (the problem!).

Now we just make sure both are synced so if unity tries to stomp on the focus things will work out :).

Changed in nux (Ubuntu):
status: New → In Progress
Changed in nux:
status: New → In Progress
importance: Undecided → Medium
Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in nux:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: In Progress → Invalid
Changed in unity (Ubuntu):
status: In Progress → Invalid
Changed in nux (Ubuntu):
status: Invalid → In Progress
Changed in unity:
status: In Progress → Invalid
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:nux at revision None, scheduled for release in nux, milestone 4.0.4

Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: 7.2.0 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.5+14.04.20140214-0ubuntu1

---------------
nux (4.0.5+14.04.20140214-0ubuntu1) trusty; urgency=low

  [ Brandon Schaefer ]
  * Add XIM preedit support
  * Bump version to 4.0.5
  * We need to check if the XIC client is synced up with the xevents
    coming in. If someone changes the focus window and our XIC hasn't
    been updated, we need to make sure we stay synced. Otherwise XIM
    fails to work. (LP: #1175669)

  [ CI bot ]
  * Flush trunk to Ubuntu

  [ Chris Townsend ]
  * Need to add version 1.10 of lcov to the supported versions so the
    Debian package build can succeed.

  [ Eleni Maria Stea ]
  * added virtual destructors where missing (fixing static analysis
    errors).
  * small fixes based on clang errors and warnings.
  * fixed syntax error in macro.
  * minor fixes (static analyzer errors and warnings).

  [ Albert Astals ]
  * Kill declared but not implemented functions.

nux (4.0.4-0ubuntu1) UNRELEASED; urgency=low

  [ Sam Spilsbury ]
  * Bump version to 4.0.4.
 -- Ubuntu daily release <email address hidden> Fri, 14 Feb 2014 23:11:31 +0000

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu Saucy):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in nux (Ubuntu Saucy):
status: Confirmed → Won't Fix
Stephen M. Webb (bregma) on 2015-08-12
Changed in nux:
status: Fix Committed → Fix Released

Has it been fixed?
It's the same as usual on Ubuntu 16.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers