Unity doesn't work with ATI RV730/M96 [Mobility Radeon HD 4650/5165] in 13.04

Bug #1173158 reported by Beowulf on 2013-04-26

This bug report was converted into a question: question #227543: Unity doesn't work with ATI RV730/M96 [Mobility Radeon HD 4650/5165] in 13.04.

12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to 13.04 Unity stopped working, the launcher doesn't show up on the screen. Gnome fallback and xfce4 work.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 7.0.0daily13.04.18~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: None
Date: Fri Apr 26 15:11:36 2013
DistUpgraded: 2013-04-26 14:09:50,260 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 6.20.155.1+bdcom, 3.5.0-27-generic, x86_64: installed
 bcmwl, 6.20.155.1+bdcom, 3.8.0-19-generic, x86_64: installed
 fglrx-legacy, 8.97.100.7, 3.5.0-27-generic, x86_64: installed
 virtualbox, 4.2.10, 3.5.0-27-generic, x86_64: installed
 virtualbox, 4.2.10, 3.8.0-19-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RV730/M96 [Mobility Radeon HD 4650/5165] [1002:9480] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3624]
InstallationDate: Installed on 2012-05-11 (349 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Hewlett-Packard HP Pavilion dv7 Notebook PC
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=246998be-2cd0-44bf-84ed-f543cab86250 ro quiet splash vt.handoff=7
SourcePackage: unity
UnitySupportTest:
 Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code 1: X Error of failed request: BadRequest (invalid request code or no such operation)
   Major opcode of failed request: 138 (ATIFGLEXTENSION)
   Minor opcode of failed request: 66 ()
   Serial number of failed request: 23
   Current serial number in output stream: 23
UpgradeStatus: Upgraded to raring on 2013-04-26 (0 days ago)
dmi.bios.date: 08/25/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.46
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3624
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 18.51
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.46:bd08/25/2011:svnHewlett-Packard:pnHPPaviliondv7NotebookPC:pvrRev1:rvnHewlett-Packard:rn3624:rvr18.51:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv7 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 3:1.12.4+git20121105-makson1~ppa2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 2:2.7.3+git20120928~quantal2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 2:6.14.6+git20120928~quantal1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 3:2.20.8+git20120928~quantal2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 2:1.0.2+git20120928~quantal1
xserver.bootTime: Fri Apr 26 15:01:06 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:
 fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
 fglrx(0): XMM failed to open CMMQS connection.(EE) fglrx(0):
 fglrx(0): XMM failed to initialize
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 3:1.12.4+git20121105-makson1~ppa2
xserver.video_driver: fglrx

Beowulf (s-highlander) wrote :
Beowulf (s-highlander) wrote :

I fixed the problem by typing the two commands into the terminal window

dconf reset -f /org/compiz/
unity --reset-icons &disown

Daniel Letzeisen (dtl131) wrote :

This is not a bug with Ubuntu or Unity. Raring/13.04 does not support the fglrx/Catalyst legacy driver. You are using a 3rd party PPA, and the fglrx-legacy driver is not installed correctly for the 3.8.x kernel, which breaks 3D aceeleration, and thus, Unity.

Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity (Ubuntu):
status: Invalid → New
Daniel Letzeisen (dtl131) wrote :

@Marco: If you're having issues with Unity and the open-source radeon driver, please file a new bug. Otherwise, read what I wrote in comment #3.

Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity:
status: New → Invalid
To post a comment you must log in.