Ubuntu minimum system requirements needs to be updated

Bug #1166124 reported by Salih EMIN on 2013-04-08
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The specified minimum system requirements do not represent reality.
According to https://help.ubuntu.com/community/Installation/SystemRequirements Ubuntu desktop needs :

* 700 MHz processor (about Intel Celeron or better)
* 512 MiB RAM (system memory)
* 5 GB of hard-drive space (or USB stick, memory card or external drive but see LiveCD for an alternative approach)
* VGA capable of 1024x768 screen resolution

With the latest technologies introduced by Unity, not only the above is illogical but also, diminishes any chance of a good desktop experience with Ubuntu.

Also if we take into consideration the tests that have been form https://wiki.ubuntu.com/DemystifyingUnityGraphicsHardwareRequirements it is obvious that for at least a bearable experience, a user will need :

* 1000 ΜHz processor (about Intel Celeron or better)
* 1024 MiB RAM (system memory)
* 3D Acceleration Capable Videocard with at least 256 MB

From experience, we all know that it is recommended to have 2048 MiB RAM to properly run a day to day Ubuntu.

A good start should be with minimum 1024 and recommended 2048 MiB RAM.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.18.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-26.42~precise1-generic 3.5.7.6
Uname: Linux 3.5.0-26-generic i686
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Apr 8 12:55:26 2013
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release i386 (20130213)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Salih EMIN (salih-emin) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in ubuntu-website-content:
status: New → Confirmed
Changed in ubuntu-website-content:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-website-content:
status: Invalid → Opinion
Changed in unity (Ubuntu):
status: Invalid → Opinion
Changed in ubuntu-website-content:
status: Opinion → Incomplete
status: Incomplete → Opinion
Salih EMIN (salih-emin) wrote :

Do not change the status of a bug if you are not the admin of a package.

Changed in ubuntu-website-content:
status: Opinion → Confirmed
Changed in unity (Ubuntu):
status: Opinion → Confirmed

@drpaneas
The page really needs to be updated.

Today, the *Recommended* Minimum System Requirements (just check the wiki page [1]) are lower than in 2010 [2]. This doesn't make sense, specially after unity.

It also states that "machines that could run XP [..] will almost always be a lot faster with Ubuntu", which is not true. Windows XP runs reasonably well with 128MB of RAM (this is almost what the compiz process consumes alone - 104MB now in my machine).

I'm not saying the specs in the bug description are right, but the bug is valid (just read the title).

[1] https://help.ubuntu.com/community/Installation/SystemRequirements
[2] https://help.ubuntu.com/community/Installation/SystemRequirements?action=recall&rev=40

Salih EMIN (salih-emin) on 2013-04-09
description: updated
N1ck 7h0m4d4k15 (nicktux) wrote :

Well , guys we struggle here with a page that is just a WIKI PAGE.

@Salih EMIN the description needs an update (again).

This is the correct page to report a bug for (The Official Documentantion)
https://help.ubuntu.com/12.04/installation-guide/i386/minimum-hardware-reqts.html

The WIKI PAGE can be updated by anyone who has a Launchpad account (Signle Sign On)
Just LOGIN and EDIT the page.

Salih EMIN (salih-emin) wrote :

@NikTh, according to that page, things are getting even messier :)

The following days I will investigate even farther, because as I see it, there is no one solid page with recommendation or minimum specs for Ubuntu Desktop (the default Ubuntu) and I shall update the description. Any help on this is really appreciated !

Probably the wiki page should be updated according to 12.10 release notes in https://wiki.ubuntu.com/QuantalQuetzal/ReleaseNotes/UbuntuDesktop#System_Requirements

And the official help is even worse than the wiki... The (correct?) minimum requirements for 12.04 are also on release notes https://wiki.ubuntu.com/PrecisePangolin/ReleaseNotes/UbuntuDesktop#System_Requirements

terryman (terryman-gr) wrote :

I just did a test with Oracle VM Virtual Box. I adjust the virtual machine to the minimum requirements

* 700 MHz processor (about Intel Celeron or better)
* 512 MiB RAM (system memory)
* 5 GB of hard-drive space

and installed Ubuntu 12.10.

The installation was fine, but when I first boot in to the system, and during an upgrade, I got a message that compiz closed and there is not enough memory to automatically analyze the problem. See this picture http://img600.imageshack.us/img600/6108/ubuntubug.png

The problem might be that the installation is on a Virtual Box, but I had installed Ubuntu many times in VB (with better specifications of course) and I never had a problem.

Besides the problem I run to, I believe that the above minimum requirements does not make Ubuntu usable as it is stated here: https://help.ubuntu.com/community/Installation/SystemRequirements

Chris Johnston (cjohnston) wrote :

help.ubuntu.com bugs don't belong to ubuntu-website-content.

affects: ubuntu-website-content → ubuntu-docs
Salih EMIN (salih-emin) wrote :

@Chris Johnston, thank you for taking time point us the right direction for this bug.

<offtopic>
I can't find anywhere, on the ubuntu.com page any Minimum/Recommended System requirements for Ubuntu Desktop. Am I missing something or there is no such thing ?
</offtopic>

Scott Ritchie (scottritchie) wrote :

Please note that we also need to update the printed text on the Canonical-printed CDs themselves, they're even more out of date and unrealistic. Pinging Colin Watson.

Stephen M. Webb (bregma) on 2013-08-07
Changed in unity:
status: New → Confirmed
Changed in ubuntu-docs:
status: Confirmed → In Progress
assignee: nobody → Svetlana Belkin (belkinsa)
Changed in ubuntu-docs:
status: In Progress → Fix Committed
Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Benjamin Kerensa (bkerensa) wrote :

@Svetlana

How is this issue fixed? I still see low-end system requirement specs which would not provide a user friendly experience on Ubuntu. I suggest we ask the Ubuntu Desktop or Community Team to look into this and provide us with more specific system requirements that would give a basic experience.

I know the specs currently offered would not cut it.

Benjamin Kerensa (bkerensa) wrote :

@Alan or @Michael Hall,

Could one of you brief the doc team as to what a reasonable base system requirement for Ubuntu is... Has Canonical done any benchmarking and user testing to try and find a good match on system reqs?

Svetlana Belkin (belkinsa) wrote :

@Ben

I agree, I only added what the person said under where I thought where it should go.

We could probably crowd source this information. A simple google spreadsheet questionnaire which asks for ubuntu release cpu/ram/gpu model and the main 5 apps used, along with the results of running a simple desktop (not gaming) benchmark might be useful here.

Changed in ubuntu-docs:
assignee: Svetlana Belkin (belkinsa) → nobody
N1ck 7h0m4d4k15 (nicktux) wrote :

This bug has been fixed in ubuntu-docs

Changed in ubuntu-docs:
status: Fix Committed → Fix Released

There is no need to preserve it as confirmed in Unity project.

As part of the bug clean up ahead of 16.04 LTS I'm marking this as invalid.
If you think this is still valid for Unity Project, please comment on why that is the case and change the status to NEW.

Regards
NickTh

Changed in unity:
status: Confirmed → Invalid
N1ck 7h0m4d4k15 (nicktux) wrote :

This bug has been fixed in ubuntu-docs

Changed in ubuntu-docs:
status: Fix Committed → Fix Released

There is no need to preserve it as confirmed in Unity project.

As part of the bug clean up ahead of 16.04 LTS I'm marking this as invalid.
If you think this is still valid for Unity Project, please comment on why that is the case and change the status to NEW.

Regards
NickTh

Changed in unity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers