compiz crashed with SIGSEGV in sigc::internal::slot_call0<unity::launcher::VolumeImp::Impl::Impl()

Bug #1161916 reported by chrisle on 2013-03-29
This bug affects 305 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

- started after today update 29.03.2013

- while working with nautilus

- graphic card is built in intel ivy bridge on a Lenovo Thinkpad L430

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: unity 6.12.0daily13.03.29-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
Uname: Linux 3.8.0-15-generic i686
ApportVersion: 2.9.2-0ubuntu5
Architecture: i386
Date: Fri Mar 29 15:21:34 2013
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationDate: Installed on 2012-09-22 (188 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120905.2)
MarkForUpload: True
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb1ebfddf <_ZN4sigc8internal10slot_call0IZN5unity8launcher9VolumeImp4ImplC1ERKNS2_4glib6ObjectI8_GVolumeEERKSt10shared_ptrINS2_11FileManagerEERKSC_INS3_25DeviceNotificationDisplayEEPS4_EUlvE1_vE7call_itEPNS0_8slot_repE+31>: mov (%edi),%edx
 PC (0xb1ebfddf) ok
 source "(%edi)" (0x00000001) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 sigc::internal::slot_call0<unity::launcher::VolumeImp::Impl::Impl(unity::glib::Object<_GVolume> const&, std::shared_ptr<unity::FileManager> const&, std::shared_ptr<unity::launcher::DeviceNotificationDisplay> const&, unity::launcher::VolumeImp*)::{lambda()#3}, void>::call_it(sigc::internal::slot_rep*) () from /usr/lib/compiz/libunityshell.so
 unity::GnomeFileManager::Impl::OnOpenLocationsUpdated(_GVariant*) () from /usr/lib/compiz/libunityshell.so
 std::function<void (_GVariant*)>::operator()(_GVariant*) const () from /usr/lib/libunity-core-6.0.so.5
 unity::glib::DBusProxy::Impl::OnPropertyChanged(_GDBusProxy*, _GVariant*, char***) () from /usr/lib/libunity-core-6.0.so.5
 std::_Function_handler<void (_GDBusProxy*, _GVariant*, char***), sigc::bound_mem_functor3<void, unity::glib::DBusProxy::Impl, _GDBusProxy*, _GVariant*, char***> >::_M_invoke(std::_Any_data const&, _GDBusProxy*, _GVariant*, char***) () from /usr/lib/libunity-core-6.0.so.5
Title: compiz crashed with SIGSEGV in sigc::internal::slot_call0<unity::launcher::VolumeImp::Impl::Impl()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo wireshark

Related branches

lp:~3v1n0/unity/volume-imp-filemanager-crash-fix
PS Jenkins bot: Approve (continuous-integration) on 2013-04-03
Andrea Azzarone: Approve on 2013-04-03
chrisle (chrisle) wrote :
Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
chrisle (chrisle) on 2013-03-29
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
userDepth (markonuvo) wrote :

Intel® Ironlake Mobile , experience Standard. I was using Nautilus and when I clicked a NTFS partition to navigate the contents then I got this crash. And Unity restarted.

Achim Behrens (k1l) wrote :

i got the same but with nvidia-current using

userDepth (markonuvo) wrote :

Again while navigating a NTFS partition crash ocurred.

chrisle (chrisle) wrote :

@ checoimg

Can you reproduce this bug, how ?

I also used an external ntfs drive while the crash occured.

description: updated
userDepth (markonuvo) wrote :

I unmounted and mounted the partition and got the bug again along with another.

Abhisek Mukherjee (abhisek) wrote :

Mount and unmount an external drive ( I used a FAT32 usb thumb formatted on OS X) and the bug repeats itself

Mark Bennison (mark-bennison) wrote :

For me this happened when I "safely removed" a USB memory stick - much like Abhisek

dc (darkcharl) wrote :

For me mounting an iscsi device triggered this bug (on 64 bit platform).

Every time I insert a cd rom compiz crashes while cd rom is being mounted.

userDepth (markonuvo) wrote :

This bug happens every 7 out of 10 while mounting.

Doug McMahon (mc3man) wrote :

While this is has gotten worse of late, particularly when removing usb drives, seems to have first occurred here with unity_6.12.0daily13.03.25.(1),
Not sure if the 25 .1 or just .25 release.
unity_6.12.0daily13.03.20 has no such issues here.

ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DistroRelease: Ubuntu 13.04
InstallationDate: Installed on 2013-01-26 (65 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
Package: unity 6.12.0daily13.03.29.1-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
Tags: third-party-packages raring
Uname: Linux 3.8.0-15-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-01-26 (64 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

tags: added: apport-collected third-party-packages

apport information

apport information

Changed in unity (Ubuntu):
importance: Medium → High
Doug McMahon (mc3man) wrote :

The issues here start with r3253 (GLibDBusProxy: add support for reading, setting and monitoring properties

Vincent Gerris (vgerris) wrote :

Not sure if I have this error, but I got automatically directed here :).
I have a Dell D630 with NVidia Quadro NVS 135M .

Jorge Rivera (gio107) wrote :

Affects me on a Sony VAIO T Series Ultrabook

I got this bug after connecting a Samsung Galaxy Nexus phone to the USB port.

Guy Stone (stoneguy3) wrote :

During safe removal of USB key in VBox VM

debb1046 (debb1046) wrote :

Get this on Raring when opening Dropbox

Doug McMahon (mc3man) wrote :

marking as a dupe - *no need* for subscibers here to comment there that it affects this or that while doing this or that..

Changed in unity:
importance: Undecided → Critical
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.0.1
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1161916

tags: added: iso-testing
Changed in unity:
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
pinbo (zhjl86) wrote :

When I was working with Nautilus, change or close folder made the unity to restart.
My laptop is Thinkpad T510.

Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

aloks.jnu (aloks-jnu) on 2013-04-04
description: updated
Msirdian (arena7) wrote :

afected me

userDepth (markonuvo) wrote :

After adding a PPA line ( ppa:xorg-edgers/ppa ) and update today 2013/04/05 16:46, I can mount and unmount without this crash.

userDepth (markonuvo) wrote :

Got the crash again at 16:49

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.04.05.2-0ubuntu1

---------------
unity (7.0.0daily13.04.05.2-0ubuntu1) raring; urgency=low

  * Revert r3266 "Don't close the dash when switching from the command lens
    to the home lens.", it's breaking dash closing for individual lens,
    which also result in a serie of failing tests (lp: #1164915)

  [ Stephen M. Webb ]
  * Bumped released version to 7.0.0

  [ Brandon Schaefer ]
  * Invalid Dnd is not being ingored in the launcher. (LP: #1163473)
  * Dash Overlay scrollbars should allow dragging, until the scrollbars
    themselfs hit the top/end of the track. (LP: #1163616)
  * [regession] Multi-monitor: Mousepointer hangs when passing between
    monitors, although no Launcher is there. (LP: #1161726)
  * The dash closes when trying to switch from Command lens to home lens
    (LP: #1108956)

  [ Chris Townsend ]
  * Need to tweak the icon glow for urgent apps (LP: #1163944)

  [ Andrea Azzarone ]
  * Window management - grab icons appear when using touchpad (LP:
    #1026712)

  [ Marco Trevisan (Treviño) ]
  * compiz crashed with SIGSEGV in
    sigc::internal::slot_call0<unity::launcher::VolumeImp::Impl::Impl()
    (LP: #1161916)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3279
 -- Ubuntu daily release <email address hidden> Fri, 05 Apr 2013 14:51:53 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Atom Stark (atomstark) wrote :

Got the crash 5 minutes ago although my system is up to date and the installation has less than 1 hour.

userDepth (markonuvo) wrote :

crash stopped on version 7.0.0

Charles Ford (charlesford42) wrote :

mounting and unmounting during USB laptop testcase using 7th generation ipod classic

crash repeats itself

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/1161916

tags: added: laptop-testing
nofallyaqoo (michaelshlamatho) wrote :

@Atom Stark (atomstark)

exactly like me, i just installed ubuntu 13.04 beta2 and after FIRST login to desktop this crash happend to me too :(

Stephen M. Webb (bregma) wrote :

Released in Unity 7.1.0

Changed in unity:
status: Fix Committed → Fix Released
milestone: 7.0.1 → none
Changed in unity:
milestone: none → 7.1.0
To post a comment you must log in.