HUD does not show up over fullscreen window

Bug #1159249 reported by Ben Aceler on 2013-03-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
7.2
Fix Released
Medium
Stephen M. Webb
unity (Ubuntu)
Medium
Andrea Azzarone
Nominated for Trusty by Stephen M. Webb
Trusty
Medium
Stephen M. Webb

Bug Description

[Impact]

The HUD was not being rendered above fullscreen windows although it would grab the keyboard.

[TEST CASE]

1. Open some site in firefox

2. Go to fullscreen mode (F11)

3. Press "Alt" once.

4 The HUD should appear and you should be able to interact with it.

[REGRESSION POTENTIAL]

No known regression potential.

[OTHER INFO]

The fix for Ubuntu 14.04 LTS was cherry picked from the Ubuntu "Vivid Vervet" dev release where it has been in production use for some time without apparent regression.

Related branches

Ben Aceler (aceler) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
theghost (theghost) wrote :

Confirmed here for Saucy / 13.10.

tags: added: saucy
Changed in unity:
status: New → Confirmed
Andrea Azzarone (azzar1) on 2014-12-19
Changed in unity:
importance: Undecided → High
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 7.3.1
Stephen M. Webb (bregma) on 2015-01-06
Changed in unity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20150115-0ubuntu1

---------------
unity (7.3.1+15.04.20150115-0ubuntu1) vivid; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Andrea Azzarone ]
  * Disable Pointer Barriers during lockscreen. (LP: #1401911)
  * Use std::weak_ptr to avoid referencing an invalid barrier. (LP:
    #1238063)
  * Enable dash and hud if there is a fullscreen window. (LP: #1159249,
    #860970)
  * Show session dialog over fullscreen windows. (LP: #1404486)
  * Avoid running pontentially dangerous code paths when the screen is
    locked. (LP: #1410582)

  [ Marco Trevisan (Treviño) ]
  * MenuManager: make sure menus are always shown when mouse is over
    them or when the always-show-menus option is on (LP: #955193,
    #1390562, #1374942, #1312137)
 -- Ubuntu daily release <email address hidden> Thu, 15 Jan 2015 15:03:31 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Nazar Mokrynskyi (nazar-pc) wrote :

Guys, you've broke completely my gaming experience!
Hud arrives all the time I click Alt (it is mapped in game to some command) and after returning there is huge framerate drop and I'm loosing 30 seconds to get back to game which is crucial in online multiplayer game.
Can this be disabled somehow? It was fine before this "fix".

Andrea Azzarone (azzar1) on 2015-01-29
Changed in unity:
status: In Progress → Fix Committed

Nazar, just use CCSM to disable the Hud keybinding or change it to something different (I use Super+space for example).

Unfortunately I don't think is possible to easily understand when the full-screen window is a game or something else (such as a browser, a video player or anything else that would benefit form this feature).

Andrea Azzarone (azzar1) wrote :

Also I can easily add an option to disable hud/dash/etc. if a fullscreen window is focused. Please let me know what do you think about it.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2015-03-18
Changed in unity (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Stephen M. Webb (bregma)
Stephen M. Webb (bregma) on 2015-03-18
description: updated
Nazar Mokrynskyi (nazar-pc) wrote :

Option to disable this for fullscreen windows would be highly appreciated!
Because both Alt and Super keys makes me crazy sometimes and lead to many unhappy situations.

Nazar Mokrynskyi (nazar-pc) wrote :

Maybe, you can somehow detect system load (I mean in terms of GPU or whether discrete graphics is enabled like in my case with built-in Intel and Nvidia in laptop through bumblebee).
Or even simpler (but narrow case) - I'm playing games from Steam, so when it is running - new behavior is not welcomed.

Nazar Mokrynskyi (nazar-pc) wrote :

@azzar1, Just get Unity update, fix is not present, will it be available in next release?

Hello Ben, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20150316-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

* enable proposed repository & install unity package.

$ LANG=C apt-cache policy unity libunity-core-6.0-9 unity-services
unity:
  Installed: 7.2.4+14.04.20150316-0ubuntu1
  Candidate: 7.2.4+14.04.20150316-0ubuntu1
  Version table:
 *** 7.2.4+14.04.20150316-0ubuntu1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.4+14.04.20141217-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/main i386 Packages
     7.2.2+14.04.20140714-0ubuntu1.1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main i386 Packages

libunity-core-6.0-9:
  Installed: 7.2.4+14.04.20150316-0ubuntu1
  Candidate: 7.2.4+14.04.20150316-0ubuntu1
  Version table:
 *** 7.2.4+14.04.20150316-0ubuntu1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.4+14.04.20141217-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/main i386 Packages
     7.2.2+14.04.20140714-0ubuntu1.1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main i386 Packages

unity-services:
  Installed: 7.2.4+14.04.20150316-0ubuntu1
  Candidate: 7.2.4+14.04.20150316-0ubuntu1
  Version table:
 *** 7.2.4+14.04.20150316-0ubuntu1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.4+14.04.20141217-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/main i386 Packages
     7.2.2+14.04.20140714-0ubuntu1.1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main i386 Packages

[CHECK: TEST CASE]
1. Open some site in firefox
2. Go to fullscreen mode (F11)
3. Press "Alt" once.
4 The HUD should appear and you should be able to interact with it.

---> HUD appeared & Keyboard input OK(Menu list appear).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20150316-0ubuntu1

---------------
unity (7.2.4+14.04.20150316-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Avoid running potentially dangerous code paths when the screen is
    locked. (LP: #1410582)
  * Ungrab the shoutdown dialog as soon as possible. (LP: #1398287)
  * Use COMPIZ_METAKEY where needed. (LP: #1363534)
  * disabled Pointer Barriers during lockscreen (LP: #1401911)
  * disabled markup for VolumeLauncherIcon quicklist menu items (LP:
    #1413411)
  * enable Dash, Hud, and session dialogs over full screen window (LP:
    #1159249, #860970, #1413773, #1404486)
  * made unity unlockable if user is in nopsswdlogin group (LP:
    #1413790)
  * skipped the animation of BGHash on startup to prevent unwanted fade-
    in (LP: #1241757)

  [ Luke Yelavich ]
  * extended accessible exploration of the Dash dynamic content (LP:
    #1066157)

  [ Marco Trevisan (Treviño) ]
  * MenuManager: make sure menus are always shown when mouse is over
    them or when the always-show-menus option is on (LP: #955193,
    #1390562, #1374942, #1312137)
  * PanelService: use gdbus to notfy upstart of service start/stop (LP:
    #1302955)
 -- CI Train Bot <email address hidden> Mon, 16 Mar 2015 17:30:35 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Nazar Mokrynskyi (nazar-pc) wrote :

Damn it!
Why are you all ignoring me? I'm suffering from this "Fix" every single time I'm launching fullscreen game!
Every click on "Alt" or "Super" causes multiple seconds of lost gameplay that is sometimes vital!
Are you seriously backported this ugly "feature" without any possibility to restore original behavior?
@azzar1 said he can add switch for this behavior, but there is no such option currently available.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers