unity slow on dual monitors (extended desktop)

Bug #1123108 reported by Michael Brook on 2013-02-12
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I am running Ubuntu 12.10 64-bit on a desktop computer that has 7.3 GB of usable RAM, an AMD A8-5500 APU Radeon Quad-Core processor, and dual monitors at 1920x1080 each, one through DVI and the other through VGA. The hardware is more than capable of intensive work, however, I've noticed that ever since I did a fresh install, Unity will sometimes become a bit sluggish while doing animations, especially after coming back from suspend. The sluggishness does not make the computer unusable, but the slower animations are not pleasant. When I first boot the computer, it seems to work okay as far as I can tell.

Normally, the animations are milky smooth, but when I suspend the computer and turn it back on, for example, the frame rate seems to drop quite a bit, especially if windows are animating across the entire screen or if I pop out the side bar, which is normally hidden. The lag in animation seems to affect the entire system, since the lag is also visible while using applications such as Firefox or Chrome.

To fix the problem, I either have to 1) entirely restart the computer or 2) go to my display settings, select one of my monitors, disable or change its resolution, and then hit apply. Once I hit apply, the one screen flickers off and then on again (if I just changed the resolution), and then the lag seems to disappear. I can also revert the changes, letting the screen turn off and back on again, and the lag still seems to be gone. Sometimes, though, I may need to do this twice in order to get the frame rate completely back to normal. Another thing to note is that if I only use a single monitor instead of dual, this problem never occurs, even after waking the computer from suspend. The problem also seems to only occur when I am using the screens as an extended desktop, not mirrors.

I first thought this issue could be due to a process utilizing too much of the CPU, so I ran 'top' but didn't notice anything very unusual about the results. While idle, the top processes are usually Xorg and compiz with about 0-3% CPU usage, and while windows are actively being moved and minimized/maximized across the screen, I've never seen Xorg go over about 30% and compiz about 15-20%.

Also, I don't know if this has anything to do with this problem, but when I bring the computer back from suspend mode, an error flashes on the screen for only about half a second:

[Firmware Bug]: cpu 1, try to use APIC500 (LVT offset 0) for vector 0x400, but the register is already in use for vector 0xf9 on another cpu
[Firmware Bug]: cpu 2, try to use APIC500 (LVT offset 0) for vector 0x400, but the register is already in use for vector 0xf9 on another cpu
[Firmware Bug]: cpu 3, try to use APIC500 (LVT offset 0) for vector 0x400, but the register is already in use for vector 0xf9 on another cpu

and it repeats. Again, not sure if it's relevant, but I thought I would mention it.

Michael Brook (michaelcbrook) wrote :

I now notice that Unity still does not work at full frame rate even when it is first booted. The only time it will work without lag is if I manually go in and change the display settings and then change them back.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Raymond Wells (rfw2nd) wrote :

I am experiencing the same issue... however:

Desktop: Core2Quad Q6600 on Radeon 2600XT (open source drivers) Ubuntu 13.04 6GB RAM/512MB VRAM
Laptop: Core2Duo T6600 on Mobility Radeon 4670 4GB RAM/1GB VRAM

On my desktop I have a 1080p monitor and a 1440x900 monitor.

I've tried 1080p monitors on my laptop, HDTV, and my secondary desktop monitor, and my laptop is profoundly faster than my desktop. I understand that it is to be expected as my laptop has a faster card and 2x the VRAM, but the difference in performance seems too much.

CPU usage is low, I think the bottleneck is how the GPU is used. Results from radeontop:
When the dash opens, Graphics Pipe usage shoots up to 92%. Just typing in the app lens (or any other lens) causes my graphics pipe usage to sustain at 80~95%, even when the only things in the dash are my text and "sorry there are no applications that match your search." Also, the unity preview animations are slow and again cause the gpu usage to skyrocket.

Furthermore, moving windows, maximize/minimize all are fast, the only slowness is with the switcher and the dash.

I hope this helps in narrowing down where the issues are :)

Maksim Boyko (boykom) wrote :

I have the same issue on my Acer Extensa 4220 laptop with integrated Intel graphics GMA 3000.

The unity on the LVDS (1280x800) works very well (Dash, window moving and effects) but on both LVDS and VGA (1440x900) it works slow.

I can show more info if you need to resolve the bug. Moreover I can help to developer to test a latest code.

Maksim Boyko (boykom) wrote :

I use ubuntu 13.04.

max ulidtko (ulidtko) wrote :

Same thing under VirtualBox: Unity on a single (virtualized) screen is nice and fast, but on two it's crawling slow.

Jaime Machado (jslmachado) wrote :

I experience the same issue on Ubuntu 13.04, I have Nvidia G102M with proprietary drivers.

Scott Deagan (scott-deagan) wrote :

I was experiencing the same problem. Here are some of the combinations I've gone through (I'm using an ASUS Z97 Pro motherboard with an Intel core i5-4430 CPU, Ubuntu 14.04):

Single monitor, Intel HD 4400: animations and window movement are very smooth.
Dual monitor (1920x1080), Intel HD 4400: animations and window movement very smooth.
Dual monitor (1920x1080 & 2560x1440), Intel HD 4400: animations a little jerky/jittery.
Dual monitor (1920x1080 & 2560x1440), nVidia 660TI: everything smooth and responsive.

I was running everything (a full-HD and quad-HD) using the Intel HD 4400. I was running my quad-HD monitor in a lower resolution (1920x1080) because performance was not good using the maximum 2560x1440.

Last night, I decided to try my nVidia GeForce 660TI again. I placed it onto the board and installed the proprietary 337.25 beta driver (downloaded from the nVidia website). All animations and window movements (with wobbly windows installed) are perfectly smooth and responsive. The only time animations become jerky is if a video is playing in the default video player (Totem?).

Changed in unity:
status: New → Confirmed
madbiologist (me-again) on 2015-05-27
tags: added: quantal
madbiologist (me-again) wrote :

Official support for Ubuntu 12.10 "Quantal Quetzal" and Ubuntu 13.04 "Raring Ringtail" has ended. If anyone is still experiencing this issue on Ubuntu 12.04 "Precise Pangolin" please check if this issue still exists on Ubuntu 14.04 "Trusty Tahr".

Trusty has a 3.13-based kernel which introduced proper AMD Radeon DPM (dynamic power management) for the first time. Further Radeon DPM improvements were made in subsequent kernels. In particular, kernel 3.17 re-enabled DPM for AMD "Cayman", "Barts", "Turks" and "Caicos" hardware after it was disabled in kernel 3.14 for stability reasons. This is first included in Ubuntu 15.04 "Vivid Vervet" which is based on the 3.19 kernel.

Anyone who still has this issue on Trusty (more likely for users with Intel or NVIDIA hardware due to the reasons I outlined above), please check that you are not running the fallback llvmpipe renderer by running this command in a terminal window:

glxinfo |grep renderer

Thuc (tstdlvl) wrote :

I have the same problem with Ubuntu 14.04 LTS. After installation Ubuntu, everything was fine. I restarted computer and things were still ok until the moment when I logged in. The unity became extremely slow. I unplugged a monitor, it went back to normal speed. I waited for a while (more than 10s), and plugged again. Now is a story of luck. Sometimes it worked, sometime not.

tags: added: multimonitor
Esp (optimus-esp) wrote :

i have the same problem with 14.04.3 LTS
Intel i7 - Nvidea GeForce GT 540M - with 8G ram.
I can't start 2 virtual machines with 2 a dual screen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers