Touch screen stops respoding to clicking after running for a while

Bug #1099289 reported by Tommy on 2013-01-14
This bug report is a duplicate of:  Bug #1068994: button1 gets stuck after a while. Edit Remove
292
This bug affects 56 people
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
xserver-xorg-input-evdev
New
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

I have an Acer Aspire V5 laptop with a 15.6 inch touchscreen, which came preinstalled with Windows 8. As I was testing Ubuntu 13.04 on it, I noticed that after a certain amount of time, I am unable to click on items with the touchscreen anymore. This only seems to affect the Unity interface, and I think it occurs while you're selecting menu items, or dragging your finger over them. I'm not 100% certain on that. Applications still respond to the touchscreen though, for example, I am able to still switch tabs and scroll through pages in the Epiphany browser with the touchscreen. However I can't switch application windows with the touchscreen, nor can I select menu items, click on any launcher icons or use the dash (any elements that make up the Unity interface).

I should also add that initially when I first boot up Ubuntu 13.04, the touchscreen works as expected, so this glitch doesn't happen all the time. It only seems to be triggered when I open menu items with the touchscreen and drag around. I'm not even sure if that's what causes it, but that's what it seems like from paying close attention to it.

I noticed this using the January 14th daily build of Ubuntu 13.04, but it also occurs in 12.10 as well.
---
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
CasperVersion: 1.330
DistroRelease: Ubuntu 13.04
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130113)
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.8.0-0.3-generic 3.8.0-rc3
Tags: raring running-unity
Uname: Linux 3.8.0-0-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
---
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3257 F.... pulseaudio
CasperVersion: 1.328
DistroRelease: Ubuntu 12.10
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Acer Aspire V5-571P
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi.signed file=/cdrom/preseed/username.seed boot=casper quiet splash --
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
Tags: quantal running-unity
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/31/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: V2.03
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire V5-571P
dmi.board.vendor: Acer
dmi.board.version: V2.03
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Acer
dmi.chassis.version: V2.03
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrV2.03:bd08/31/2012:svnAcer:pnAspireV5-571P:pvrV2.03:rvnAcer:rnAspireV5-571P:rvrV2.03:cvnAcer:ct9:cvrV2.03:
dmi.product.name: Aspire V5-571P
dmi.product.version: V2.03
dmi.sys.vendor: Acer

Tommy (lodmot347) on 2013-01-14
affects: valgrind (Ubuntu) → ubuntu
Tommy (lodmot347) on 2013-01-16
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1099289

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tommy (lodmot347) on 2013-01-16
tags: added: apport-collected raring running-unity
description: updated

apport information

tags: added: quantal
description: updated

apport information

Tommy (lodmot347) wrote : CRDA.txt

apport information

apport information

apport information

Tommy (lodmot347) wrote : Lspci.txt

apport information

Tommy (lodmot347) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

Tommy (lodmot347) wrote : RfKill.txt

apport information

Tommy (lodmot347) wrote : UdevDb.txt

apport information

apport information

apport information

For some reason I had trouble running the apport command in 13.04, but I also noticed that 12.10 has the same bug as well, so I decided to run it from that. Hopefully that still helps to an extent.

Joseph Salisbury (jsalisbury) wrote :

It would be helpful if you could collect some USB Tracedata. There are some web pages that describe how this can be done:

https://wiki.ubuntu.com/Kernel/Debugging/USB#Getting_USB_Tracedata
http://www.kernel.org/doc/Documentation/usb/usbmon.txt

If you can, reproduce the bug while collecting this data.

Thanks in advance!

Changed in linux (Ubuntu):
importance: Undecided → Medium
Tommy (lodmot347) wrote :

Thank you for the timely reply. ^^
Unfortunately I was experimenting some more with this bug last night, and it appears to just happen at random times. I couldn't find a distinct pattern of actions that triggered it. Ill collect the data for you tonight when i have access to the victimized laptop.

Tommy (lodmot347) wrote :
Download full text (182.9 KiB)

Alright, I got the trace data. Honestly I have no idea how this helps, or if I even did it correctly, but here it is. Luckily though, the glitch actually occured shortly after I started the tracing, so maybe that will make it easier to pick it out from here... I also tried the cat command, but it said that a certain directory was missing, so I just did a trace on 0u.

If it helps at all, I also ran the LSUSB command, and it came up with this output:

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 154b:0044 PNY
Bus 003 Device 003: ID 04f3:0023 Elan Microelectronics Corp.
Bus 003 Device 004: ID 064e:e330 Suyin Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0489:e04e Foxconn / Hon Hai

Here's the actual trace data that I captured when the glitch occured. Lemme know if this helps. Thanks. ^^

ffff880113b3b240 691552968 S Bo:3:002:2 -115 31 = 55534243 76260000 00000000 00000600 00000000 00000000 00000000 000000
ffff880113b3b240 691553026 C Bo:3:002:2 0 31 >
ffff880113b3b240 691553040 S Bi:3:002:1 -115 13 <
ffff880113b3b240 691553192 C Bi:3:002:1 0 13 = 55534253 76260000 00000000 00
ffff880113b3b240 692251779 S Bo:3:002:2 -115 31 = 55534243 77260000 00100000 80000a28 000012c3 c6000008 00000000 000000
ffff880113b3b240 692251824 C Bo:3:002:2 0 31 >
ffff880113f4e6c0 692251838 S Bi:3:002:1 -115 4096 <
ffff880113f4e6c0 692252533 C Bi:3:002:1 0 4096 = 80914774 c2aa91e3 9d06b261 ac086b64 1989d81e 84218727 220c3f32 c3044fc9
ffff880113b3b240 692252546 S Bi:3:002:1 -115 13 <
ffff880113b3b240 692252579 C Bi:3:002:1 0 13 = 55534253 77260000 00000000 00
ffff880113b3b240 692252649 S Bo:3:002:2 -115 31 = 55534243 78260000 00400000 80000a28 000012c3 ce000020 00000000 000000
ffff880113b3b240 692252670 C Bo:3:002:2 0 31 >
ffff880113f4e6c0 692252680 S Bi:3:002:1 -115 16384 <
ffff880113f4e6c0 692253867 C Bi:3:002:1 0 16384 = 2f2eee17 d417a2c1 8ceec254 7f612686 0f1ff470 61b22eec fdf97ac3 77e49332
ffff880113b3b240 692253880 S Bi:3:002:1 -115 13 <
ffff880113b3b240 692253911 C Bi:3:002:1 0 13 = 55534253 78260000 00000000 00
ffff880113b3b240 692254006 S Bo:3:002:2 -115 31 = 55534243 79260000 00700000 80000a28 000012c3 ee000038 00000000 000000
ffff880113b3b240 692254031 C Bo:3:002:2 0 31 >
ffff880113f4e6c0 692254037 S Bi:3:002:1 -115 28672 <
ffff880113f4e6c0 692255803 C Bi:3:002:1 0 28672 = c3d9d579 69ee83ad fdfcf4c7 85bcb4af 379b737e abdfbef9 eb3f34bf 9caddf5f
ffff880113b3b240 692255814 S Bi:3:002:1 -115 13 <
ffff880113b3b240 692255852 C Bi:3:002:1 0 13 = 55534253 79260000 00000000 00
ffff880113b3b240 693600868 S Bo:3:002:2 -115 31 = 55534243 7a260000 00000000 00000600 00000000 00000000 00000000 000000
ffff880113b3b240 693600915 C Bo:3:002:2 0 31 >
ffff880113b3b240 693600932 S Bi:3:002:1 -115 13 <
ffff880113b3b240 693601078 C Bi:3:002:1 0 13 = 55534253 7a260000 00000000 00
ffff880113f4b480 694907474 C Ii:3:003:1 0...

Joseph Salisbury (jsalisbury) wrote :

It might be worthwhile reporting this upstream since it happens in the v3.8-rc3 kernel.

Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Tommy (lodmot347) wrote :

Will do. ^^
Thanks again for your help.

Tommy (lodmot347) wrote :

Didn't get a response after 3 days, so I filed a bug report at bugzilla.kernel.org on the issue.

Tommy (lodmot347) wrote :

Update: After experimenting more with the bug, I realized that the bug is actually within the Unity interface, not the Linux touchscreen drivers. So I've changed the bug info to reflect this.

affects: linux (Ubuntu) → unity (Ubuntu)
Tommy (lodmot347) on 2013-02-21
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
status: Incomplete → New
status: New → Incomplete
Anton Anikin (anton-anikin) wrote :

Hello.
I have the same problem on Acer W700 tablet.
Ubuntu 13.04 (gnome-shell and unity)
kernel 3.9-rc3
touchscreen:
 ID 04f3:000c Elan Microelectronics Corp

Anton Anikin (anton-anikin) wrote :

So, it is not only unity problem...
Maybe, evdev driver or somewhere else in xorg

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Anton Anikin (anton-anikin) wrote :

Also, I have found with xev utility that when clicks normal - it generates both ButtonPress and ButtonRelease events... But when clicks not works - it generates only ButtonRelease event.

Anton Anikin (anton-anikin) wrote :

It seems here is the patch for this issue (but I have not tested it yet)
https://bugs.freedesktop.org/show_bug.cgi?id=56578#c17

Tommy (lodmot347) wrote :

Thank you very much. I'll give this a shot.

Daniel Holz (daniel-holz91) wrote :

I think I have the same bug with my WeTab. After logging in everything works but after a short time I can´t left-click anything in the starterbar on the left, the top bar, the unity dashboard and any non-gtk-application. For example: Chrome and Firefox don´t work but Epiphany does.
Does someone know if and how that patch works? I have no idea how to use it.

Daniel Holz (daniel-holz91) wrote :

I tried the patch for the xserver but it didn´t change anything.

Nick (nickponvert) wrote :

I also have this bug or one that is very similar. Unity stops responding to touchscreen single clicks after a period of time. I am still able to use multitouch features like swiping with four fingers to show the dock. I examined the input device in xinput and it showed clicks and releases while the bug is in effect. I will be having this problem daily, so please let me know if I can help. When it happens I either log out and back in or use the stylus.

Nick (nickponvert) wrote :

I still need to test this theory more, but the bug seems to begin when I use the 3-finger window actions gestures. Pehaps it is a problem with the multutouch?

pauls (paulatgm) wrote :

Nick, there's a lot of us with this problem on 2 touch devices, and it shows up for us on single touch events. See this bug:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/946417

pauls (paulatgm) wrote :

By the way, it's not just unity and ubuntu, I've also tried Fedora and Slackware on my cando touch device and both have the same problem. It's upstream.

Tommy (lodmot347) wrote :

I've already tried reporting the bug upstream.

The issue is, they apparently have such strict guidelines for those kind of bugs that I'm baffled as to how it even works. I did my absolute best to follow the guidelines for filing an upstream bug report. After 2 hours of putting the email together and sending it with all the information I could find on it, I never received a response.

This bug is perhaps duplicate of bug 1015183 or bug 1068994. I have attached a patch (for xorg-server) to that bugs which solves the problem on the Lenovo Thinkpad Twist.

Konstantinos Togias (ktogias) wrote :

I have the same issue on a sony vaio duo 11 with ubuntu 13.04 and kernel http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc8-raring/ . (Kernels earlier than 3.9 do not properly support duo's N-Trig DuoSense Touch Screen - see https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/1121379 ).

Konstantinos Togias (ktogias) wrote :

 I have also tested with gnome-shell and kde from 13.04 repositories and seem to have similar issues. After some time (especially when doing fast subsequent taps on the screen or trying to drag a scrollbar or type on the on-screen keyboard) the main components of the desktop environment (panels, dialogs etc) do not accept a click with tapping, while the cursor continues to move properly at the tapped point and evtest properly reports BTN_TOUCH events.

pauls (paulatgm) wrote :

I've recently installed 13.04 on my lenovo s10-3t which has the cando touch screen and it's still a bug.

Till, I'm using a netbook with atom processor, so patching and compiling solfware is an unbelievably arduous task. But, I can install packages and test things. Can you or someone provide a package for the patched xorg that you'd like me to test?

pauls (paulatgm) wrote :

Till, I tried applying the patch and making the debs. There were no errot messages, so I installed the patched debs and rebooted. But I don't see any improvement. It still eventually stops responding.

There's a second part to this bug for those of us who have a touchpad mouse and that's the fact that when I touch the touchpad, the mouse cursor jumps off the page instead of moving from the point that it was left by the last touch of the screen. This problem also remains after trying that patch.

quafzi (ubuntu-hardware) wrote :

pauls, I can fully confirm your description. In fact, the mouse cursor is moved only by clicking, and it is located in the lower right corner after that. This behavior just makes you crazy, when you try to click something...

Zhang Weiwu (zhangweiwu) on 2013-05-02
summary: - Touch screen stops clicking...
+ Touch screen stops respoding to clicking after running for a while
Zhang Weiwu (zhangweiwu) wrote :

I found that when this happens, Firefox also stops to respond to clicks - real mouse click, not only touch-pad clicks. And that this doesn't happen to other software like Nautilous, and that this happens only in firefox, not on its titlebar (which traditionally is part of a window-manager - things changed so much nowadays I don't even knnow how to address it now). I am guessing this behaviour ascribes to this bug -- it happened twice on my tablet, and if it keep happening I would be able to say for sure.

This effects more than Unity but up to Ubuntu based distributions. Bug is even present on Bodhi Linux.

Zhang Weiwu (zhangweiwu) wrote :

Previously I said, that when the computer no longer respond to touchpad clicks, it also stops to respond to physical mouse clicks. This I managed to reproduce again, thus I can confirm this behaviour. And I confirm this happens not only to firefox but also to amule, which uses wxwidget. i guess this misbehavior applies to anything that is not gtk (e.g. tcl/tk).

pauls (paulatgm) wrote :

The fix is nearly done at https://bugs.freedesktop.org/show_bug.cgi?id=56578 Suggest you monitor that for final resolution.

LJ (the-mr-lj-88) wrote :

good to read, that there will be a fix. I have the same issue with my Dell XPS12 (a bug report therefor also exists).

LJ (the-mr-lj-88) wrote :

has someone tested the fix?
when will it be included in the ubuntu updates?

ArKtos (killercompany-gmail) wrote :

Dell XPS 12 , same Problem .... ubuntu 13.04.

Anything a can do , let me know ......

Cody Swanson (codyswanson4) wrote :

Lenovo Z400 Touch, same problem with 12.04...Any testing I can do, I'll do!

Szymon Gosek (quad-g) wrote :

Got this today on Acer Iconia W700P, will help also.

Cody Swanson (codyswanson4) wrote :

I have been trying to compile this for a day now, and I know I'm doing something stupid...Can somebody point me in the direction of a tutorial or something???

inashdeen (inashdeen) wrote :

Same problem here. ELAN Touchscreen on acer aspire v5 - 471pg

vinyvat (brimhall) wrote :

Same problem on my Dell XPS 12.

I really think it is some x11 or gtk patch ubuntu uses. I tried debian testing, fedora 19, *none* of them have this problem.

I also tried some "latest greatest" x11 ppa repositories with xubuntu 13.0.4: edgars and oibaf in the hopes that one of these bleeding edge x11 would fix the problem, but still there.

If someone can setup a ppa to try out various binaries with potential fixes I'll happily help test.

Tori Hayduke-Toomath (thaytoo) wrote :

I've been having a similar problem on my brand-new Lenovo Z400 touch. I'm pretty new to Linux, so I'm not entirely sure what I can do to help, if anything. Let me know how if I can! I want to get the touch screen to be just fine! :)

ANYWAYS, I noticed a few times that the touchscreen suddenly works again sometime past midnight. Can't pinpoint a certain time, because I will just notice it's working again randomly, but it's always past midnight... Maybe it's just me, but it could possibly be that whatever is ultimately causing this may reset at a certain time daily... I'm not even sure if that's possible, but thought I'd throw it out there.

Cody Swanson (codyswanson4) wrote :

I believe a patch for this should be included in the next X-Server update. I'm not really sure when that is...

LJ (the-mr-lj-88) wrote :

@ thaytoo: Can confirm the touchscreen suddenly works again. Mine also has a funny side effect; if I make any further clicks after the touch screen stops working, they will be executed some time later when it works again :D.
But this happens very infrequently - waiting so long is no option.

Would be great to see a patch in the next X-Server update - are there any details?

Tori Hayduke-Toomath (thaytoo) wrote :

@the-mr-lj-88: I've been trying to keep a log of when I notice this, and have been trying to check it over every so often, but no luck with pinpointing a 'random time that it works' again. :/
I DO notice though, that at least one time a day, I get an error message asking if I want to send the error report. I always do. The majority of these have occured between 12am(midnight)-1am for me. very occasionally, they are at other times (once around 6pm). But pretty much every time I'm on the computer past midnight, an error message will pop up. 12:01, 12:25, & 12:31 are some of the recorded times. I'm thinking this error is part of this, but idk. :P
If it'd help, I can try to post a link of my touchscreen log. I'm trying to use it to potentially spot a pattern of some sort.
My mouse will follow my finger most of the time, but will not click on anything I tap. (unless I'm in the login screen after a suspend-it seems to work completely fine then, every time!) At least you can sort of click eventually possibly. xP

Since I'm still figuring Linux out, (lol) is there a link or anything that will be given with the x-server update is released?

mray (mrayyyy) wrote :

Same problem on "Lenovo Yoga 13" on ubuntu 13.04 and 13.10 (alpha) so far.

Micah F (fitchmicah) wrote :

I'm also on the Acer W700 here (with Ubuntu 13.10). I'm getting all kinds of similar symptoms. Gnome and Unity have problems with touching the menu immediately upon logging in. I have to open the launcher view in both of these environments in order to interact with the menu via touch. Then, after a while, I cannot touch to click anything!

After a little bit of interaction with XFCE, touch clicking also stops working.

For whatever reason, the most reliable environment seems to be E17. I can use multiple applications for an extended period without losing touch-click functionality.

I have the Acer Iconia W500. Getting the exact same problem. The touchscreen and clicking would be fine at 1 moment and the next the clicking kinda gets disabled and i cant click using the touchscreen.

Someone please email me at: <email address hidden> if someone found a fix

Stefan Seidel (seidler2547) wrote :

@Matthew Goodman (matthewthegoodman) this is not a wish list, it's a bug tracker.

@Micah F (fitchmicah) the issue with GNOME is probably that bug: https://bugzilla.gnome.org/show_bug.cgi?id=697192 -- GNOME 3, the "touch optimized" UI doesn't work with touch screens.

I'm on Arch Linux + KDE (because of the said GNOME bug) now, everything works as expected. So it's only a matter of time and Ubuntu not being a bad player in the open source game (as they sometimes are) until this is resolved.

inashdeen (inashdeen) wrote :

why did this bug consider a duplicate of #1068994. ? i thought that is an issue with the ubuntu tablet . by the way, fix it quick, please. this really bother me :(

LJ (the-mr-lj-88) wrote :

referring to bug 1068994, it seems to be fixed in 13.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.