debian/control Build-Depends is missing dependency's to build

Bug #1082151 reported by Joseph Mills on 2012-11-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

apt-get build-deps is not working because it is missing things like compiz plugins.
I think that these things should be added.

Also why is there is unity-2d stuff in the debian/control for unity 3d just a question there but for real the control file needs to be updated. I have seen that there is stuff like that on the mailing list but don't seem to be working either that or I am building wrong version. I thought that all unity was now 3d and 7.X not sure about that. Thanks for taking a look at this bug

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 6.12.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
Uname: Linux 3.7.0-2-generic i686
ApportVersion: 2.6.2-0ubuntu5
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Nov 22 14:43:00 2012
InstallationDate: Installed on 2012-11-22 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121121)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Joseph Mills (josephjamesmills) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
MC Return (mc-return) wrote :

I had the same problem with outdated build-deps. (sudo apt-get build-dep unity failed to pull all build dependencies)
In my case libxcb-dri2-0-dev was missing IIRC.

Changed in unity:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers