Ubuntu

[regression] Shortcut overlay does not hide when modifier key is pressed

Reported by Łukasz Zemczak on 2012-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz
High
Brandon Schaefer
0.9.9
High
Brandon Schaefer
Unity
High
Brandon Schaefer
compiz (Ubuntu)
High
Brandon Schaefer
unity (Ubuntu)
High
Brandon Schaefer

Bug Description

On trunk, the autopilot test case unity.tests.test_shortcut_hint.ShortcutHintInteractionsTests.test_shortcut_hint_hide_pressing_modifiers fails as a regression.

[Test Case]
1. Press and hold Super to show the Shortcut overlay screen
2. Press any modifier key
   -> Make sure the overlay badges on the launcher icons disappear

----------------------------------
Desired solution:

- When the SUPER key is pressed, all keys with the exception of the "P" key should be grabbed by Unity.

- This should allow the "Shortcut overlay does not hide when modifier key is pressed" while enabling the laptop SUPER+P presentation mode to still work.

Related branches

lp:~brandontschaefer/compiz/lp.1075207-fix-ubuntu-super-p-patch
Merged into lp:compiz/0.9.9 at revision 3631
Andrea Azzarone: Approve on 2013-03-06
Sam Spilsbury: Approve on 2013-03-06
PS Jenkins bot: Approve (continuous-integration) on 2013-02-28
lp:~brandontschaefer/compiz/lp.1075207-raring-super-p-patch
Merged into lp:compiz/raring at revision 3633
PS Jenkins bot: Approve (continuous-integration) on 2013-03-07
Andrea Azzarone: Approve on 2013-03-06
Łukasz Zemczak (sil2100) wrote :
Changed in unity:
milestone: none → 7.0.0
Changed in unity:
importance: Undecided → Medium
status: New → Triaged
Daniel van Vugt (vanvugt) wrote :

Testing on quantal the Keyboard Shortcuts overlay does disappear correctly. It's only the overlay badges on the launcher that don't disappear. Is that what you mean?

Changed in unity:
status: Triaged → Incomplete
John Lea (johnlea) wrote :

@vanvugt; the overlay badges should also disappear so this is a regression.

Changed in ayatana-design:
status: New → Fix Committed
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
description: updated
Łukasz Zemczak (sil2100) wrote :

@Daniel
For me both the overlay and the badges don't disappear when I tap Alt, Ctrl or Shift while holding Super. Is it differently for you? I'm currently using unity staging, but I had the same thing when using quantal.

Daniel van Vugt (vanvugt) wrote :

Hmm, OK. In that case I can't reproduce the whole bug :/

Changed in unity:
status: Incomplete → New
Stephen M. Webb (bregma) wrote :

I can confirm this occurs on Raring, but it does not occur on Quantal.

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
John Lea (johnlea) on 2013-01-18
summary: - Shortcut overlay does not hide when modifier key is pressed
+ [regression] Shortcut overlay does not hide when modifier key is pressed
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High

This is caused by fixing this bug:
https://bugs.launchpad.net/ubuntu/quantal/+source/unity/+bug/950160

So the only way we can fix this is by reverting that other fix... The problem being we no longer grab all the keys so when a modifier is pressed compiz doesn't send the key terminate....

John Lea (johnlea) wrote :

@brandontschaefer; +1 from me for reverting the fix to bug #950160 to solve this issue. Note we only want to grab all other keys when SUPER is pressed, we should not grab all other keys when any other modifier is pressed.

@John; Well the problem is, if we grab all the keys when super is pressed Super+P no longer works for going into presentation mode. Which the Super+P is not changeable...so if we grab all the keys when Super is pressed, Super+P no longer works which is one of the main problems with that other bug....so we are kind of in a catch 22 situation.

John Lea (johnlea) wrote :

@brandontschaefer; can we grab all keys other than SUPER+P and create an exception for this one shortcut?

We would have to hard code that in... and I think the only way that would get accepted is by adding this to the ubuntu patches...but Ill have to talk with Daniel or Sam about it.

John Lea (johnlea) wrote :

@brandontschaefer; sounds good, fingers crossed you can find a way to do it. I've updated the bug description.

description: updated
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress

@John; After talking with Daniel Ill implement a fix where we only ungrab Super+P leaving OEM (Dell) happy, while grabbing everything else which will fix this problem. So it should be a compiz only fix.

Changed in compiz:
status: New → Triaged
Changed in compiz (Ubuntu):
status: New → In Progress
Changed in compiz:
status: Triaged → In Progress
importance: Undecided → High
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz:
milestone: none → 0.9.9.2
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/raring at revision 3633, scheduled for release in compiz, milestone Unknown

Changed in compiz:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
importance: Undecided → High
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.9.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.03.08-0ubuntu1

---------------
compiz (1:0.9.9~daily13.03.08-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * [regression] Shortcut overlay does not hide when modifier key is
    pressed (LP: #1075207)
  * Unity blocks other programs from binding globally to Super+* (* =
    any key) (LP: #950160)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3633
 -- Automatic PS uploader <email address hidden> Fri, 08 Mar 2013 10:34:21 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers