When Unity UI elements are above an unresponsive window, they flicker

Bug #1070735 reported by Chris Halse Rogers on 2012-10-24
96
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Daniel van Vugt
6.0
Fix Released
Medium
Łukasz Zemczak
unity (Ubuntu)
Medium
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]

UI flicker in some cases.

[Test Case]

When Unity UI elements - the alt-tab switcher, or the top bar shadow - are above an unresponsive window, the portion of the Unity elements which are above the window flicker in and out of view.

[Regression Potential]

Low, single line marking damage to the nux for drawing more often.

---

Although the attached video doesn't show it, this behaviour still occurs if the unresponsive window is not visible - the Unity elements over where it is still flicker.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Oct 24 19:55:41 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.18, 3.5.0-15-generic, x86_64: installed
 virtualbox, 4.1.18, 3.5.0-16-generic, x86_64: installed
 virtualbox, 4.1.18, 3.5.0-17-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:04c1]
 Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] [1002:6741] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120521)
MachineType: Dell Inc. Dell System Inspiron N4110
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-17-generic root=UUID=29e6204e-f505-41b5-b312-b6257ee24e9e ro rootflags=subvol=@ quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/20/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: Q4E343
dmi.board.vendor: Dell Inc.
dmi.board.version: X01
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd09/20/2011:svnDellInc.:pnDellSystemInspironN4110:pvr:rvnDellInc.:rnQ4E343:rvrX01:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Inspiron N4110
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.8.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 9.0-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Related branches

Chris Halse Rogers (raof) wrote :
Changed in unity:
milestone: none → 7.0.0
Daniel van Vugt (vanvugt) wrote :

I have a theory that the problem could be the fade plugin failing to post damage for the faded window, but still redrawing it. So unity never gets told that it needs to redraw the switcher/overlay on top.

Please try this and tell us if it hides the problem:
CCSM > OpenGL >
  framebuffer_object = OFF
  vertex_buffer_object = OFF
  always_swap_buffers = OFF

Changed in compiz:
milestone: none → 0.9.9.0
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

Those options certainly hide the flicker. On the down side, they hide the flicker by making the UI elements disappear, rather than flicker in and out ☺.

New video attached.

Changed in unity:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

raof,

It looks like it's now happening with regular windows. Not just faded/unresponsive windows. Is that right?

Changed in compiz:
status: New → Confirmed

No, that was an unresponsive ccsm window - note that I suspended it from
the console each time.

I've not seen this happen with anything but unresponsive windows.

Fusion (bornolbers) wrote :

i saw the video.. it' wasn't only on the alt-tab switcher, it is also the dash. At the dash, the flicker is much more and happens from the beginning (not after some alt-tabs).

Changed in unity (Ubuntu):
assignee: nobody → Fusion (bornolbers)
assignee: Fusion (bornolbers) → nobody
Chris Halse Rogers (raof) wrote :

Yeah, as I said above, it's not just the alt-tab switcher, it's also (at
least) the dash and the top-bar shadow.

Daniel van Vugt (vanvugt) wrote :

Workaround:
In CCSM, disable the "Fading Windows" plugin.

Works for me. How about you, raof?

Changed in compiz:
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
Fusion (bornolbers) wrote :

"In CCSM, disable the "Fading Windows" plugin"
works for me too.

ps. i also noticed that not responding windows even minimized causes the flicker - when fading windows enabled

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
Changed in compiz:
status: Triaged → Invalid
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in compiz:
milestone: 0.9.9.0 → none
Changed in unity:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2872, scheduled for release in Unity 7.0.0

no longer affects: compiz
no longer affects: compiz (Ubuntu)

I have a similar problem that I described in Bug #1072535
In it, I talk about an associated problem with the launcher that hides and reveals uncontrollably.

I tried the fix described here (disabling CCSM's Fading Windows). It seems to have fixed the panel glitch, but it is now not possible to reveal the launcher with the pointer anymore (still possible with the super key though).

Should this launcher problem have its own bug report? It does seem to be linked as it is affected by the fix, but I can't see anyone else having this launcher problem.

Regarding my previous comment:
After disabling Fading Windows and a restart, the launcher is back but the problem is the same. The visual glitch on the panel is fixed though. Should I modify Bug #1072535 to talk only about the launcher problem?

Daniel van Vugt (vanvugt) wrote :

Stéphane,

Yes, exactly one issue per bug is preferred. If there is any overlap in other bugs with what's discussed here then please clarify and refine the other bugs, removing the overlap.

description: updated
description: updated
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity (Ubuntu Quantal):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0-0ubuntu1

---------------
unity (6.12.0-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Includes two already cherry-picked fixes in Ubuntu
    - Unregister gdbus object in the dtor (LP: #1047760)
    - Top panel "tooltip" got out of sync when navigating with the
      keyboard (LP: #1067358)
    - Fix escaping of _panel_title (LP: #1067357)
    - Fix ALT+Tab switches to incorrect window (LP: #1071298)
    - Stop Unity UI elements from flickering in some cases (LP: #1070735)
 -- Timo Jyrinki <email address hidden> Thu, 08 Nov 2012 11:10:13 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello Chris, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.12.0-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Chris, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.12.0-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Timo Jyrinki (timo-jyrinki) wrote :

Confirmed fixed with the quantal-proposed version by doing the test case in the duplicate bug #1060855

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0-0ubuntu0.2

---------------
unity (6.12.0-0ubuntu0.2) quantal-proposed; urgency=low

  * Cherry-pick a fix for regression in top panel title (LP: #1085045)
  * Cherry-pick a fix for unity::TimeUtil::TimeDelta overflow (LP: #806248)

unity (6.12.0-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release.
    - Includes two already cherry-picked fixes in Ubuntu
    - Unregister gdbus object in the dtor (LP: #1047760)
    - Top panel "tooltip" got out of sync when navigating with the
      keyboard (LP: #1067358)
    - Fix escaping of _panel_title (LP: #1067357)
    - Fix ALT+Tab switches to incorrect window (LP: #1071298)
    - Stop Unity UI elements from flickering in some cases (LP: #1070735)
 -- Timo Jyrinki <email address hidden> Mon, 03 Dec 2012 11:35:27 +0200

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released
mohican (mohican) wrote :

I have a problem that look like this, but it's on precise.

Dash flickers when a window that redraws often is under it.
e.g. system monitor, 'resources' tab
e.g. the clock screenlet

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.