1002:6798 [fglrx] VT cursor is visible and blinking on top of Unity Radeon HD 7970 and 5450

Bug #1067320 reported by Nicolas Delvaux on 2012-10-16
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
fglrx-installer (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

A black cursor is blinking on top of the screen.
It is not as regular as a true shell prompt (because of glitches), but I'm sure this is the cursor of the underlying TTY.

If I try to switch to any other TTY, the focus remains on the desktop (eg. I can still click and type in Firefox) but the black cursor does move as I type.

For example, I just switched to TTY 1 and was able to log-in (I see it because of the cursor position on the screen), while my username and my password were also written in the text-box where I'm writing this bug report.

This bug is really odd and annoying.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Tue Oct 16 13:34:59 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 fglrx-updates, 9.000, 3.5.0-17-generic, x86_64: installed
 virtualbox, 4.1.18, 3.5.0-17-generic, x86_64: installed
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Tahiti XT [Radeon HD 7970] [1002:6798] (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:2780]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121004)
MachineType: MSI MS-7752
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=9054a8bb-9c6c-4689-be51-a5fece8e4155 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/04/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.6
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z77A-G45 (MS-7752)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.6:bd09/04/2012:svnMSI:pnMS-7752:pvr1.0:rvnMSI:rnZ77A-G45(MS-7752):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7752
dmi.product.version: 1.0
dmi.sys.vendor: MSI
version.compiz: compiz 1:0.9.8.4-0ubuntu2
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Nicolas Delvaux (malizor) wrote :
summary: - Blinking black "cursor" on the desktop with fglrx
+ [fglrx] VT cursor is visible and blinking on top of Unity

I should add that there is a bit of randomness in this bug.
After a reboot, sometime it is gone, sometime it is back.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Senno Kaasjager (st3vie) wrote :

I have the same issue, in the login screen and while typing my credentials, I see the cursor move, and also sometimes after login. Sometimes, after I entered my credentials and try to login (hit enter, or click with the mouse), I'm not logged in, but the login is shown again, like it has reset (shows black screen, then goes back to login screen). Then the issue is gone and I can login normally.

Also, when the issue is after logging in and I logout, then the issue is gone as well. So, it seems the logout resets something that fixes this issue. For me anyway, maybe others can confirm this.

It does not happen all the time, though, but so far since the upgrade to 12.10 it happens more often than in 12.04.

summary: - [fglrx] VT cursor is visible and blinking on top of Unity
+ 1002:6798 [fglrx] VT cursor is visible and blinking on top of Unity
+ Radeon HD 7970

issue confirmed here with ATI Radeon HD 5450

summary: 1002:6798 [fglrx] VT cursor is visible and blinking on top of Unity
- Radeon HD 7970
+ Radeon HD 7970 and 5450
antoine (antoine-requet) wrote :

This is also occuring for me with a radeon HD 5670 (ubuntu 12.10, amd64).

Nicolas Delvaux (malizor) wrote :

When this issue happens, it also produces a massive graphic glitch when you try to switch to another user (or to the guest session) without closing your session first.
It seems both sessions are superposed: everything blink and is corrupted. The only solution I found in this case is to reboot via magic keys.

Hans-Peter Schadler (hps-abyle) wrote :

Still haven't found a way to get rid of this blinking cursor.

It is not only the case with Unity(tested with Ubuntu 12.10 fresh install), but also with xfce (tested with Xubuntu 12.10 fresh install, fglrx install per apt-get install fglrx fglrx-amdcccle, all updates installed).

Nicolas Delvaux (malizor) wrote :

Perhaps this is rather a bug in lightdm?
Does this problem still happens when using GDM, KDM or similar?

Update (with some kind of solution):
What I have tried so far:
- Disabling KMS explicitly at grub prompt: no change
- Disabling vesafb: blank screen
- Disabling Plymouth: no change

Another thing I tried right now, was installing the AMD Catalyst 12.11 Beta 8 driver. So far (tested it with 6 or 7 reboots) it seems to work. Also switching users works again (but there are some quirks if you try to switch back to the first user again. You have to use ctrl-alt-F7, but that can be a general problem and may be not related to the fglrx driver as it seems to switch to the wrong console if one uses "Switch User" in the xfce menu).

Long story short: No graphic errors and no visible VT cursor so far.

What one has to do after installing the beta driver, is editing the file /etc/ati/signature
After the installation of the beta driver, one gets an unpleasant watermark in the lower right corner of the screen which tells that the driver is for testing purposes only. To get rid of this, edit the mentioned file and replace the content with

9777c589791007f4aeef06c922ad54a2:ae59f5b9572136d99fdd36f0109d358fa643f2bd4a2644d9efbb4fe91a9f6590a145:f612f0b01f2565cd9bd834f8119b309bae11a1ed4a2661c49fdf3fad11986cc4f641f1ba1f2265909a8e34ff1699309bf211a7eb4d7662cd9f8e3faf14986d92f646f1bc

(all in one line)

Hope that helps!

humboink (humboink) wrote :

I updated to Catalyst 12.11 Beta 8 driver, as Hans-Peter suggested.
After the first reboot, it seemed the bug was corrected... but it came back at next reboot.

Nicolas Delvaux (malizor) wrote :

This bug seems to be a bad interaction between lightdm and fglrx.
I switched to GDM and now the problem does not happen anymore.

Nicolas Delvaux (malizor) wrote :

Nevermind, today I got this bug when using GDM.

no longer affects: lightdm

Update: As BorisH mentioned, the bug is still there after updating to Catalyst 12.11 Beta 8. It does not happen that often anymore for me, but it still happens.

Just updated to Catalyst 12.11 Beta 11. Bug is still there.

Marcin Dancewicz (mdancewicz) wrote :

This affects me too on Ubuntu 12.10 and AMD Radeon HD 7800.

Sebastian H. (sebastianh) wrote :

I got around this by configuring uvesafb.

Not sure if this is the same bug but I also get this too with 13.1, Ubuntu 12.10 x86_64.

http://www.youtube.com/watch?v=4Fp8rpKaMT4

jave (javeivanovski) wrote :

I get the flashing cursor when Ubuntu updates the kernel? I can also get rid of the cursor by logging out then logging back in.

Brendon Rapp (legion28) wrote :

Along the same lines as Sebastian H., I solved this problem by disabling framebuffer (specifically, by uncommenting the GRUB_TERMINAL=console line in /etc/default/grub, and re-building the grub config).

I may try uvesafb like Sebastian did to restore framebuffer functionality, but it's not a pressing issue for my use case.

Akarsh (akarsh-es) wrote :

It affects me on HD4670. And something I have noticed is that if my comp is connected to an ethernet connection it usually does not come up.

Confirmed with ATI Radeon HD 7750 and AMD Catalyst 13.1 on Ubuntu 12.10 . In many cases (but not frequently) the whole screen turns black for a few seconds (1 or 2 seconds).

The blinking rectangle corresponds to a console cursor at tty7, i was able to see the console's text, but I don't know how to reproducte this effect.

Nicolas Delvaux (malizor) wrote :

No more problem on Ubuntu 13.04 for me.

I run Xubuntu 12.04.3 LTS 64 bit version. I also have this problem with fglrx and fglrx-updates.

Logging out and back in solves the issue. This issue doesn't show up on every boot, it happens about one in every three or four boots.

I meant to say that logging out and back in solves the issue for that session only.

Changed in unity:
status: New → Confirmed
Will Cooke (willcooke) wrote :

Sorry folks, but as part of the bug clean up ahead of 16.04 I'm marking this as invalid because it affects an Ubuntu release which is now unsupported. If you can still recreate this bug in a supported release please do open a new bug and we can triage it for consideration in the 16.04 development cycle.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers