Unity panel shadow appears as solid black bar on GLES/ARM (Pandaboard, Nexus 7)

Bug #1055949 reported by Paul Larson on 2012-09-25
60
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Won't Fix
Medium
Unassigned
ubuntu-nexus7
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

On the 20120924 image on Panda, I'm seeing a black bar up at the top of the screen just under the menubar. It goes all the way across, but behind the icons on the left. Moving windows over it and removing them does not cause it to ever redraw properly. Screenshot attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-211.18-omap4 3.5.4
Uname: Linux 3.5.0-211-omap4 armv7l
.tmp.unity.support.test.0:

ApportVersion: 2.5.2-0ubuntu4
Architecture: armhf
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Mon Sep 24 23:34:27 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 pvr-omap4, 1.9.0.5.1.1, 3.5.0-211-omap4, armhf: installed
 pvr-omap4, 1.9.0.5.1.1, 3.5.0-211-omap4, armv7l: installed
EcryptfsInUse: Yes
GraphicsCard:

InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta armhf+omap4 (20120924)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: ro quiet splash root=UUID=47ac6515-38e5-4a8a-a31d-0f59c4a76865
Renderer: Software
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
version.compiz: compiz 1:0.9.8.2+bzr3377-0ubuntu1
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu1

Paul Larson (pwlars) wrote :
Didier Roche (didrocks) on 2012-09-25
tags: added: gles
summary: - black bar at top of screen on Panda
+ Unity panel shadow appears as solid black bar on GLES/ARM (Pandaboard)
affects: compiz → unity
no longer affects: compiz (Ubuntu)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :

There's a small chance that the fix for bug 1057528 will resolve this.

Francis Ginther (fginther) wrote :

Fix for bug 1057528 does not appear to solve this issue. Still seeing it with: unity 6.8.0+bzr2785sruubuntu0+797 from ppa:unity-team/sru.

Tested on a pandaboard.

Daniel van Vugt (vanvugt) wrote :

It was a small chance. I always expected the cause of this bug was different and specific to GLES.

Daniel van Vugt (vanvugt) wrote :

I truly thought I should be able to reproduce this on x86 if I built for GLES. But the panel shadow is just working, properly. :/

Though I can only test lp:unity/6.0 and lp:nux/3.0 right now because the trunks have too many bugs (build failures and crashes) to test on GLES right now.

summary: - Unity panel shadow appears as solid black bar on GLES/ARM (Pandaboard)
+ Unity panel shadow appears as solid black bar on GLES/ARM (Pandaboard,
+ Nexus 7)
Changed in unity:
milestone: none → 7.0.0
Chris Wayne (cwayne18) wrote :

This was fixed on the first release of the Nexus 7 image. Marking fix released for that project.

Changed in ubuntu-nexus7:
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

I think you're wrong. The Nexus 7 has no panel shadow at all (probably to hide this bug?)

Alex Chiang (achiang) wrote :

Hi Chris,

We re-opened this task because it was a hack for the Nexus 7 (simply by commenting out the shadow completely) which is not a proper fix.

Thanks.

Changed in ubuntu-nexus7:
status: Fix Released → Confirmed
importance: Undecided → Medium
Bryce Harrington (bryce) on 2012-11-08
tags: added: tegra3
Oliver Grawert (ogra) wrote :

definitely still there in raring

Daniel van Vugt (vanvugt) wrote :

I suspect the root cause here is the same as GLES bug 1039435. In both cases we seem to be using textures in a way that GLES/ARM devices don't support (non-power-of-2?). Should be a simple problem... ?

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity:
milestone: 7.0.1 → 7.3.1
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Raring):
status: Confirmed → Won't Fix
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Andrea Azzarone (azzar1) wrote :

We no longer support unity 7 on nexus 7.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-nexus7:
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Won't Fix
milestone: 7.3.3 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers