compiz crashed with SIGSEGV on Unity "Unmount" in async_wrapper_callback() from g_simple_async_result_complete() from _g_simple_async_result_complete_with_cancellable() from unmount_reply()

Bug #1055812 reported by Dirk Lehmann on 2012-09-24
120
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
6.0
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Quantal
High
Marco Trevisan (Treviño)

Bug Description

[Impact]

Crasher related to device mounting handling

[SRU TESTCASE]

1) Attach an USB stick to your computer
2) Click on the USB device launcher icon so that it gets mounted
3) Right click on the USB icon and click "Umount"

What should happen:
4) The usb stick is unmounted (the icon is removed from the launcher)
   with no unity crashes.

[Regression potential]

Test the testcase and volume handling in general, shouldn't affect anything else.

---------------------

I can find a existing bug report. I get this crash after a restart of the system.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: compiz-core 1:0.9.8.2+bzr3377-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Sep 24 23:12:11 2012
Disassembly: => 0x0: Cannot access memory at address 0x0
DistUpgraded: 2012-08-14 21:13:32,503 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c072]
   Subsystem: Samsung Electronics Co Ltd Device [144d:c072]
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: SAMSUNG ELECTRONICS CO., LTD. N150
ProcCmdline: compiz
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=aae38911-dfa1-41a0-9919-44adcbf61e2a ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/i386-linux-gnu/gio/modules/libgioremote-volume-monitor.so
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/i386-linux-gnu/gio/modules/libgvfsdbus.so
Title: compiz crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: Upgraded to quantal on 2012-08-14 (41 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 03/27/2010
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 01KB.M073.20100327.JIP
dmi.board.asset.tag: SAMSUNG
dmi.board.name: N150
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr01KB.M073.20100327.JIP:bd03/27/2010:svnSAMSUNGELECTRONICSCO.,LTD.:pnN150:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnN150:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct10:cvrN/A:
dmi.product.name: N150
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.8.2+bzr3377-0ubuntu1
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu1

Related branches

Dirk Lehmann (dlehmann69) wrote :
visibility: private → public

StacktraceTop:
 ?? ()
 async_wrapper_callback (source_object=0xb4e44c90, res=0xb4e2a0b0, user_data=user_data@entry=0x919ab68) at gproxyshadowmount.c:315
 g_simple_async_result_complete (simple=simple@entry=0xb4e2a0b0) at /build/buildd/glib2.0-2.33.14/./gio/gsimpleasyncresult.c:775
 _g_simple_async_result_complete_with_cancellable (result=0xb4e2a0b0, cancellable=0x0) at gvfsdaemondbus.c:736
 unmount_reply (proxy=0x94e5300, res=0x962eae0, user_data=user_data@entry=0x9ac6c58) at gdaemonmount.c:221

Changed in compiz (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in g_simple_async_result_complete()
+ compiz crashed with SIGSEGV in async_wrapper_callback()
tags: removed: need-i386-retrace
summary: - compiz crashed with SIGSEGV in async_wrapper_callback()
+ compiz crashed with SIGSEGV in async_wrapper_callback() from
+ g_simple_async_result_complete() from
+ _g_simple_async_result_complete_with_cancellable() from unmount_reply()
affects: compiz (Ubuntu) → unity (Ubuntu)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
summary: - compiz crashed with SIGSEGV in async_wrapper_callback() from
- g_simple_async_result_complete() from
+ compiz crashed with SIGSEGV on Unity "Unmount" in
+ async_wrapper_callback() from g_simple_async_result_complete() from
_g_simple_async_result_complete_with_cancellable() from unmount_reply()
Changed in unity:
milestone: none → 7.0.0
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
description: updated
description: updated
Felix Möller (felix-derklecks) wrote :

I was hit by this a few minutes ago with 6.8.0-0ubuntu2, is this expected?

Daniel van Vugt (vanvugt) wrote :

Yes, I think. The fix does not get released till 6.10. And if you look at the top of this bug it doesn't show as released in any /ubuntu/ yet.

Hello Dirk, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

No crash observed anymore.

tags: added: verification-done
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Dirk, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

No crash with ubuntu2 version either with the test case.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Hmm, not really fixed properly? --> bug 1102926

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.