dash preview animation is slow on high resolution screens (also fullscreen mode)

Bug #1055126 reported by Achim on 2012-09-23
144
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
6.0
Won't Fix
High
Unassigned
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Description: Ubuntu quantal (development branch)
Release: 12.10

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
unity:
  Installed: 6.6.0-0ubuntu1
  Candidate: 6.6.0-0ubuntu1
  Version table:
 *** 6.6.0-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status
compiz:
  Installed: 1:0.9.8.2+bzr3377-0ubuntu1
  Candidate: 1:0.9.8.2+bzr3377-0ubuntu1
  Version table:
 *** 1:0.9.8.2+bzr3377-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
Animations should be smooth.

4) What happened instead
When I maximize the dash and right-click on an item with blur enabled the animation is almost
not visible, because it isn't really smooth.
If I disable blur everything is smooth. FYI scrolling is smooth with blur enabled.

To my mind Unity seems to do some expansive operations, because my system should
really be capable of running unity smooth, which is true for most parts of the shell.

If you need more information, please let me know.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sun Sep 23 20:05:16 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.2)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Achim (ach1m) wrote :
summary: - unity right-click animation is slow with blur enabled
+ unity right-click animation in dash is slow with active blur enabled

Not sure why but this animation is quite unexpectedly smooth (enough) even on my netbook.

Bilal Akhtar (bilalakhtar) wrote :

I was able to successfully reproduce this. It's an issue that pops up only when the screen resolution is high (above 1440:900, it's very obvious with my 1920:1080) and the dash is set to fullscreen. In my case, it happened on Intel GPU, but since it's more of a compiz performance issue, it should be reproducible on amd and nvidia systems too.

summary: - unity right-click animation in dash is slow with active blur enabled
+ unity right-click animation in dash is slow with active blur enabled and
+ screen res is high
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-09-25
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - unity right-click animation in dash is slow with active blur enabled and
- screen res is high
+ dash preview animation is slow on high resolution screens (also
+ fullscreen mode)
Nick Dedekind (nick-dedekind) wrote :

I think the dash is the first thing to use the new nux animation framework.
Perhaps the animation controller not getting regular frame intervals (supposed to be every 16ms).

I can reproduce this issue on my laptop with maximised dash on 1600x900 (Though I do get a few frames). The preview navigation animation doesn't seem to suffer on my laptop, but it isn't using nux animation.

Changed in unity:
milestone: none → 7.0.0
Nick Dedekind (nick-dedekind) wrote :

Here are some debugging results from dash redraw request while animating. Shows the animation progress of the Easing curve. As you can see, there are a lot more animation intervals when the dash is windowed as opposed to maximised.

Maximized Dash:
Animation update FadeOutCallBack: 1.00
Animation update FadeOutCallBack: 0.90
Animation update FadeOutCallBack: 0.85
Animation update FadeOutCallBack: 0.00

Windowed Dash:
Animation update FadeOutCallBack: 1.00
Animation update FadeOutCallBack: 1.00
Animation update FadeOutCallBack: 1.00
Animation update FadeOutCallBack: 1.00
Animation update FadeOutCallBack: 0.99
Animation update FadeOutCallBack: 0.99
Animation update FadeOutCallBack: 0.98
Animation update FadeOutCallBack: 0.97
Animation update FadeOutCallBack: 0.96
Animation update FadeOutCallBack: 0.93
Animation update FadeOutCallBack: 0.90
Animation update FadeOutCallBack: 0.76
Animation update FadeOutCallBack: 0.60
Animation update FadeOutCallBack: 0.38
Animation update FadeOutCallBack: 0.00

Omer Akram (om26er) on 2012-09-28
no longer affects: compiz (Ubuntu)
Omer Akram (om26er) on 2012-09-28
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
status: Confirmed → Triaged
Jay Taoko (jaytaoko) wrote :

This is a know issue that we are currently working on. The dash to preview animation as introduced some inefficiency in the rendering. A fix will land soon.

Daniel van Vugt (vanvugt) wrote :

Is it bug 1064834 or something different?

Achim (ach1m) wrote :

Daniel, I think it is something different. The updated version of nux doesn't improve the performance for me.

$ apt-cache policy libnux-3.0-0
libnux-3.0-0:
  Installiert: 3.10.0-0ubuntu1
  Kandidat: 3.10.0-0ubuntu1
  Versionstabelle:
 *** 3.10.0-0ubuntu1 0
        100 /var/lib/dpkg/status
     3.8.0-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages

Omer Akram (om26er) wrote :

We definitely want to see this fixed but I don't think Jay will have the time to look into this having different priorities.

Changed in unity:
assignee: Jay Taoko (jaytaoko) → nobody
Walter Ribeiro (wribeirojr) wrote :

This issue is still present in 13.04

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Andrea Azzarone (azzar1) on 2013-04-12
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-04-12
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.04.15-0ubuntu1

---------------
unity (7.0.0daily13.04.15-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Command lens does not close when pressing Alt+F2 (LP: #1167466)

  [ Andrea Azzarone ]
  * dash preview animation is slow on high resolution screens (also
    fullscreen mode) (LP: #1055126)

  [ Marco Trevisan (Treviño) ]
  * Unity makes unneeded copies of Nux DrawList (LP: #1167605)
  * Unityshell uses much of his CPU time only to get tray XIDs from
    PanelController (LP: #1167894)
  * Adding Lens results is more expensive than needed (LP: #1168569)
  * Opening new-window from quicklist static action does not focus the
    newly opened window (LP: #1164483)
  * Launcher pre-processes icons also when the icons have not been
    changed since last draw cycle (LP: #1168556)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3300
 -- Ubuntu daily release <email address hidden> Mon, 15 Apr 2013 04:17:42 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix released in Unity 7.1.0.

Changed in unity:
milestone: 7.0.1 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints