[regression] [Unity 6.6] unityshell makes compiz wake up 80-110Hz (without unityshell 5-10Hz)

Bug #1054088 reported by Daniel van Vugt on 2012-09-21
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
The Ubuntu Power Consumption Project
Undecided
Andrea Azzarone
Unity
Fix Released
High
Andrea Azzarone
6.0
Fix Released
High
Andrea Azzarone
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Critical
Andrea Azzarone
Quantal
Critical
Andrea Azzarone

Bug Description

I noticed compiz is using a lot of CPU and waking up lots since upgrading to unity 6.6 and compiz 0.9.8.2.

With unityshell loaded, compiz wakes up 80-110 times per second. Without unityshell, compiz is waking up 5-10 times per second.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Fri Sep 21 22:27:49 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel van Vugt (vanvugt) wrote :
Changed in unity:
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

Hmm, and now my battery life sucks. It was very good with Unity 6.4/Compiz 0.9.8.0.

Possibly related bugs are:

* bug #917210, which has been fixed some time ago, but which may contain some relevant discussions;
* and bug #961202, which could be fixed together with this one.

no longer affects: compiz (Ubuntu)
Changed in unity:
milestone: none → 6.8
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-09-23
Changed in unity:
status: New → Confirmed
Changed in ubuntu-power-consumption:
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-09-24
Changed in unity:
milestone: 6.8 → 7.0
Didier Roche (didrocks) on 2012-09-25
Changed in unity (Ubuntu Quantal):
importance: High → Critical
Andrea Azzarone (azzar1) on 2012-09-25
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu Quantal):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-09-25
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu Quantal):
status: Confirmed → In Progress
no longer affects: nux
Changed in ubuntu-power-consumption:
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux:
milestone: none → 4.0
Daniel van Vugt (vanvugt) wrote :

Not a nux bug. Only unity is the problem. I am testing the fix now.

Changed in nux:
status: New → Invalid
milestone: 4.0 → none
Changed in nux (Ubuntu Quantal):
status: New → Invalid
Andrea Azzarone (azzar1) on 2012-09-28
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
summary: - [regression] unityshell makes compiz wake up 80-110Hz (without
- unityshell 5-10Hz)
+ [regression] [Unity 6.6] unityshell makes compiz wake up 80-110Hz
+ (without unityshell 5-10Hz)
Daniel van Vugt (vanvugt) wrote :

In case anyone is wondering...
Fix committed to lp:unity at revision 2762.

However the final fix was a few revisions later. I think the final fix is:
bzr diff -r2761..2766

Daniel van Vugt (vanvugt) wrote :

And it also looks like:
Fix committed to lp:unity/6.0 at revision 2745

I wish people would update bugs...

Andrea Azzarone (azzar1) on 2012-09-30
Changed in ubuntu-power-consumption:
status: In Progress → Fix Committed
no longer affects: nux
no longer affects: nux/3.0
no longer affects: nux (Ubuntu)
no longer affects: nux (Ubuntu Quantal)
Changed in nux:
status: New → Fix Committed
milestone: none → 3.8
Changed in nux:
status: Fix Committed → Fix Released

When upgrading to ubuntu 12.10 can reenable PPA disabled by the update. You put the root password but the check is not activated.

papukaija (papukaija) wrote :

@Javier: Please open a new bug for your issue. Thanks.

Changed in ubuntu-power-consumption:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Changed in nux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers