unity launcher should still have option to show device icon 'only when mounted'

Bug #1053704 reported by Doug McMahon on 2012-09-20
144
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

It seems now to only be 'Always' (default), or never via the blacklist though the blacklist is only persistent for internal volumes
You should add a new schema to allow 'only when mounted', individually or in general .

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Sep 20 18:30:27 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120912)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-09-23
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
dozsi (dozsabalint) on 2012-10-04
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Doug McMahon (mc3man) on 2012-10-04
Changed in unity (Ubuntu):
status: Fix Released → Triaged
arpanaut (johnmac) wrote :

This seems to be a regression re. uaer's flexibility as to what is shown in the launcher.
It is an all or nothing choice, I only want mounted volumes showing. as was previously implemented.
Now with some upgrades to packages the "blacklist" option in dconf gets unset and I have to again remove all volumes individually from launcher to rebuild the blacklist.
Very Irritating!
If I may ask, why would anyone want ALL volumes constantly in their launcher when nautilus/files offers easy access?
I know this is not a discussion area, but a quick link to the discussion reguarding the logic of this would be appreciated, Thank You!

VladimirCZ (vlabla) wrote :

And I do not want any disk icons to be shown in the launcher. This is not a wish list issue. Developers have removed that from CCSM voluntarily. So it a regression - lost of functionality. Please, restore previous functional state.

Bachi (m-bachmann) wrote :

Agreed - removing a used feature without any specific reason is a regression and should be treated as such.
I also don't want to see any disk icons in my launcher. Please, restore previous functional state.

Bortnyák Roland (antivirtel) wrote :

I can confirm, doesn't work on 14.04 either. Package info:
unity:
  Installed: 7.2.0+14.04.20140416-0ubuntu1
  Candidate: 7.2.0+14.04.20140416-0ubuntu1
  Version table:
 *** 7.2.0+14.04.20140416-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

JoseLuisTriana (theunfor) wrote :

I confirm too that this has not been fixed in Ubuntu 14.04

unity:
  Instalados: 7.2.0+14.04.20140416-0ubuntu1
  Candidato: 7.2.0+14.04.20140416-0ubuntu1
  Tabla de versión:
 *** 7.2.0+14.04.20140416-0ubuntu1 0
        500 http://mx.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

So, when we couid see the fix?.

Bortnyák Roland (antivirtel) wrote :

BTW., I've tried to add an UUID (FAT32's) to the blacklist, but it does nothing... Please fix that too!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers