Ubuntu

[FFE][UIFe] Dash - land the "more suggestions..." lens

Reported by Olli Ries on 2012-09-20
46
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Critical
Unassigned
unity-lens-shopping
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

= Proposed Change =

Land the Lens that delivers commercial content into the Dash.

= New Package =

unity-lens-shopping

= Effects on Ubuntu =

The feature is packaged up as a Unity Lens and is visible when the user does a global search from the Dash home screen and there are matching suggestions to show. These suggestions show in a new category called 'More suggestions', which is only visible after searching the Dash home screen.

It communicates with a U1 server for it's data. This feature doesn't alter any of the other behaviours in Unity, it's completely isolated.

If there are any issues we can a) remove the package or b) disable the server, and in both cases the users will not see any difference from the standard experience.

= Translations =

Package has six translatable strings.

This is a sabdfl driven project, apologies for being late.

Changed in unity (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-2
Olli Ries (ories) on 2012-09-20
Changed in unity:
importance: Undecided → Critical
status: New → Fix Released
Changed in ayatana-design:
status: New → Fix Released
Iain Lane (laney) wrote :

So I understand that this is a request for a new package, unity-lens-shopping, to be added to the archive and then to be seeded. Here's what I see that you need.

  - A willing archive admin to do NEW review
  - Main Inclusion Request (https://wiki.ubuntu.com/MainInclusionProcess)
  - Once these two are granted, a corresponding change to the seeds (or a Recommends from unity) to pull it in by default.

When can you do the initial upload? This (and NEWing) does not need to block on the main inclusion. I'd prefer it to be done as soon as possible.

Since this is a Mark decision, it doesn't need my approval, but please liaise with the docs team for the UIFe before proceeding.

Iain Lane (laney) wrote :

(and translators, sorry)

Jamie Strandboge (jdstrand) wrote :

MIR review based on earlier code:
 * Builds fine with only main enabled
 * No test suite. Does not meet the acceptance criteria
 * Uses vala, not python
 * Canonical is the upstream
 * Make sure there is a bug subscriber
 * No watch file-- not an issue for this MIR since we are the upstream, but a watch file with proper release tarballs is preferred
 * Lintian clean on source and binaries
 * debian/rules is clean
 * provides a dbus session service
 * no dbus system services or otherwise privileges commands, initscripts/upstart job or cron jobs
 * hardening options are enabled, but PIE and BINDNOW are not. Please compile unity-shopping-daemon with PIE and BINDNOW
 * there are various compiler warnings.

Security review:
As John mentioned, go to global menu. type in something (eg, 'foo'), Foo Fighters and other stuff comes up in 'Treat yourself'. Clicking it opens the browser in amazon. No reason for an audit as we are just passing a URL to the browser.

Something also needs to be done about the lack of a test suite. Rather than just manual tests, it seems the dbus service could be tested easily enough during the build and then add some unit tests for the vala stuff. I'll let Didier decide on what meets acceptance criteria wrt the testsuite though....

I'm told the compiler warnings are not fixable and a problem with vala. Conditional ACK provided it is compiled to build with PIE and BINDNOW.

Archive review:
I reviewed for deNEW and the package looks fine.

Jeremy Bicha (jbicha) wrote :

+1 from the Docs Team.

I got clarification in #ubuntu-desktop that this new lens won't show in the lens bar at the bottom of the dash. With the screenshots we use (which don't show an actual search in progress), this won't affect screenshots. As discussed in other bugs, we're getting some help from Matt Price over the next couple days so that we have at least an opportunity to discuss these features in ubuntu-docs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

Al 20/09/12 17:47, En/na Neil Jagdish Patel ha escrit:
> Hi,
>
> Together with the notification by Olli to ubuntu-devel[0], I wanted to
> let the Docs and Translations teams know of a new package proposal for
> Quantal: unity-lens-shopping[1].
>
> This package provides the "More suggestions" feature to the Dash (during
> home screen search) and has a translation impact of six additional
> strings. The package should be ready for translations, please let me
> know if there are any mistakes in the project etc. I have also spoken to
> David Planella and hopefully have added the right details to the MIR/FFe[2].
>
> Documentation wise, I believe discussions are in progress with Jeremy
> and some help is available from our side to try and ease the burden of
> this landing so late.
>
> On that last point, and just like the email to you guys from John a
> couple days back, I apologise for how late this is landing and I know it
> means you cannot provide the level of quality you normally do. It is
> unacceptable and we will try our hardest to avoid having the same issues
> for 13.04.
>
> [0] https://lists.ubuntu.com/archives/ubuntu-devel/2012-September/035905.html
> [1] h
> <https://bugs.launchpad.net/unity-lens-shopping/+bug/1053470>ttps://launchpad.net/unity-lens-shopping
> [2] https://bugs.launchpad.net/unity-lens-shopping/+bug/1053470
>
> Thank you,
>

Ok, +1 from the translations team after having discussed the details
with Neil. We will also appreciate some help if there is any technical
i18n issue detected with the lens.

Thanks.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Didier Roche (didrocks) wrote :

The needed change for the MIR has been done.

Changed in unity (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in unity-lens-shopping:
status: New → Fix Released
Didier Roche (didrocks) wrote :

Override component to main
unity-lens-shopping 6.0.0-0ubuntu1 in quantal: universe/gnome -> main
unity-lens-shopping 6.0.0-0ubuntu1 in quantal amd64: universe/gnome/optional -> main
unity-lens-shopping 6.0.0-0ubuntu1 in quantal armel: universe/gnome/optional -> main
unity-lens-shopping 6.0.0-0ubuntu1 in quantal armhf: universe/gnome/optional -> main
unity-lens-shopping 6.0.0-0ubuntu1 in quantal i386: universe/gnome/optional -> main
unity-lens-shopping 6.0.0-0ubuntu1 in quantal powerpc: universe/gnome/optional -> main
Override [y|N]? y
6 publications overridden.

mikelococo (mikelococo) wrote :

It's worth noting that this freeze exception:

1) Doesn't discuss the privacy implications of this change. At. All.
2) Doesn't attempt to justify it's importance level of 'critical' in any way.
3) Does it actually use code to obfuscate that the feature is driven by Mark Shuttleworth and not by community consensus or technical requirement? Or is it just common among insiders to use terms like "sabdfl" to refer to Shuttleworth? When circumventing processes due to pressure from key people, it is doubly important to be transparent about that fact and say out loud: "Mark Shuttleworth wants this feature in now, and thinks that it's so important that it doesn't need to abide by normal project processes or require community review. Here's why..."

In retrospect given the community reaction to this change in Bug #1054776, the lack of meaningful review in the freeze exception is pretty frightening.

So the security review missed sending in the clear local file names to a remote source ? Oops.

And given "If there are any issues we can a) remove the package or b) disable the server, and in both cases the users will not see any difference from the standard experience" how about you just do one of those now ?

Stefano Rivera (stefanor) wrote :

Oops, clicked that by accident

Changed in unity (Ubuntu Quantal):
status: Fix Released → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers