[quantal] [regression] Missing panel shadow in Unity 6.4

Bug #1045705 reported by Daniel van Vugt on 2012-09-04
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Daniel van Vugt
unity (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

After upgrading to Unity 6.4 recently, neither of my two quantal machines have a panel shadow any more.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.4.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Tue Sep 4 16:55:26 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.112+bdcom, 3.5.0-10-generic, x86_64: installed
 bcmwl, 5.100.82.112+bdcom, 3.5.0-11-generic, x86_64: installed
 bcmwl, 5.100.82.112+bdcom, 3.5.0-12-generic, x86_64: installed
 bcmwl, 5.100.82.112+bdcom, 3.5.0-13-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:17f8]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
MachineType: Hewlett-Packard HP Folio 13 Notebook PC
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-11-generic root=UUID=b5cafb66-fea2-4ba7-87dd-d5210ec8f1ce ro quiet splash acpi_osi=Linux vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/05/2012
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 17F8
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 46.34
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.06:bd03/05/2012:svnHewlett-Packard:pnHPFolio13NotebookPC:pvr068C100000204A00000320100:rvnHewlett-Packard:rn17F8:rvr46.34:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Folio 13 Notebook PC
dmi.product.version: 068C100000204A00000320100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.8.0-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Related branches

Daniel van Vugt (vanvugt) wrote :
Omer Akram (om26er) wrote :

Its GLES branch related.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 6.6
summary: - [quantal] [regression] Missing panel shadow
+ [quantal] [regression] Missing panel shadow in Unity 6.4
Rainer Rohde (rainer-rohde) wrote :

Same here...

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

It's much worse than I thought. The panel shadow code was completely disabled (just "return;") because it's never worked properly with USE_MODERN_COMPIZ_GL.

Changed in unity:
status: Confirmed → In Progress
Andrea Cimitan (cimi) on 2012-09-12
tags: added: unity-quantal-visuals
tags: added: unity-visuals-quantal
removed: unity-quantal-visuals
Changed in unity:
milestone: 6.6 → none
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

Please make sure the fix for bug 1050704 is released before this one.

Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Omer Akram (om26er) on 2012-09-14
Changed in unity (Ubuntu Quantal):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2698

Changed in unity (Ubuntu Quantal):
assignee: nobody → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity/6.0 at revision 2687

Changed in unity (Ubuntu Quantal):
status: In Progress → Triaged
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in unity:
milestone: none → 7.0
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 6.6.0-0ubuntu1

---------------
unity (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixes non-escaped character sequences in dash previews (LP: #1039020)
    - Updated background layer for preview cover-art and details panels
      to be 10% low-light
    - Expand a PlacesGroup if it is the only category that contains results
      (LP: #950710)
    - Update unity autopilot tests to match autopilot API
    - Updated the convert files to fix some typos in the key names
    - Add gmodule dependency
    - Activate proper result if the categories aren't displayed in-order
      (LP: #1040101)
    - Refactor device launcher icons (LP: #713423)
    - LauncherController: make the controller enable the launcher struts,
      based on hide-mode option (LP: #1044005)
    - Launcher: make always possible to drag an icon to the bottom or top
      of its sub list (LP: #1043968)
    - Don't desat bfb/hud icon in DNDReset (LP: #1043963)
    - Progressively adjust the speed of the minimize animation. First
      time it is used is slower, then speeds up the more it is used.
      (LP: #1017510)
    - Implement new ordering of categories for home lens. (LP: #1043915)
    - UnityWindow now implements ScaleWindowInterface (LP: #876017)
    - Launcher: restore an icon position after that the dragging has been
      cancelled (LP: #955561)
    - LauncherDragWindow: cancel drag on window mapped/unmapped
      (LP: #1044723)
    - Now there is a check of an override color in RefreshColor (which is
      called when a PropertyNotify event happens). Also added a check in
      FullySaturateColor to a void division by zero. (LP: #975350)
    - Queue redraw after cover-art texture is updated from a url/file source.
      (LP: #1043947)
    - Fixed ability to delete glib::Source wrapper during its callback
      (LP: #1044823)
    - Close preview when dash is hidden. (LP: #1045298)
    - LauncherModel: rewrite the Reordering functions to keep the icon
      priority deltas (LP: #761155)
    - Make sure we can pass extra hints when activating preview actions.
      (LP: #1046352)
    - UnityWindow: scale window code improved (LP: #1033935)
    - The mouse will now cause the HUD buttons to change selection
      (LP: #1042692)
    - "Alt+Space" shortcut to reveal the window menu is not hardcoded, but a
       Compiz key option. " (Hold)" should also be translated. Made all
       Compiz plug-in names and all Compiz plug-in option names in
       unityshell.cpp static constants.
    - remove unity --reset, it's not anymore really needed now that we are
      in stable days of unity and we moved to gsettings
    - Removed the variables 'oldPrev' and 'oldNext' which got assigned the
      value NULL, but then were never used
    - Fixed the size of the previews to 770x380 pixels. (LP: #1045243)
    - UnityWindow: use smart pointers, use static close_icon (with dynamic
      state) and PanelStyle context (LP: #1033935) (LP: #1045127)
      (LP: #1046124) (LP: #1046126)
    - Remove everything in the #ifndef USE_MODERN_COMPIZ_GL ifdefs and remove
      the ifdefs alltogether. unity now requires compiz...

Read more...

Changed in unity (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers