unity spread window on second click not working when ibus language panel is shown.

Bug #1035895 reported by Apple Lam on 2012-08-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Brandon Schaefer
6.0
Fix Released
Low
Brandon Schaefer
unity (Ubuntu)
Low
Brandon Schaefer

Bug Description

I can´t spread window by click twice on the unity launcher after setting for something in ibus, and I am not sure is this a ibus problem.

Problem Reproduce Video (<1min): http://www.sendspace.com/file/wkt5n6
- Open some windows to check if spread window function works normally.
- Change some setting in ibus makes language panel shown.
- Click on launcher to check if spread window function works normally.

Expected result: It works normally as the video shown.
Happened instead: Nothing happened and I am bored to press Alt+Tab again.

Using Ubuntu 12.04 LTS

ibus versions
- ibus - 1.4.1-3ubuntu1
- ibus-pinyin - 1.4.0-1

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Sun Aug 12 22:20:55 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Apple Lam (smallapplelam) wrote :
Omer Akram (om26er) wrote :

set 'show settings panel' to 'always' inhibits this issue. Confirmed here on both 12.04 and 12.10

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
milestone: none → 6.4
assignee: Brandon Schaefer (brandontschaefer) → nobody
Omer Akram (om26er) wrote :

I'll have a talk with Brandon before assigning.

Changed in unity:
milestone: 6.4 → 6.6

This happens not of ibus but because that language panel is always on top. This means when we try to activate scale it doesn't think the application you are clicking has been raised to the top, because of the panel...so scale never activates. (This happens as well when onboard is open...)

Soo I would suggest either expanding this bug to include Any window that is always on top causes spread to not work in the launcher....

summary: - unity spread window on second click not working when ibus language panel
- is shown
+ Unity spread fails when clicking on a launcher icon twice if there is a
+ window always on top.
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Confirmed → In Progress
description: updated
description: updated

Actually it turns out I was wrong...very odd. It is as if the ibus language panel is not set to always on (X wise) but still is...

Sorry for changing the title....

Im looking into this...though it could be an ibus bug.

summary: - Unity spread fails when clicking on a launcher icon twice if there is a
- window always on top.
+ unity spread window on second click not working when ibus language panel
+ is shown.

The problem is the language panel that ibus makes is a gtk.WINDOW_POPUP. The window doesn't have _NET_WM_STATE_ABOVE nor is it a dialog window (which should be set for a popup IIRC). I should be able to figure something out soon...

Omer Akram (om26er) on 2012-09-12
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Confirmed → In Progress
Omer Akram (om26er) wrote :

@brandon, any update on this?

@Omer yeah, I a fix for it (tell unity to ignore windows that have the override redirect set for it). Ill have a branch out later today!

Changed in unity:
milestone: 6.6 → 7.0
Changed in unity:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2745
Fix committed into lp:unity/6.0 at revision 2745 (not a typo)

Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers