Software center launcher integration - cancelled install is not removed from launcher

Bug #1027209 reported by Nice Testhouse on 2012-07-20
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Medium
Bilal Akhtar
software-center (Ubuntu)
Medium
Gary Lasker
Precise
Undecided
Iain Lane
unity (Ubuntu)
Medium
Bilal Akhtar
Precise
Undecided
Unassigned

Bug Description

[Description]

When installing an application, the icon for it is added from launcher even if the installation is cancelled.

[Test Case]

Follow the below steps to see the issue:
#. Open software-center
#. Click on install on a big application like wesnoth
#. Wait until the "In Progress" appears in the toplevel toolbar of s-c
#. Click on the "In Progress" button in the toolbar
#. Click on the "cancel" button of the install of the application
What happens:
The application's icon is added to the Unity launcher at the moment of cancellation.
What should happen:
The application's icon is not added to the launcher on an install cancellation.

[Regression Potential]

Should be low; just adds an extra signal to not be called instead of "transaction-stopped" when the transaction (installation) is cancelled. All on_transaction_complete does that on_transaction_cancelled doesn't is add the application to the launcher, which is explicitly what we're trying to avoid doing here.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.0.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-5.5-generic 3.5.0-rc7
Uname: Linux 3.5.0-5-generic i686
ApportVersion: 2.4-0ubuntu3
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Fri Jul 20 19:49:16 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120713.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Nice Testhouse (testhouse) wrote :
Omer Akram (om26er) wrote :

due to some reason I can't see the flying animation of the icon and the launcher icon is added only after the installation is completed.

Bilal Akhtar (bilalakhtar) wrote :

This has been fixed in the Precise 5.0 branch, as the change was made to send the icon only after installation is complete. It's still this way in Quantal because the "flying icon at the start of install" behavior will return in Quantal with a few bug fixes.

Changed in unity:
status: New → In Progress
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in unity (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
importance: Undecided → Medium
Omer Akram (om26er) on 2012-07-24
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Medium
Nice Testhouse (testhouse) wrote :

Week 30- same issue observed on ubuntu 12.10 quantal (Nvidia) with ppa:SIL2100

The icon does not fly into launcher once the installation of wesnoth starts.

After cancelling the installation, icon flies into launcher and shows as "Waiting to install".

Nice Testhouse (testhouse) wrote :

Week 33 - Ubuntu 12.10 Quantal with ppa:timo-jyrinki/prerelease

Same issue observed.

Action and observation:-
-Open software centre and install "Wesnoth"
- Click on progress bar
- Now cancel the installation midway -----> Icon for application "Wesnoth" flies into the launcher
- Cancel action is complete -----> Icon for application "Wesnoth" stays on launcher, moving the mouse on this icon shows the name "Battle for Wesnoth(1.10)" and clicking on this icon makes the icon saturate and de-saturate in appearance a few times and icon is back to normal saturated look.

description: updated
Omer Akram (om26er) wrote :

@bilal, what's the status update about this bug in Quantal?

Bilal Akhtar (bilalakhtar) wrote :

@Omer: I'll add it by next week. Haven't started working on this but will start in a day or two.

Bilal Akhtar (bilalakhtar) wrote :

This seems like a software-center bug. Icons aren't sent anymore at the start of installation, and it seems like Software Center sends the AddLauncherIcon call AFTER the cancellation is complete.

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
Nice Testhouse (testhouse) wrote :

@Bilal - Yes, the icon is made to fly into the launcher at the end of the installation in a newer version of the software center.

Sorry, the issue here is different. Once an installation is cancelled, the corresponding icon for the app is expected to be removed from the launcher. The icon flies into launcher after pressing the cancel button.

Issue : The icon is not removed from launcher even after the installation is cancelled.

Follow the below steps to see the issue:
#. Open software-center
#. Click on install on a big application like wesnoth
#. Wait until the "In Progress" appears in the toplevel toolbar of s-c
#. Click on the "In Progress" button in the toolbar
#. Click on the "cancel" button of the install of the application
Expected Result:
The icon is removed from the launcher after the download was cancelled.

Bilal Akhtar (bilalakhtar) wrote :

That's surprising, because it *should* be removed if the code works alright. My installs of Quantal are borked right now so I won't be able to test this for a day or two.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Nice Testhouse (testhouse) wrote :

Week 34 - Same issue observed on Ubuntu 12.10 Quantal with ppa:timo-jyrinki/prerelease with machines (Intel,Radeon,Nvidia).

Icon moves to launcher on click of cancel button (Cross button) and stays on launcher even after the installation cancel is complete.

Nice Testhouse (testhouse) wrote :

Additional information - The icon stays on launcher and remains there even after restarting the machine, the only change is the image of "Battle of Wesnoth" on the icon is replaced by a default question mark grey icon image.

Nice Testhouse (testhouse) wrote :

Week 35 - Same issue observed on ubuntu 12.10 quantal with ppa:unity-team/release

Nice Testhouse (testhouse) wrote :

Week 36 - Same issue observed on ubuntu 12.04 precise with ppa:unity-team/sru

Changed in software-center (Ubuntu):
importance: Undecided → Medium
Gary Lasker (gary-lasker) wrote :

Indeed, Software Center is incorrectly sending the add-to-launcher signal to Unity when an install is cancelled. I'll close out the Unity side bug tasks as this is a bug on the Software Center side. Thanks everyone for your comments,, we'll work on this one very soon!

Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.10
Gary Lasker (gary-lasker) wrote :

Just a quick note that USC is in fact getting a "transaction-finished" signal emitted from the aptd backend on a cancellation of the install.

Changed in software-center (Ubuntu):
status: Triaged → In Progress
tags: added: ca-escalated
Gary Lasker (gary-lasker) wrote :

The attached branch adds a new signal from aptd called "transaction-cancelled" that is fired accordingly, and wires it into the Software Center code.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.14

---------------
software-center (5.3.14) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/trivial-renaming,
    lp:~mvo/software-center/trivial-rename2:
    - drop the Gtk suffix from two more classes and rename
      catview_gtk.py to catview and split out lobbyview
  * lp:~mvo/software-center/pep8-again:
    - add the software-center top level to the pep8 check
      and fix its pep8 errors
  * lp:~mvo/software-center/make-currency-part-of-the-db:
    - move the currency field into the database itself
  * lp:~mvo/software-center/merge-prev-purchases-lp969273:
    - change the way reinstall previous purchases is done,
      fixes double entries in the db, and items already
      purchased will display properly and will no longer
      display a price (LP: #969273)
  * lp:~mvo/software-center/login-cleanup:
    - refactor and cleanup the login backend code, remove
      the unused interfaces for launchpad ppas
  * lp:~mvo/software-center/lp1034894-again:
    - fix the navigation buttons to be displayed as a
      single button style (LP: #1034894)
  * lp:~mvo/software-center/extra-unity-categories:
    - provide an ascii-only stable alias name for use
      by Unity for "Top Rated" and "What's New"
  * lp:~mvo/software-center/dataprovider-desktop-dependency-property:
    - add "is_desktop_dependency" property for the unity people
      (LP: #1047315)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/handle-trans-cancel-lp1027209:
    - don't add an application to the Unity launcher for the case
      where an installation is cancelled (LP: #1027209)
 -- Michael Vogt <email address hidden> Tue, 18 Sep 2012 10:37:32 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Nice Testhouse (testhouse) wrote :

Week 38- On ubuntu 12.10 quantal with ppa:unity-team/staging , this works fine.
No icon is sent to the launcher until installation is almost complete.
No icon is sent to the launcher after cancel button is pressed.

description: updated
Iain Lane (laney) on 2013-01-17
Changed in unity (Ubuntu Precise):
status: New → Invalid
Changed in software-center (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) on 2013-01-17
description: updated
David Pitkin (dpitkin) on 2013-01-17
tags: removed: ca-escalated

Hello Nice, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Executing the test case on 5.2.9 from precise-proposed, seems fixed.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.9

---------------
software-center (5.2.9) precise-proposed; urgency=low

  [ Brian Murray ]
  * software-center/paths.py:
    - modify the OEM_CHANNEL_DESCRIPTOR path (LP: #1095823)

software-center (5.2.8) precise-proposed; urgency=low

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/handle-trans-cancel-lp1027209-for-5.2:
    - backport of the transaction cancellation fix for bug LP: #1027209.

  [ Michael Vogt ]
  * lp:~mvo/software-center/robustness-lp1054070
    - cherry pick fix for corruption fix LP: #1054070
 -- Brian Murray <email address hidden> Mon, 28 Jan 2013 09:14:24 -0800

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers