firefox profile launched from second launcher combines with first

Bug #1022197 reported by Bjorn Hansen on 2012-07-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Triaged
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

I have created a second launcher for firefox (for launching an alternate profile) and pinned it to the unity bar. I also modified the original slightly so that I can run both profiles at once. The two launchers run the following commands:

firefox %u -P default -no-remote
firefox -P Bjorn -no-remote

up until a recent update (I think in the last week, but I'm not sure), this worked great; each launcher worked independant of the other, launching the intended instance if it wasn't already running, and switching to it if it was. Now suddenly when I click the second one (Bjorn profile), it launches the correct instance, but the small arrow that's normally to the left of the launcher indicating an open window/running instance is instead shown next to the first launcher (for the default profile).

This is rather inconvenient as if the default profile instance isn't already running, I can no longer use that launcher to launch it because it simply activates/focuses the already open window from the second profile. As a workaround I currently always launch the default profile first, and then the other (so I now have two arrows to the left of the default launcher - as illustrated in the attached screenshot), but it's still inconvenient because it's now two clicks to switch; click on the default launcher and then choose the window I want. Clicking on the second launcher just informs me that "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

The expected behavior, I believe, is that a launched application should always get associated with the launcher it was started from (as it used to).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Sat Jul 7 21:29:14 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Bjorn Hansen (holomorph) wrote :
Sebastien Bacher (seb128) wrote :

That's still an issue, unsure if that's by design though, they are the same application...

Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers