compiz crashed with SIGSEGV in unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()

Bug #1020075 reported by Rainer Rohde on 2012-07-02
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
5.0
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
Critical
Unassigned

Bug Description

[Test Case]
No clear test case. Ensure that unity does not crash when adjusting screen settings or after login.

[Regression Potential]
Launchers not put correctly on multiple monitors, edge barriers broken.

Original description:

This happened when adjusting my second monitor to be twin view and w/o sticky edges.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: compiz-core 1:0.9.8+bzr3249-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
Uname: Linux 3.5.0-2-generic x86_64
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
Date: Mon Jul 2 07:34:15 2012
Disassembly: => 0x3d77: Cannot access memory at address 0x3d77
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120629)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x3d77: Cannot access memory at address 0x3d77
 PC (0x00003d77) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent(unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent>) () from /usr/lib/compiz/libunityshell.so
 sigc::internal::slot_call2<sigc::bound_mem_functor2<void, unity::ui::EdgeBarrierController::Impl, unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent> >, void, unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent> >::call_it(sigc::internal::slot_rep*, unity::ui::PointerBarrierWrapper* const&, std::shared_ptr<unity::ui::BarrierEvent> const&) () from /usr/lib/compiz/libunityshell.so
 unity::ui::PointerBarrierWrapper::EmitCurrentData() () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 (compiz:1883): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed
 gnome-session[1806]: WARNING: Application 'compiz.desktop' killed by signal 11
 gnome-session[1806]: WARNING: App 'compiz.desktop' respawning too quickly
 gnome-session[1806]: CRITICAL: We failed, but the fail whale is dead. Sorry....
 (compiz:2518): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed

Related branches

Rainer Rohde (rainer-rohde) wrote :
visibility: private → public

StacktraceTop:
 ?? ()
 unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent (this=0x2c757c0, owner=0x3c5a000, event=...) at /build/buildd/unity-5.12/plugins/unityshell/src/EdgeBarrierController.cpp:139
 operator() (_A_a2=..., _A_a1=<optimized out>, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/mem_fun.h:1917
 operator()<unity::ui::PointerBarrierWrapper* const&, const std::shared_ptr<unity::ui::BarrierEvent>&> (_A_arg2=..., _A_arg1=<optimized out>, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/adaptors/adaptor_trait.h:103
 sigc::internal::slot_call2<sigc::bound_mem_functor2<void, unity::ui::EdgeBarrierController::Impl, unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent> >, void, unity::ui::PointerBarrierWrapper*, std::shared_ptr<unity::ui::BarrierEvent> >::call_it (rep=<optimized out>, a_1=<optimized out>, a_2=...) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:173

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: compiz-0.9
Rainer Rohde (rainer-rohde) wrote :

This happened when moving the Thunderbird window to my second monitor on the right...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
AlexHarrowell (a-harrowell) wrote :

I'm experiencing this bug immediately after login on Ubuntu Quantal 12.10 for x86-64, on a ThinkPad X200S with 8GB of RAM and an Intel graphics card.

Steps to reproduce:

1) Update packages in the branch to current status
2) Reboot
3) A normal login screen is presented
4) Log in with your password

Symptoms:

Graphical controls don't start. Launcher and toolbar absent. Window management elements absent. Desktop icons are present.

Underlying system is functional from the CLI. Mozilla Firefox is available if you launch it via the bug reporting tool. Document Viewer (evince) is functional, but missing the window bar. OpenOffice is functional.

Stacktrace, segfault analysis etc. is identical with this bug except that the memory location is given as 0x0.

Problems began with a similar failure, which produced a crash report relating to nautilus and saying that nautilus, libcups2, libgail-3-0, libgtk-3-0, libgtk-3-common needed updating. Updating relieved the nautilus crash and got rid of a nautilus trap int3 error from syslog, but replaced it with the compiz crash.

Compiz debug output shows that various files are not found at first attempt but are eventually traced.

Andy (smiffy75) wrote :

This happens reliably on an Acer Aspire Timeline X laptop when I plug in an external monitor. I never had this problem before 12.04.

Daniel van Vugt (vanvugt) wrote :

Looks like a regression of bug 983268. Assuming bug 983268 was properly fixed.

affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 6.2
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2012-09-05
Changed in unity (Ubuntu Precise):
importance: Undecided → Critical
status: New → Fix Committed
description: updated

Hello Rainer, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Florian Stoll (flostoll) wrote :

After testing 5.16.0-0ubuntu1 some days without any compiz crashes I think it fixed stability problems. I am working with the internal and an external screen and before this upgrade sometimes compiz crashed by clicking on the launcher to start an application. I did not get that error by adjusting screen settings.

I frequently change resolution and screen setup (add/removing external displays etc) on 12.04 and haven't had this crash with -proposed enabled. Seems good.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.16.0-0ubuntu1

---------------
unity (5.16.0-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - Update libgeis-dev and libgrail-dev dependencies in debian/control
  * New upstream release.
    - launcher is not refreshed after user session switch (LP: #1016430)
    - Dragging windows around is slow/sluggish/laggy when multiple monitors
      are enabled (LP: #874619)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - Tooltips backgrounds are not refreshed (no active blur) (LP: #967112)
    - [regression] Unity panel transparency (active blur) not updating properly
      (LP: #865006)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Black background around after dash is restored (LP: #992516)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - [SRU regression] alt-grave not switching to next window unless 'grave'
      pressed twice (LP: #1035668)
    - [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
      incomplete/missing (LP: #1034164)
    - [nvidia] unity crashed in
      nux::GraphicsEngine::QRP_GLSL_1Tex (glDrawArrays) (LP: #1031554)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Compiz won't start if "unredirect fullscreen windows" is enabled
      (LP: #980663)
    - [regression] Unity launcher on-screen corruption on resume from suspend
      with nVidia proprietary driver (LP: #915265)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - [nvidia] compiz crashed with SIGSEGV in
      nux::BasePainter::PaintBackground (LP: #982626)
    - Update dependency on the renamed libgeis

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest nux as libgeis-dev and libutouch-geis-dev are
      conflicting (LP: #1047385)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Sep 2012 10:53:17 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

peterstan (stasnel) on 2015-04-05
Changed in unity (Ubuntu Precise):
assignee: nobody → peterstan (stasnel)
Changed in unity (Ubuntu Precise):
assignee: peterstan (stasnel) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers