Unity GPU memory usage

Bug #1019616 reported by Alex on 2012-06-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I have noticed that after i upgraded to ubuntu 11.10 my graphics are slower and choppy. 3D Apps are not smooth. Even firefox has as bad time in rendering/scrolling a page. I am running 12.04 right now, fully updated.

I've done some research and came to the conclusion that unity fills to much of my memory AFTER i use the DASH. After a little bit of browsing through the lenses my graphics are very chopy.
I run: nvidia-smi -q -g 0 2>&1
and got:
Memory Usage
        Total : 127 MB
        Used : 120 MB
        Free : 7 MB
While it used only 80MB on startup. You may think that 127MB is very low but then why does gnome shell with effects runs smoothly? By the way, my card has 512MB, i don't know why it is getting list as 127MB.... perhaps that's another bug.

Pls tell me what you thing about this.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 295.40 Thu Apr 5 21:28:09 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu10
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom]
CompositorRunning: compiz
Date: Sat Jun 30 18:57:24 2012
DistUpgraded: 2012-04-27 00:15:44,763 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:34ee]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 090c:71b3 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.)
 Bus 002 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
MachineType: Gigabyte Technology Co., Ltd. M68MT-S2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic root=UUID=0c47a693-8a87-4d0d-adbd-e0d173bf7167 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-04-26 (64 days ago)
dmi.bios.date: 11/15/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F1
dmi.board.name: M68MT-S2
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF1:bd11/15/2010:svnGigabyteTechnologyCo.,Ltd.:pnM68MT-S2:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnM68MT-S2:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: M68MT-S2
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Alex (icidrop) wrote :
Omer Akram (om26er) wrote :

Can you please try unity 5.14-0ubuntu1 from precise-proposed, check and let us know if that fixes the issue for you.?

Changed in unity (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 982434, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Nicolay Doytchev (lightrush) wrote :

I'm sorry but how is this a duplicate of that bug? This is about graphics memory. The other bug is about system memory. I am observing the exact same issue and my system indeed has 128MB graphics RAM. As soon as it gets past 115MB full, everything starts to lag. If I reduce texture quality, turn on compression remove blurs and animations, the system manages to stay slightly below this threshold and run fine.

In contrast in KDE - Kubuntu 12.10, my graphics RAM does not go past 80MB of usage and EVERYTHING runs smooth.

This that manifests itself on several systems with 128MB VRAM NVIDIA cards.

Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.