logging out/in with mounted drives causes unity launcher icons to be duplicated

Bug #1010714 reported by Doug McMahon on 2012-06-08
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone
Quantal
Medium
Andrea Azzarone

Bug Description

Happens with all drives whether internal or external
Test Case
mount a drives(s) so icon is in unity launcher
Log out, then in
Icon(s) will be duplicated

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 5.12-0ubuntu3
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,place,mousepoll,vpswitch,regex,text,gnomecompat,dbus,workarounds,commands,fade,resize,session,move,cube,expo,scale,ezoom,rotate,scaleaddon,unityshell]
Date: Fri Jun 8 18:54:21 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120603)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Omer Akram (om26er) wrote :

Doug, was that the case in Precise for you?

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

confirming the bug on Quantal.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 6.0

On 06/10/2012 03:25 AM, Omer Akram wrote:
> Doug, was that the case in Precise for you?
>
> ** Changed in: unity (Ubuntu)
> Status: New => Confirmed
>
No, fine in precise & 12.10 until I believe the upgrade of gvfs* to
1.13.0-0ubuntu3. - ' Install udisks2 monitor instead of the gdu one '
( not having changelogs directly available in synaptic or
update-manager atm is getting to be a real pita

Should be fairly easy to double check, I don't think it would be hard to
downgrade that package set.
In any event only seems to affect Unity here, unity-2d is ok

Doug McMahon (mc3man) wrote :

2nd variation of bad behavior

Test Case:
Mount an internal drive, lock to the Unity launcher
Unmount the drive, then log out/in or do a full restart
2 icons for the same drive will show in the launcher, drive is not mounted. Both icons can be removed separately with a r. click > Unlock from Launcher'

Downgrading gvfs* to the 1.13.0-0ubuntu1 version & none of this happens

Omer Akram (om26er) wrote :

bug 1010858 could be related.

Doug McMahon (mc3man) wrote :

There seem to be numerous possibilities to get doubled up icons in the unity launcher -
1. logging out/in with mounted drives (internal/external
2. logging out/in, restarting with pinned internal drives, mounted or not
3. auto-mounting internal drives thru fstab

Additionally there may be some other unintended?? behavior -
User 1 mounts drive A, then logs out without unmounting drive A
User 2 logs in, drive A is unavailable & not shown in nautilus

All of this is from the new gvfs & udisks2. (media is mounted to /run/media/username

Should mounts in /run/media/username be removed on a logout?

Doug McMahon (mc3man) wrote :

"Additionally there may be some other unintended?? behavior -
User 1 mounts drive A, then logs out without unmounting drive A
User 2 logs in, drive A is unavailable & not shown in nautilus"
Ignore that - been some time since I shared an install

I have pasted a screenshot of the problem here:
http://ubuntuforums.org/showpost.php?p=12036995&postcount=3

Didier Roche (didrocks) on 2012-07-10
Changed in unity:
milestone: 6.0 → 6.2
Andrea Azzarone (azzar1) on 2012-07-17
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers