Unity launcher icons transparent after Digikam move operation

Bug #1008768 reported by Marius B. Kotsbak on 2012-06-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Most launcher icons were grey after Digikam move operation. Only the folder/Nautilus icon is left untouched, but all of the icons does work.

APPORT INFO

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,resize,place,imgpng,move,compiztoolbox,grid,vpswitch,mousepoll,water,regex,gnomecompat,wobbly,session,animation,fade,workarounds,cube,rotate,expo,ezoom,scale,unitymtgrabhandles,unityshell]
CompositorRunning: compiz
Date: Mon Jun 4 23:51:14 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:b100]
   Subsystem: Giga-byte Technology Device [1458:b100]
MachineType: GIGABYTE T1005
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 TERM=xterm
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.4.0-3-generic root=UUID=f1d0446d-3ea3-46a7-9842-8773acca78e6 ro quiet splash i8042.noloop=1 vt.handoff=7
SourcePackage: unity
UdevDb: Error: [Errno 2] Ingen slik fil eller filkatalog
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2010
dmi.bios.vendor: GIGABYTE
dmi.bios.version: GSBF05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1005
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnGIGABYTE:bvrGSBF05:bd08/30/2010:svnGIGABYTE:pnT1005:pvrGSBF05:rvnGIGABYTE:rnT1005:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1005
dmi.product.version: GSBF05
dmi.sys.vendor: GIGABYTE
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Marius B. Kotsbak (mariusko) wrote :
Marius B. Kotsbak (mariusko) wrote :

See attached screenshot.

Evan Peck (colors) wrote :

That's... odd. Can you give me a description of exactly what happened? "Digikam move operation" doesn't exactly sum it up. It will be very helpful to know exactly what steps led up to triggering this, and why Nautilus is the only icon not affected. Prabably cuz' it's fabulous like that. :-)

Thanks for reporting + nice screenshot!
Evan Peck

summary: - Most launcher icons were grey after Digikam move operation
+ Unity launcher icons transparent after Digikam move operation
description: updated
Omer Akram (om26er) on 2012-06-06
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Marius B. Kotsbak (mariusko) wrote :

I tried again now. The transparent icons starts already when I start dragging images in Digikam. The folder/Nautilus icon is probably active because the images can be dragged here (I tried moving there and the window opened).

The bug is that the icons are still transparent while the move operation is in progress (when I chose a folder inside Digikam and selected "move") and after it has finished. I am not sure if this is a misbehavior in Digikam so I added as affecting that project as well.

Evan Peck (colors) wrote :

Okay, thank you, I knew this couldn't be just a freak thing.
So Nautilus is still transparent because the photos can be moved there.
I see. So, it looks like Digikam just doesn't finish the Unity-where-to-move-stuffs feature after it's done.

I have Digikam, how can I replicate this?

Thnak you
Evan Peck

Marius B. Kotsbak (mariusko) wrote :

Just move some photos inside Digikam running unity (add them or add a collection of existing photos, make a new album/folder to move them to). I also think it is just not finishing the move process. When I tried again now the icons were reset when exiting Digikam.

I reported a crash at exit of Digikam after the move operation that might be related:

https://bugs.kde.org/show_bug.cgi?id=301284

I guess it might be busy updating the photo database (I notice it consumes a lot of CPU after the move operation).

Andrea Azzarone (azzar1) wrote :

Can you still reproduce this?

no longer affects: unity
Changed in digikam (Ubuntu):
status: New → Incomplete
no longer affects: digikam (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.