Shortcuts - shortcuts don't work when application indicators are visible

Bug #1005312 reported by 2green on 2012-05-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Shortcuts will not work with:
- open application indicators (e.g. switch user account, time and date settings, etc)
- opened sound level bar in movie player and similar stuff from other apps.
- opened dash home
- etc.

This bug blocks an efficient work proces for the user and the usage of shortcuts is no longer predictable. Also the chance it occurs is pretty high.

* Steps to reproduce

Open a windowed app (e.g. firefox)
Show desktop using the shortcut ctrl-alt-d
Maximize the windowed app again (e.g. firefox)
Left click on 'time and date' in the upper right corner (leave the application indicator opened)
Show desktop using the shortcut ctrl-alt-d

* Expected behavior

The windows app is minimized.

* Current behavior

Nothing happens (the windowed app is not minimized)

2green (zendhetmij) on 2012-05-27
description: updated
description: updated
description: updated
2green (zendhetmij) on 2012-05-28
description: updated
summary: - Shortcuts - shortcuts are blocked when application indicators are opened
+ Shortcuts - shortcuts don't work when application indicators are opened
summary: - Shortcuts - shortcuts don't work when application indicators are opened
+ Shortcuts - shortcuts don't work when application indicators are visible
Omer Akram (om26er) wrote :

Not a Unity bug. That's a general issue about how X11 handles things. Not something to be fixed in Unity.

Changed in unity (Ubuntu):
status: New → Invalid
2green (zendhetmij) wrote :

Hard to fix due to dependencies with X, but still a bug.

Changed in unity (Ubuntu):
status: Invalid → New
2green (zendhetmij) wrote :

@Omer Akram,

Reading your argument I understand the relation with X makes it hard to fix. But Invallid seems wrong, other window managers don't seem to have this specific problem.

Omer Akram (om26er) wrote :

2green, could you tell which window manager are you talking? does it work in classic gnome session for you? (gnome shell here might be a different case as I believe the top panel menus there are not gtk one')

Changed in unity (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

In classic desktop if a menu is opened show desktop does not work either.

2green (zendhetmij) wrote :

Omer, Xubuntu for example has this problem only partial.

E.g.
open firefox in ubuntu 12.04
Clicking on the time/data indicator in ubuntu 12.04 (upper right part of the window) opens an indicator.
Now using ctrl-alt-D does NOT minimize firefox.

Doing this same thing in xubuntu DOES minimize firefox.

Note:
Some of the indicators from Xubuntu give the exact same problem we have in ubuntu with unity, some other like data settings don't have this problem.

Changed in unity (Ubuntu):
status: Incomplete → New
Omer Akram (om26er) wrote :

just tested with firefox. what firefox does is that when you press the alt key it closes the menu hence releasing the grab. In unity alt is used for different purposes.

Changed in unity (Ubuntu):
status: New → Won't Fix
2green (zendhetmij) wrote :

Thas interesting... i'll retest it with another application on xubuntu.

2green (zendhetmij) wrote :

Tested in ubuntu and Xubuntu, this problem occurs with every application in Ubuntu. This problem does NOT occur with any application in Xubuntu using the date setting example as mentioned above.

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 10905, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

2green (zendhetmij) wrote :

@Daniel, thanks i'll add the missing information to bug 10905.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers