"on startup"-ed pidgin's window does not restore

Bug #1001405 reported by Aristotelis Mikropoulos on 2012-05-18
118
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I have set Pidgin to start on login (startup app). Its icon shows on the launcher and it has a white arrow left of it (so it states a window of Pidgin is "opened" somewhere, probably "minimized"). But when I click on that Pidgin icon, nothing happens, Pidgin's "main window" does not restore anywhere. I cannot even find it with Super+W. This gets fixed if I quite Pidgin (right click -> Quit, on the icon) and rerun it. I have also set Skype as a startup app, but it doesn't have any problems (maybe because it has a status icon on the "horizontal upper panel"?).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Fri May 18 22:11:00 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Gabriel_P (gabp) wrote :

I'm experiencing the same issue. Ubuntu 12.04, NVIDIA current drivers, Pidgin 2.10.3 (libpurple 2.10.3)

Angel Mass (angelmass) wrote :

I'm experiencing the same issue with Ubuntu 12.04 Pidgin 2.10.3 libpurple 2.10.3. No NVIDIA drivers installed.

When I start Ubuntu, the Pidgin window used to show up Maximized. Now the window doesnt show up but the pidgin icon appears in the taskbar (Im using Avant Window Navigator as taskbar) as it has been excuted.

The way I fix it is, I do right click on the Pidgin icon at the taskbar , then click on "Close". Then I execute Pidgin from the main menu and again it just show up in the taskbar, so I Right click on it and then choose "Unminimize". Nothing happens but I can Right click on it again and choose "Maximize" and that is how the Pidgin window manage to show up finally. Its very annoying.

David Silva (davidm-silva) wrote :

I believe it has something to do with Ubuntu itself.
Using Ubuntu 12.04 I had the same issue when Pidgin was locked in the launcher.
The workaround I found was to open Pidgin from the Message menu on top and lock it again to the Launcher.
Obviously this won't solve the issue related here but might help figuring what command Ubuntu uses to launch Pidgin when you open it via the Message Menu.

Sorry, my English is not that great but I belive you understood what I said.

Tchalvak (tchalvak) wrote :

http://askubuntu.com/questions/78854/pidgin-not-showing-up-after-opening-it/186278#186278

To avoid this behavior to you have to get to Menu > Tools > Preferences
Set "Show System Tray Icon" to "Always"

pwaring (launchpad-pwaring) wrote :

I can confirm the fix in #6 works for me. Perhaps the Ubuntu package should just have that option enabled by default as a temporary measure?

Ted (artisdom) wrote :

#6 works for me.

Anton (antony-doma) wrote :

#6 works for me.

Jesse Johnson (holocronweaver) wrote :

#6 works for me on Ubuntu 13.04.

Changed in unity:
status: New → Confirmed
Alex Baggott (alex-baggott) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu and cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu, please comment on why that is the case and change the bug status to NEW.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Seventy Nine (seventynine) wrote :

I had the same / a similar issue today. The Pidgin window was not showing up, after I killed the Pidgin process, since it was hanging when shutting down normally.

The shutdown was not commencing at this point:
(10:48:26) proxy: Connection in progress
dns[13098]: nobody needs me... =(
(10:48:55) prefs: /pidgin/blist/list_visible changed, scheduling save.
(10:49:01) util: Writing file prefs.xml to directory /home/*****/.purple
(10:49:01) util: Writing file /home/*****/.purple/prefs.xml

The reason why I tried to restart Pidgin was my Office Communicator (SIPE) plugin (running at current latest version 1.23.0), which was not able to connect to our Lync server (which itself has probably the issue at the moment).

Then I tried to restart Pidgin and it was not showing up anymore. The reason is the /pidgin/blist/list_visible property which have been changed to 0 in the previous shutdown. When I switched it back to 1 in the /home/*****/.purple/prefs.xml like:
<pref name='blist'>
 [...]
 <pref name='list_visible' type='bool' value='1'/>
 [...]
</pref>

The Pidgin window is showing up again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers