Exception raised from python import causes update script failure

Bug #1361828 reported by Max Brustkern on 2014-08-26
36
This bug affects 11 people
Affects Status Importance Assigned to Milestone
AmazonCloudReader WebApp
Undecided
Unassigned
AngryBirds WebApp
Undecided
Unassigned
BBCNews WebApp
Undecided
Unassigned
CNN-News WebApp
Undecided
Unassigned
CutTheRope WebApp
Undecided
Unassigned
Deezer Webapp
Undecided
Unassigned
DeviantArt WebApp
Undecided
Unassigned
FacebookMessenger WebApp
Undecided
Unassigned
GMail WebApp
Undecided
Unassigned
GoogleCalendar WebApp
Undecided
Unassigned
GoogleDocs WebApp
Undecided
Unassigned
GoogleNews WebApp
Undecided
Unassigned
GooglePlus WebApp
Undecided
Unassigned
GooglePlusGames WebApp
Undecided
Unassigned
Grooveshark WebApp
Undecided
Unassigned
Hulu-Player WebApp
Undecided
Unassigned
LastFM-Radio WebApp
Undecided
Unassigned
Launchpad WebApp
Undecided
Unassigned
LibreFm WebApp
Undecided
Unassigned
LinkedIn WebApp
Undecided
Unassigned
LiveMail WebApp
Undecided
Unassigned
LordOfUltima WebApp
Undecided
Unassigned
Mail-Ru WebApp
Undecided
Unassigned
Newsblur WebApp
Undecided
Unassigned
Pandora WebApp
Undecided
Unassigned
QQ-Mail WebApp
Undecided
Unassigned
Reddit WebApp
Undecided
Unassigned
TiberiumAlliances WebApp
Undecided
Unassigned
Tumblr WebApp
Undecided
Unassigned
Twitter WebApp
Undecided
Unassigned
VkCom WebApp
Undecided
Unassigned
Wordpress WebApp
Undecided
Unassigned
YahooMail WebApp
Undecided
Unassigned
YahooNews WebApp
Undecided
Unassigned
YandexMail WebApp
Undecided
Unassigned
YandexMusic WebApp
Undecided
Unassigned
YandexNews WebApp
Undecided
Unassigned
YouTube WebApp
Undecided
Unassigned
unity-webapps-youtube (Ubuntu)
Medium
Justin McPherson

Bug Description

Got this when I started an xubuntu session on utopic.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: unity-webapps-youtube 2.4.16+13.10.20130924.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-10.15-generic 3.16.1
Uname: Linux 3.16.0-10-generic x86_64
ApportVersion: 2.14.6-0ubuntu2
Architecture: amd64
Date: Tue Aug 26 15:19:39 2014
ExecutablePath: /usr/share/session-migration/scripts/update-desktop-file-unity-webapps-youtube.py
InstallationDate: Installed on 2013-05-31 (452 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/session-migration/scripts/update-desktop-file-unity-webapps-youtube.py
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=en_US
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/session-migration/scripts/update-desktop-file-unity-webapps-youtube.py']
SourcePackage: unity-webapps-youtube
SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
Title: update-desktop-file-unity-webapps-youtube.py crashed with AttributeError in __getattr__(): When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
UpgradeStatus: Upgraded to utopic on 2014-02-18 (189 days ago)
UserGroups: adm autopilot bluetooth cdrom dip libvirtd lpadmin plugdev sambashare scanner sudo

Related branches

Max Brustkern (nuclearbob) wrote :
tags: removed: need-duplicate-check
Changed in unity-webapps-youtube (Ubuntu):
importance: Undecided → Medium
Colin Watson (cjwatson) on 2015-02-05
information type: Private → Public
David Barth (dbarth) on 2015-02-05
Changed in unity-webapps-youtube (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-youtube (Ubuntu):
status: New → Confirmed
miked (miked11) wrote :

root@ubuntu-14101504a2:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04
Codename: vivid
root@ubuntu-14101504a2:~# uname -mrs
Linux 3.19.0-8-generic x86_64
root@ubuntu-14101504a2:~#

tags: added: vivid
miked (miked11) wrote :

root@ubuntu-14101504a2:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04
Codename: vivid
root@ubuntu-14101504a2:~# uname -mrs
Linux 3.19.0-10-generic x86_64
root@ubuntu-14101504a2:~#

summary: - update-desktop-file-unity-webapps-youtube.py crashed with AttributeError
- in __getattr__(): When using gi.repository you must not import static
- modules like "gobject". Please change all occurrences of "import
- gobject" to "from gi.repository import GObject". See:
- https://bugzilla.gnome.org/show_bug.cgi?id=709183
+ Exception raised from python import causes update script failure
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers