YouTube complains 'You need to upgrade your Adobe Flash Player to watch this video.'

Bug #1308842 reported by Alan B. Clements
220
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Oxide
High
Unassigned
unity-webapps-facebookmessenger (Ubuntu)
High
Justin McPherson
unity-webapps-googleplus (Ubuntu)
High
Justin McPherson
unity-webapps-youtube (Ubuntu)
High
Justin McPherson

Bug Description

Even after installing flashplugin-installer, adobe-flashplugin or pepperflashplugin-nonfree it continues to complain. Chromium is only able to play flash videos after pepperflashplugin-nonfree is installed.

Revision history for this message
Alan B. Clements (alan-clements) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-youtube (Ubuntu):
status: New → Confirmed
Revision history for this message
Mitchell (curious-mitchell) wrote :

Yep, buggy for me too. Webapps in it's current implementation sucks. Bad move for an LTS folks.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

Oxide is adding support for pepper plugins, should be available shortly

tags: added: webapps-hotlist
removed: webkit
Changed in unity-webapps-youtube (Ubuntu):
importance: Undecided → High
Changed in oxide:
status: New → Confirmed
Changed in unity-webapps-youtube (Ubuntu):
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-grooveshark (Ubuntu):
status: New → Confirmed
Revision history for this message
Kevin Chavanne (kevin-chavanne) wrote :

I have the same problem

Changed in oxide:
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-facebookmessenger (Ubuntu):
status: New → Confirmed
Changed in unity-webapps-googleplus (Ubuntu):
status: New → Confirmed
Revision history for this message
Renê Barbosa (renebarbosa) wrote :

Affected too. I am using Ubuntu 14.04 LTS.

Revision history for this message
Yatharth Agarwal (yatharth999) wrote :

@renebarbosa: There's a "Me too!" button (or rather, a button styled as a link for some reason) as the top of the page. 14.04 has already been mentioned as being affected.

Revision history for this message
Renê Barbosa (renebarbosa) wrote :

Yup I have clicked it! Thank you.

Revision history for this message
john ortiz (castor1808) wrote :

this bug affected too in youtube or unity-webapps-facebookmessenger 2.4.16+14.04.20140217-0ubuntu1. anyone has any solution to repect? thank you

Revision history for this message
David Barth (dbarth) wrote : Re: [Ubuntu-webapps-bugs] [Bug 1308842] Re: YouTube complains 'You need to upgrade your Adobe Flash Player to watch this video.'

The problem is due to the absenc of Flash support in the current container.
14.10 should see a Flash compatible containre (works in a branch right
now), which will be SRU ed to 14.04.

On Sun, Aug 31, 2014 at 10:33 PM, john ortiz <email address hidden> wrote:

> this bug affected too in youtube or unity-webapps-facebookmessenger
> 2.4.16+14.04.20140217-0ubuntu1. anyone has any solution to repect? thank
> you
>
> --
> You received this bug notification because you are a member of Ubuntu
> WebApps bug tracking, which is subscribed to unity-webapps-
> facebookmessenger in Ubuntu.
> https://bugs.launchpad.net/bugs/1308842
>
> Title:
> YouTube complains 'You need to upgrade your Adobe Flash Player to
> watch this video.'
>
> Status in Oxide Webview:
> Triaged
> Status in “unity-webapps-facebookmessenger” package in Ubuntu:
> Confirmed
> Status in “unity-webapps-googleplus” package in Ubuntu:
> Confirmed
> Status in “unity-webapps-grooveshark” package in Ubuntu:
> Confirmed
> Status in “unity-webapps-youtube” package in Ubuntu:
> Confirmed
>
> Bug description:
> Even after installing flashplugin-installer, adobe-flashplugin or
> pepperflashplugin-nonfree it continues to complain. Chromium is only
> able to play flash videos after pepperflashplugin-nonfree is
> installed.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/oxide/+bug/1308842/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~ubuntu-webapps-bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~ubuntu-webapps-bugs
> More help : https://help.launchpad.net/ListHelp
>

Adolfo Jayme (fitojb)
Changed in unity-webapps-facebookmessenger (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in unity-webapps-googleplus (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in unity-webapps-grooveshark (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Dominique Ramaekers (dominique-ramaekers) wrote :

If I click on a video, I just get a black window with the message 'Video not available'...

Revision history for this message
Dominique Ramaekers (dominique-ramaekers) wrote :

Additional info:
Ubuntu Willy
unity-webapps-facebookmessenger:i386 (2.4.16+14.04.20140217-0ubuntu1)

Revision history for this message
David Barth (dbarth) wrote :

To fix the issue, the feature branch tracked by https://bugs.launchpad.net/oxide/+bug/1326113 needs to land.

Changed in unity-webapps-youtube (Ubuntu):
assignee: Alexandre Abreu (abreu-alexandre) → nobody
assignee: nobody → Justin McPherson (justinmcp)
no longer affects: unity-webapps-grooveshark (Ubuntu)
Changed in unity-webapps-facebookmessenger (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
Changed in unity-webapps-googleplus (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
Revision history for this message
Alessandro Viprati (vipri-alessandro) wrote :

This bug 1326113 is now tracked as "Fix released" and I don't see the message "You need to upgrade your Adobe Flash Player to watch this video." in my WebApps.

I'm using Ubuntu 14.04: now I can play videos on webbrowser-app WebApps (I use G+, FacebookMessenger and YouTube), so I think this bug-report can be marked as "Fix Released" on 14.04 (or Invalid?)

Revision history for this message
corrado venturini (corradoventu) wrote :

I have the problem with Chromium on Ubuntu 16.04 GNOME; Firefox works fine. I uninstalled and re-installed adobe-flashplugin and pepperflashplugin-nonfree but the problem continues.

Revision history for this message
Justin McPherson (justinmcp) wrote :

#1326113 is about Flash support in Oxide/Webapp container.

If you install adobe-flashplugin you should have flash support in Chromium, it works on 15.04. I'll have to check for 16.04.

You should only use adobe-flashplugin, as it is the maintained version.

See, https://wiki.ubuntu.com/Chromium/Getting-Partner-Flash, for help with installing flash.

Revision history for this message
corrado venturini (corradoventu) wrote :

Ubuntu Software Center is no longer available in Ubuntu 16.04 and the new 'Software' does not know adobe-flashplugin.

Revision history for this message
Sam Segers (sam-sgrs) wrote :

If you have chrome installed in /opt/google/chrome, it should use the pepper flash plugin from chrome. (the official stable chrome installs here)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers