Windows Live Mail webapp should be 'Outlook.com' or similar

Bug #1215763 reported by Philip Khor on 2013-08-23
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-webapps-livemail (Ubuntu)
Medium
Justin McPherson

Bug Description

[Impact]

Hotmail has been rebranded as Outlook.com, but the livemail webapp's branding has not been updated to reflect this change.

Currently the icon is broken, resulting in a question mark icon when installing this webapp.

[Testcase]
- search for livemail in the dash
Expected result:
- you see a livemail or outlook icon
- the same icon is displayed on your launche once you drag the webapp shotcut to it
Actual result:
- the icon is blank
- a question mark icon is displayed on your launcher instead

[Regression potential]

Limited: the icon is currently broken.

However for full disclosure, the change also guards the message count detection logic to let it work only on a legit inbox folder

Related branches

Adolfo Jayme (fitojb) on 2013-08-25
Changed in unity-webapps-livemail (Ubuntu):
status: New → Triaged
importance: Undecided → Low
pauljwells (pauljwells) wrote :

More to the point. Currently the webapp does not _have_ an icon! It's there in usr/share/icons but the .desktop file in /usr/share/applications has no icon associate. Easy hack to fix - open nautilus as root, right-click properties of the .desktop file and then click on the icon and navigate to /usr/share/icons/unity-webapps-applications/128/apps and select the livemail icon. Could also use a custom (e.g. outlook) icon instead.

David Barth (dbarth) on 2014-04-22
Changed in unity-webapps-livemail (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
tags: added: webapps-hotlist
David Barth (dbarth) on 2014-04-30
Changed in unity-webapps-livemail (Ubuntu):
importance: Low → Medium
milestone: none → trusty-updates
status: Triaged → Fix Committed
David Barth (dbarth) on 2014-04-30
description: updated

Hello Philip, or anyone else affected,

Accepted unity-webapps-livemail into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-webapps-livemail/2.4.17+14.04.20140502.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Philip Khor (philip10khor) wrote :

I'm using unity-webapps-livemail 2.4.17+14.04.20140502.1-0ubuntu1. The icon is still labeled LiveMail, whereas the icon image remains the same.

tags: added: verification-failed
removed: verification-needed
Robert Bruce Park (robru) wrote :

I'm a little bit confused -- in the bug description it mentions the rebranding, but then it says that currently there isn't any icon displayed at all. So it seems to me that this SRU was just to fix the icon display, no attempt at rebranding was made (either with the icon or the service name).

I confirmed in a fresh VM that there is no icon (blank page icon) without this package installed, and installing this package fixes the icon to be a real icon.

So I recommend that we release this package as-is, since it fixes the blank icon issue, and then pursue an additional update with the rebranding when it's ready.

tags: added: verification-done
removed: verification-failed
Philip Khor (philip10khor) wrote :

I tagged this bug verification-failed because it did not fix the bug that was originally reported - the original bug report did not mention the missing icon. The 'icon not being displayed' part was reported by other users on this thread later on, and I did not notice this issue on my computer.

As far as my computer is concerned, I have noticed no further bugs apart from the branding issue with this package.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-webapps-livemail - 2.4.17+14.04.20140502.1-0ubuntu1

---------------
unity-webapps-livemail (2.4.17+14.04.20140502.1-0ubuntu1) trusty; urgency=medium

  [ Justin McPherson ]
  * Rename and fix icon details (LP: #1215763)
 -- Ubuntu daily release <email address hidden> Fri, 02 May 2014 16:33:47 +0000

Changed in unity-webapps-livemail (Ubuntu):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity-webapps-livemail has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

David Barth (dbarth) wrote :

Robert: that's correct no rebranding just here. I think this should be addressed as a separate issue. Maybe even renaming the package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers