update-desktop-file-unity-webapps-launchpad.py crashed with AttributeError in __getattr__(): When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183

Bug #1369208 reported by Braham on 2014-09-14
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
unity-webapps-launchpad (Ubuntu)
Medium
Unassigned

Bug Description

always get the unexpectedly closed error

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: unity-webapps-launchpad 2.4.16+13.10.20130924.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-10.15-generic 3.16.1
Uname: Linux 3.16.0-10-generic i686
ApportVersion: 2.14.7-0ubuntu2
Architecture: i386
CrashCounter: 1
CurrentDesktop: Unity
Date: Sun Sep 14 10:03:44 2014
ExecutablePath: /usr/share/session-migration/scripts/update-desktop-file-unity-webapps-launchpad.py
ExecutableTimestamp: 1380061253
InstallationDate: Installed on 2011-09-18 (1091 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/session-migration/scripts/update-desktop-file-unity-webapps-launchpad.py
ProcCwd: /home/shakti
ProcEnviron:
 PATH=(custom, no user)
 LANGUAGE=en_US:en
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/session-migration/scripts/update-desktop-file-unity-webapps-launchpad.py']
SourcePackage: unity-webapps-launchpad
Title: update-desktop-file-unity-webapps-launchpad.py crashed with AttributeError in __getattr__(): When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
UpgradeStatus: Upgraded to utopic on 2014-08-23 (21 days ago)
UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare

Related branches

Braham (brahamshakti) wrote :
tags: removed: need-duplicate-check
Changed in unity-webapps-launchpad (Ubuntu):
importance: Undecided → Medium
Braham (brahamshakti) on 2014-09-15
Changed in unity-webapps-launchpad (Ubuntu):
assignee: nobody → Braham (brahamshakti)
Braham (brahamshakti) on 2014-09-18
Changed in unity-webapps-launchpad (Ubuntu):
assignee: Braham (brahamshakti) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-launchpad (Ubuntu):
status: New → Confirmed
tags: added: vivid
information type: Private → Public
Changed in unity-webapps-launchpad (Ubuntu):
assignee: nobody → Puspendu Banerjee (puspendu-banerjee)

Fixed. GLib introspection has been done inside offending function get_local_applications_path():

Changed in unity-webapps-launchpad (Ubuntu):
status: Confirmed → In Progress

The attachment "unity-webapps-launchpad_fix_lp1369208.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in unity-webapps-launchpad (Ubuntu):
assignee: Puspendu Banerjee (puspendu-banerjee) → nobody
status: In Progress → Confirmed
tags: added: wily
Changed in unity-webapps-launchpad (Ubuntu):
status: Confirmed → Triaged
Flashrom (m-schult) wrote :

i dont see the task bar on the left side

Changed in unity-webapps-launchpad (Ubuntu):
assignee: nobody → Puspendu Banerjee (puspendu-banerjee)
status: Triaged → Fix Committed
assignee: Puspendu Banerjee (puspendu-banerjee) → nobody
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package unity-webapps-launchpad - 2.4.16+16.04.20151119-0ubuntu1

---------------
unity-webapps-launchpad (2.4.16+16.04.20151119-0ubuntu1) xenial; urgency=medium

  [ Alexandre Abreu ]
  * Add default desktop file added: Launchpadlaunchpadnet.desktop
  * Add migration script added: debian/unity-webapps-
    launchpad.migrations scripts/ scripts/update-desktop-file-exec-
    line.py
  * Add proper license
  * Add session migration script
  * Add session migration script & desktop file for StartupWMClass
    added: Launchpadlaunchpadnet.desktop debian/unity-webapps-
    launchpad.migrations scripts/update-desktop-file-unity-webapps-
    launchpad.py
  * Add support for domain name in debian/control
  * Default desktop file uses the webbrowser-app directly
  * Install desktop file
  * Strip unecessary part from debian/copyright
  * Update copyright
  * Update copyright
  * Update copyright
  * Update copyright & control (lintian)
  * Update copyright GPL-3 license
  * Update description and icons copyright
  * Update icons copyright & legal
  * Update/fix installed icons removed: debian/icons/ debian/icons/128/
    debian/icons/128/unity-webapps-launchpad.png debian/icons/48/
    debian/icons/48/unity-webapps-launchpad.png debian/icons/52/
    debian/icons/52/unity-webapps-launchpad.png debian/icons/64/
    debian/icons/64/unity-webapps-launchpad.png
  * Update/fix installed icons; update copyright renamed:
    128/launchpad.png => 128/unity-webapps-launchpad.png
    48/launchpad.png => 48/unity-webapps-launchpad.png 52/launchpad.png
    => 52/unity-webapps-launchpad.png 64/launchpad.png => 64/unity-
    webapps-launchpad.png
  * add COPYING added: COPYING
  * merge trunk
  * remove debian/source (dpkg failure) removed: debian/source/
    debian/source/format debian/source/include-binaries
  * remove junk files removed: debian/unity-webapps-launchpad/
    debian/unity-webapps-launchpad.debhelper.log debian/unity-webapps-
    launchpad.postinst.debhelper debian/unity-webapps-
    launchpad.postrm.debhelper debian/unity-webapps-launchpad.substvars
    debian/unity-webapps-launchpad/DEBIAN/ debian/unity-webapps-
    launchpad/DEBIAN/control debian/unity-webapps-
    launchpad/DEBIAN/md5sums debian/unity-webapps-
    launchpad/DEBIAN/postinst debian/unity-webapps-
    launchpad/DEBIAN/postrm debian/unity-webapps-launchpad/usr/
    debian/unity-webapps-launchpad/usr/share/ debian/unity-webapps-
    launchpad/usr/share/doc/ debian/unity-webapps-
    launchpad/usr/share/doc/unity-webapps-launchpad/ debian/unity-
    webapps-launchpad/usr/share/doc/unity-webapps-launchpad/changelog.gz
    debian/unity-webapps-launchpad/usr/share/doc/unity-webapps-
    launchpad/copyright debian/unity-webapps-launchpad/usr/share/icons/
    debian/unity-webapps-launchpad/usr/share/icons/hicolor/
    debian/unity-webapps-launchpad/usr/share/icons/hicolor/48x48/
    debian/unity-webapps-launchpad/usr/share/icons/hicolor/48x48/apps/
    debian/unity-webapps-
    launchpad/usr/share/icons/hicolor/48x48/apps/unity-webapps-
    launchpad.png debian/unity-webapps-launchpad/usr/share/icons/unity-
    webapps-applications/ debian/unity-webapps-
    launch...

Read more...

Changed in unity-webapps-launchpad (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers