[SRU] unity-webapps-gmail in Saucy

Bug #1245027 reported by pep on 2013-10-26
136
This bug affects 29 people
Affects Status Importance Assigned to Milestone
unity-webapps-gmail (Ubuntu)
High
Justin McPherson
Saucy
Undecided
Robert Bruce Park

Bug Description

[Impact]

 * The webapp has ceased functioning due to changes in the website outside our control.

[Test Case]

 * Browse to the affected website, notice it is not working.

[Regression Potential]

 * Zero, the stable release is already broken.

[Other Info]

 * We don't have automated SRU tests set up yet, but I verified this fix manually in a fresh Saucy VM.

Related branches

pep (atreyv) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-gmail (Ubuntu):
status: New → Confirmed
makilakixki (zandueta) wrote :

I guess developers do not care much about this once superb webapp. The bug still remains unassigned after two months and the webapp has a score of one single star in the software centre. Come on guys, this is a killer feature Ubuntu once used to have!

Justin McPherson (justinmcp) wrote :

At least in part this problem is caused by the DOM changing and the webapp no longer looking for the correct content.

The package version listed in the report will not work with what Gmail is rendering at the time of this comment - it will fail at the attempts to find login information.

Le 17/01/2014 08:08, Justin McPherson a écrit :
> At least in part this problem is caused by the DOM changing and the
> webapp no longer looking for the correct content.
>
> The package version listed in the report will not work with what Gmail
> is rendering at the time of this comment - it will fail at the attempts
> to find login information.
Do you have a new package available, even in a PPA to verify that the
new heuristics code would solve this? (it should really)

David

You can look here, https://launchpad.net/~justinmcp/+archive/webapps-ppa, for a packaged version of trunk. This version of the Gmail webapp works as of this comment.

It contains a precursor of the new system.

Changed in unity-webapps-gmail (Ubuntu):
importance: Undecided → High

Le 21/01/2014 11:58, Alberto Salvia Novella a écrit :
> ** Changed in: unity-webapps-gmail (Ubuntu)
> Importance: Undecided => High
>
Hi Robert,

Can you help release this package with the new accelerated SRU process?

David

Justin, is this[0] the merge that fixes this bug? If so, please link the branch to the bug report. Also, fix the jenkins error and get it actually merged into trunk. It needs to be released in Trusty before it can be SRU'd into Saucy.

This is going to be very difficult if not impossible to SRU, due to changes in dependent components. We can't just SRU the whole stack due to the container switchover, and cherry-picking the changes that this depends on may prove to be difficult. I don't have the ability to do it myself; I will need somebody more familiar with the webapps internals (Alex? Victor?) to diff saucy/trusty versions of webapps-applications and then identify a) which changes gmail depends on, and b) how feasible it is to backport those to saucy.

[0] https://code.launchpad.net/~justinmcp/unity-webapps-gmail/heuristics-update/+merge/199409

Justin McPherson (justinmcp) wrote :

@robert; The fix for this landed in trunk from https://code.launchpad.net/~justinmcp/unity-webapps-gmail/login-fix. What you see there is new code (which has a similar change) but is not needed to fix this immediate problem.

Changed in unity-webapps-gmail (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
Robert Bruce Park (robru) wrote :

Oh, ok. in that case it should be easier to SRU. I'll work on creating a Saucy package for this.

Changed in unity-webapps-gmail (Ubuntu):
status: Confirmed → Fix Committed
description: updated
Robert Bruce Park (robru) wrote :

Those of you affected by this bug, if you want to help test the updated package, please open a terminal (Ctrl+Alt+T) and type these commands:

sudo add-apt-repository ppa:ubuntu-unity/daily-build
sudo apt-get update
sudo apt-get install unity-webapps-gmail
sudo rm -rf /etc/apt/sources.list.d/ubuntu-unity*
sudo apt-get update

Then restart firefox and confirm that the webapp is now working. Thanks!

Changed in unity-webapps-gmail (Ubuntu Saucy):
status: New → Fix Committed
Changed in unity-webapps-gmail (Ubuntu):
status: Fix Committed → Fix Released
summary: - unity-webapps-gmail is not working in 13.10 saucy
+ [SRU] unity-webapps-gmail in Saucy
tags: added: verification-done
Changed in unity-webapps-gmail (Ubuntu Saucy):
assignee: nobody → Robert Bruce Park (robru)
Pat McGowan (pat-mcgowan) wrote :

Works for me using chromium

Tested from ppa:ubuntu-unity/daily-build and it's working properly:
- launch from dash opens firefox window
- click on menu icon and draws attention to gmail firefox tab/window
- shows correct number of unread inbox mail

Only problem is that the message notification center shows two Gmail (one
GMail and the other Gmail).
The same with with dash: shows two gmail apps (different case again).

On Wed, Jan 22, 2014 at 8:06 PM, Robert Bruce Park <
<email address hidden>> wrote:

> Those of you affected by this bug, if you want to help test the updated
> package, please open a terminal (Ctrl+Alt+T) and type these commands:
>
> sudo add-apt-repository ppa:ubuntu-unity/daily-build
> sudo apt-get update
> sudo apt-get install unity-webapps-gmail
> sudo rm -rf /etc/apt/sources.list.d/ubuntu-unity*
> sudo apt-get update
>
> Then restart firefox and confirm that the webapp is now working. Thanks!
>
> ** Changed in: unity-webapps-gmail (Ubuntu Saucy)
> Status: New => Fix Committed
>
> ** Changed in: unity-webapps-gmail (Ubuntu)
> Status: Fix Committed => Fix Released
>
> ** Summary changed:
>
> - unity-webapps-gmail is not working in 13.10 saucy
> + [SRU] unity-webapps-gmail in Saucy
>
> ** Tags added: verification-done
>
> ** Changed in: unity-webapps-gmail (Ubuntu Saucy)
> Assignee: (unassigned) => Robert Bruce Park (robru)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1245027
>
> Title:
> [SRU] unity-webapps-gmail in Saucy
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/unity-webapps-gmail/+bug/1245027/+subscriptions
>

Wayne Do Rego (waynebow) wrote :

Mostly working for me with Chromium 31.

Working for me:
- Icon shows in launcher
- Gmail appears in messaging menu (but twice as in Pep's explanation)
- Right click on launcher icon allows me to compose a new message
- Gmail appears in dash and opens gmail in Chromium (however again it appears twice as "Gmail" and "GMail" and clicking on "GMail" doesn't seem to do anything.)
- Clicking on "Gmail" in messaging menu switches to already open Chromium Gmail window. However, clicking on "GMail" opens a completely new Chromium and loads Gmail.

Not working for me:
- No badge showing unread mails on launcher icon

Thanks!

Justin McPherson (justinmcp) wrote :

@waynebow The unread counts represent the delta in unread messages for the session. If you send yourself a test message does the icon change?

Wayne Do Rego (waynebow) wrote :

Sorry, quite right, the icon changed to indicate that there was one new message when I sent myself a message.

Hello pep, or anyone else affected,

Accepted into saucy-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Robert Bruce Park (robru) wrote :

Thanks for taking care of this, Chris!

tags: added: verification-done
removed: verification-needed
Changed in unity-webapps-gmail (Ubuntu Saucy):
status: Fix Committed → Fix Released
Vincent Gerris (vgerris) wrote :

Is this bug still present in 14.04 ?
When I start the app gmail after pressing install, I get an empty screen with back and forward arrows grayed out.
So if that is the unity web app the bug is still present.

Robert Bruce Park (robru) wrote :

No, *this* bug is resolved in 13.10 and 14.04. What you're seeing is a bug in the webapp container, which isn't loading webapps for some reason.

Thufir (hawat-thufir) wrote :

is it resolved in 14.10?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers