"PyGIWarning: Gtk was imported without specifying a version first"

Bug #1575485 reported by The Powerpuff Girls on 2016-04-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-tweak-tool (Ubuntu)
Low
J Phani Mahesh

Bug Description

Earlier, I've noticed some installed apps weren't appearing in the launch. The noticeable one was Unity Tweak Tool, so I typed it in the Terminal to see if it'll launch, which it did but also gave an error:
"/usr/lib/python3/dist-packages/UnityTweakTool/__init__.py:40: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk"

It appears to that something, like the Gtk isn't configured properly, or not configured at all and doesn't know which one to choose.
I have two folders, gtk2 and gtk3 in my home folder. It appears I have two installed (which were most likely installed with a fresh install of Xenial) which is causing the conflict.

PS: The Unity Tweak Tool, now shows up in the launch; I'm not sure what was changed, but a few things that weren't showing before, are now. My guess is installing extra packages for apps may have fixed them?

Info:
OS: Ubuntu 16.04 (Xenial) x64
App Version: 3.18.3

- Blossom.

affects: gnome-terminal (Ubuntu) → unity-tweak-tool (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-tweak-tool (Ubuntu):
status: New → Confirmed
mau (amadormau) wrote :
J Phani Mahesh (phanimahesh) wrote :
Changed in unity-tweak-tool (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → J Phani Mahesh (phanimahesh)
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-tweak-tool - 0.0.7+-0ubuntu5

---------------
unity-tweak-tool (0.0.7+-0ubuntu5) disco; urgency=medium

  * Switch to source format 3.0 (quilt), because this in not a native package
  * Use nemo-desktop to draw desktop icons under Unity (LP: #1814506)
  * Specify GTK version 3 to fix warning (LP: #1575485)
  * Add required dependency on notify-osd (LP: #1822472)
  * Add missing build dependency on dh-python
  * Drop ancient X-Python3-Version field
  * Run wrap-and-sort

 -- Benjamin Drung <email address hidden> Wed, 10 Apr 2019 14:36:41 +0200

Changed in unity-tweak-tool (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers