Port schemas from gnome-settings-daemon-common to com.canonical.unity.settings-daemon

Bug #1842324 reported by Khurshid Alam on 2019-09-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-session (Ubuntu)
Undecided
Khurshid Alam
ubuntu-settings (Ubuntu)
Undecided
Khurshid Alam
unity (Ubuntu)
Undecided
Khurshid Alam
unity-control-center (Ubuntu)
Undecided
Khurshid Alam
Eoan
Undecided
Khurshid Alam
unity-greeter (Ubuntu)
Undecided
Khurshid Alam
unity-settings-daemon (Ubuntu)
Undecided
Khurshid Alam

Bug Description

Unity-settings-daemon still depends on gnome-settings-daemon schemas. It is undesired as it requires to modify code in all unity related components when upstream drops some gsettings schemas.

gnome-settings-daemon > 3.33 drops/modify media-keys schemas in an undesired way that it can't easily be reverted. Keyboard & mouse schemas are modified and unity-settings-daemon is crashing. So it's better unity uses it's own schema as suggested by Laney. We will of-course keep using settings migration (org.gnome.settings-daemon-> org.gnome.desktop) wherever possible.

https://gitlab.gnome.org/GNOME/gnome-settings-daemon/commit/6dff93a0dfa80db3f481eed5d6ed689bf469aa1b

https://gitlab.gnome.org/GNOME/gnome-settings-daemon/commit/44f53c64c5a2514d2c022bcb1596a9e46f1df51c

https://gitlab.gnome.org/GNOME/gnome-settings-daemon/commit/121a6f89917898b8d05db2e1933dd0ad59c26768

Since this is a huge task it can be achieved gradually.

1) Ubuntu 19.10

- Port media keys to use com.canonical.unity.settings-daemon

- u-s-d will still use org.gnome.settings-daemon name in dbus

- u-s-d will still respects activation toggle in org.gnome.settings-daemon

- everything else remains the same

2) Ubuntu 20.04

- Port rest of plugins to use com.canonical.unity.settings-daemon

- u-s-d will still use org.gnome.settings-daemon name in dbus

- Activation toggle key will now use com.canonical.unity.settings-daemon

- Everything else will remain the same

Related branches

Changed in unity-settings-daemon (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
description: updated
Changed in unity-control-center (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Changed in unity (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Changed in unity-greeter (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
description: updated
description: updated
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
status: New → Confirmed
description: updated
description: updated
description: updated
description: updated
description: updated
summary: Port schemas from gnome-settings-daemon-common to com.canonical.unity
- .settings-daemon
+ .settings-daemon-schemas
summary: Port schemas from gnome-settings-daemon-common to com.canonical.unity
- .settings-daemon-schemas
+ .settings-daemon
description: updated
description: updated
Changed in indicator-session (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Changed in ubuntu-settings (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in ubuntu-settings (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 19.10.2

---------------
ubuntu-settings (19.10.2) eoan; urgency=medium

  [ Khurshid Alam ]
  * Remove screensaver override for unity
    Unity is now using it's own schema for media keys. See LP: #1842324

 -- Sebastien Bacher <email address hidden> Sat, 21 Sep 2019 13:19:29 +0200

Changed in ubuntu-settings (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 18.04.0+19.10.20190921-0ubuntu1

---------------
unity-greeter (18.04.0+19.10.20190921-0ubuntu1) eoan; urgency=medium

  [ Khurshid Alam ]
  * Port media keys to use com.canonical.unity.settings-daemon. LP:
    #1842324 (LP: #1842324)

 -- Sebastien Bacher <email address hidden> Sat, 21 Sep 2019 10:59:35 +0000

Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+19.10.20190921-0ubuntu1

---------------
unity-settings-daemon (15.04.1+19.10.20190921-0ubuntu1) eoan; urgency=medium

  [ Khurshid Alam ]
  * Port media keys to use com.canonical.unity.settings-daemon (LP:
    #1842324)

 -- Sebastien Bacher <email address hidden> Sat, 21 Sep 2019 10:59:14 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 17.3.20+19.10.20190921-0ubuntu1

---------------
indicator-session (17.3.20+19.10.20190921-0ubuntu1) eoan; urgency=medium

  [ Khurshid Alam ]
  * Port media keys to use com.canonical.unity.settings-daemon. LP:
    #1842324 (LP: #1842324)

 -- Sebastien Bacher <email address hidden> Sat, 21 Sep 2019 10:59:04 +0000

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+19.10.20190924-0ubuntu1

---------------
unity (7.5.0+19.10.20190924-0ubuntu1) eoan; urgency=medium

  [ Khurshid Alam ]
  * Port media keys to use com.canonical.unity.settings-daemon. LP:
    #1842324 (LP: #1842324)

  [ Tasos Sahanidis ]
  * Fix gcc 7.2 build errors

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 24 Sep 2019 09:46:52 +0000

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-control-center (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-control-center (Ubuntu):
status: Fix Released → In Progress

Hello Khurshid, or anyone else affected,

Accepted unity-control-center into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-control-center/15.04.0+19.10.20190921-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unity-control-center (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+19.10.20190921-0ubuntu1

---------------
unity-control-center (15.04.0+19.10.20190921-0ubuntu1) eoan; urgency=medium

  [ Khurshid Alam ]
  * Port media keys to use com.canonical.unity.settings-daemon. LP:
    #1842324 (LP: #1842324)

 -- Sebastien Bacher <email address hidden> Sat, 21 Sep 2019 11:09:43 +0000

Changed in unity-control-center (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers