Incorrect information about display shown in gnome/unity-control-center

Bug #1755490 reported by Dariusz Gadomski on 2018-03-13
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-desktop3 (Ubuntu)
Undecided
Unassigned
Trusty
Low
Dariusz Gadomski
hwdata (Ubuntu)
Low
Unassigned
Trusty
Low
Dariusz Gadomski
Xenial
Low
Dariusz Gadomski
Bionic
Low
Dariusz Gadomski
Cosmic
Low
Dariusz Gadomski
unity-settings-daemon (Ubuntu)
Low
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Low
Unassigned
Cosmic
Low
Unassigned

Bug Description

[Impact]

 * There is a number of display devices that misuse the width & height field in EDID. Instead of real size in centimeters it contains encoded aspect ratio (e.g. 1600x900, 16x10, 160x90).
This leads to incorrect calculation of diagonal for the purpose of e.g. Unity settings app.

[Test Case]

 1. Connect a display device that provides incorrect EDID data (e.g. LG 49UB850T-DA TV).
 2. Open the Displays section of Unity settings.
 3. Look for the name of the newly connected display in the settings window.

Expected result:
Display name should contain its real diagonal or model name (if dimensions are not availabe).

Actual result:
Display name contains a ridiculous diagonal (e.g. 72" in case of a 49" display).

[Regression Potential]

 * This affects the way the display name will be formatted for any software using unity-settings-daemon. If anything is testing/comparing display names - it may fail.

[Other Info]

* Original bug description:

After connecting a LG 49UB850T-DA TV the following information is displayed in the unity-control-center: Goldstar Company Ltd 72"

It's misleading since neither the company name nor the diagonal matches.

Related branches

Dariusz Gadomski (dgadomski) wrote :

Goldstar seems to be a former name of LG (before the Lucky-Goldstar merge).

I've made a pull request upstream to update it:
https://github.com/vcrhonek/hwdata/pull/1

Dariusz Gadomski (dgadomski) wrote :

Another thing is the diagonal length calculation. From my quick look this is done based on EDID data in unity-settings-daemon.

summary: - Incorrect information displayed in unity-control-center
+ Incorrect information about display shown in unity-control-center

After examining raw EDID data from 2 different LG TVs I can see that both of them set bytes 21 and 22 of the EDID data in a wrong way.
They both state that the display size is 160x90 cm which in turn corresponds to a approximately 72" diagonal.

So unity-settings-daemon does its job correctly and EDID from LG is buggy. Trying to find more info about it.

Changed in unity-settings-daemon (Ubuntu):
status: New → Invalid
Changed in unity-settings-daemon (Ubuntu):
status: Invalid → In Progress
Changed in hwdata (Ubuntu):
status: New → In Progress
Victor Kareh (vkareh) wrote :

In case it helps, I've seen comments regarding some TVs encoding the aspect ratio (16/9 or 16/10) as though it was the size:

https://github.com/linuxmint/slick-greeter/blob/master/files/usr/bin/slick-greeter-check-hidpi#L24-L29

Not sure what is the actual source of this information, though.

Khurshid Alam (khurshid-alam) wrote :

Is this still valid for u-s-d? I believe the bug was fixed in hwdata.

Dariusz Gadomski (dgadomski) wrote :

It's still valid. hwdata fixed the "vendor name" part of the issue. u-s-d needs to be patched to fix the "nonsense diagonal calculation" part.

description: updated
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Low
Changed in hwdata (Ubuntu):
importance: Undecided → Low
description: updated
Sebastien Bacher (seb128) wrote :

u-s-d uploaded to disco & SRUed to cosmic/bionic/xenial

Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Committed
Changed in hwdata (Ubuntu):
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

I've updated hwdata in disco, but looking at the gnome-desktop code it seems to query the info from udev/hwdb nowadays and not hwdata. Could you test on >= bionic if the vendor is still buggy (Goldstar instead of LG)? The fix does make sense for xenial though so I'm going to SRU there

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+18.04.20180413-0ubuntu4

---------------
unity-settings-daemon (15.04.1+18.04.20180413-0ubuntu4) disco; urgency=medium

  [ Dariusz Gadomski ]
  * gnome-settings-daemon/display-name.c:
    - some vendors record the screen ratio (e.g 16/9) in the EDID instead
      of including the screen size, detect those cases and display
      the product name instead of the screen diagonal. (lp: #1755490)

 -- Sebastien Bacher <email address hidden> Tue, 20 Nov 2018 16:07:31 +0100

Changed in unity-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Dariusz Gadomski (dgadomski) wrote :

seb128: it's also fixed in hwdb upstream (https://github.com/systemd/systemd/pull/10051). I need to check if that's already present in Bionic.

Hello Dariusz, or anyone else affected,

Accepted unity-settings-daemon into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-settings-daemon/15.04.1+18.04.20180413-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unity-settings-daemon (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted unity-settings-daemon into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-settings-daemon/15.04.1+18.04.20180413-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unity-settings-daemon (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic

This bug was fixed in the package hwdata - 0.317-0ubuntu2

---------------
hwdata (0.317-0ubuntu2) disco; urgency=medium

  * debian/rules:
    - don't install deprecated changelog

 -- Sebastien Bacher <email address hidden> Tue, 20 Nov 2018 17:01:21 +0100

Changed in hwdata (Ubuntu):
status: Fix Committed → Fix Released
Dariusz Gadomski (dgadomski) wrote :

seb128: I checked and sadly none of the releases (including disco) contains the hwdb fix - looks like it hasn't been released yet upstream - latest systemd release (239) has been published before the fix has been comitted.

Sebastien Bacher (seb128) wrote :

@Dariuz, oh ok, I see, systemd has its own import/db and changes on top, you forgot to mention that in your report/bug description. I found back to info and it has been fixed in systemd in that commit
https://github.com/systemd/systemd/commit/c6d7a5e9 and indeed there has been not systemd release since

description: updated
summary: - Incorrect information about display shown in unity-control-center
+ Incorrect information about display shown in gnome/unity-control-center
Sebastien Bacher (seb128) wrote :

I've opened bug #804584 for the systemd/hwdb change/SRU (easier to have another bug/test case)

Sebastien Bacher (seb128) wrote :

The xenial SRU was not accepted yet because it's blocked by another SRU that needs to be verified (https://launchpad.net/ubuntu/+source/unity-settings-daemon/15.04.1+16.04.20160701-0ubuntu2) and is already in proposed. We lack the hardware/Tester for that verification but since we know it's working on bionic and the update doesn't create a regression I've tagged it verified now, which should unblock the fix here

Sebastien Bacher (seb128) wrote :

(bug #1804584 is the correct number for the systemd report)

Dariusz Gadomski (dgadomski) wrote :

I have just verified both: bionic (15.04.1+18.04.20180413-0ubuntu1.2) and cosmic (15.04.1+18.04.20180413-0ubuntu3) u-s-d packages.

In both cases it calculates the diagonal correctly or puts the model name if the real dimensions are not available.

However, there is a problem I didn't see coming: hwdata is not installed by default on bionic & cosmic, so the PNP codes are not resolved to vendor names, e.g. u-s-d returned DEL for Dell and GSM for LG Electronics.

What are your thoughts on this Seb? Is it worth pulling in hwdata as dependency of u-s-d?
It's clearly safer than changing the implementation to use systemd's hwdb.

Sebastien Bacher (seb128) wrote :

@Dariusz, I guess we would think about that but I wouldn't block the SRU on that since the change isn't buggy even without hwdata, you get a label with a vendor code instead of a buggy value, which is still an improvement.

Dariusz Gadomski (dgadomski) wrote :

Alright, thanks Seb. It makes it verified then.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Changed in unity-settings-daemon (Ubuntu Bionic):
importance: Undecided → Low
Changed in unity-settings-daemon (Ubuntu Cosmic):
importance: Undecided → Low

Hello Dariusz, or anyone else affected,

Accepted unity-settings-daemon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-settings-daemon/15.04.1+16.04.20160701-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unity-settings-daemon (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
Dariusz Gadomski (dgadomski) wrote :

hwdata SRU proposal for cosmic.

Dariusz Gadomski (dgadomski) wrote :

hwdata SRU proposal for bionic.

Dariusz Gadomski (dgadomski) wrote :

hwdata SRU proposal for xenial.

Dariusz Gadomski (dgadomski) wrote :

I've just verified it on xenial (15.04.1+16.04.20160701-0ubuntu3). Works as expected. Thanks!

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Dariusz Gadomski (dgadomski) wrote :

I have also provided debdiffs for hwdata (disco is already synced with upstream) so that LG devices are not shown under Goldstar label.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+18.04.20180413-0ubuntu1.2

---------------
unity-settings-daemon (15.04.1+18.04.20180413-0ubuntu1.2) bionic; urgency=medium

  [ Dariusz Gadomski ]
  * gnome-settings-daemon/display-name.c:
    - some vendors record the screen ratio (e.g 16/9) in the EDID instead
      of including the screen size, detect those cases and display
      the product name instead of the screen diagonal. (lp: #1755490)

 -- Sebastien Bacher <email address hidden> Tue, 20 Nov 2018 16:07:31 +0100

Changed in unity-settings-daemon (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity-settings-daemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+18.04.20180413-0ubuntu3

---------------
unity-settings-daemon (15.04.1+18.04.20180413-0ubuntu3) cosmic; urgency=medium

  [ Dariusz Gadomski ]
  * gnome-settings-daemon/display-name.c:
    - some vendors record the screen ratio (e.g 16/9) in the EDID instead
      of including the screen size, detect those cases and display
      the product name instead of the screen diagonal. (lp: #1755490)

 -- Sebastien Bacher <email address hidden> Tue, 20 Nov 2018 16:07:31 +0100

Changed in unity-settings-daemon (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

I see an hwdata upload for Xenial but I don't see the change to GSM / Goldstar Company as having been done in Disco. Is there a reason it hasn't been updated there too?

Changed in hwdata (Ubuntu):
status: Fix Released → Incomplete

The attachment "cosmic_hwdata_0.290-1ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Dariusz Gadomski (dgadomski) wrote :

Brian: afaik disco version of hwdata has been synced with latest upstream by Sebastien. Upstream has this change already applied.

With the disco package source:
grep GSM hwdata-0.317/pnp.ids*
hwdata-0.317/pnp.ids:GSM LG Electronics
hwdata-0.317/pnp.ids.patch:-GSM Goldstar Company Ltd
hwdata-0.317/pnp.ids.patch:+GSM LG Electronics

Brian Murray (brian-murray) wrote :

Ah, my bad the system I was on didn't have disco in its sources.list file.

Changed in hwdata (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial

Hello Dariusz, or anyone else affected,

Accepted hwdata into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hwdata/0.267-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in hwdata (Ubuntu):
status: Incomplete → Fix Released
Dariusz Gadomski (dgadomski) wrote :

Looks like the latest hwdata update (0.267-1ubuntu1) doesn't have full debdiff applied. The change to hwdata-0.267/pnp.ids is missing, it contains only changes to hwdata-0.267/pnp.ids.patch.

It doesn't fix the issue this way.

tags: added: verification-failed-xenial
removed: verification-needed-xenial
tags: added: verification-failed
removed: verification-needed
Dan Streetman (ddstreet) wrote :

Uploaded patched hwdata to cosmic and bionic, and corrected hwdata to xenial. Please remove the hwdata_0.267-1ubuntu1 package in xenial-proposed.

Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted hwdata into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hwdata/0.267-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-xenial
removed: verification-failed verification-failed-xenial
Changed in hwdata (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
removed: verification-done-bionic
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted hwdata into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hwdata/0.290-1ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in hwdata (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
removed: verification-done-cosmic
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted hwdata into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hwdata/0.290-1ubuntu0.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Dariusz Gadomski (dgadomski) wrote :

Run the verifications for:
hwdata | 0.267-1ubuntu2 | xenial-proposed
hwdata | 0.290-1ubuntu0.18.04.1 | bionic-proposed
hwdata | 0.290-1ubuntu0.18.10.1 | cosmic-proposed

tags: added: verification-done-bionic verification-done-cosmic verification-done-xenial
removed: verification-needed-bionic verification-needed-cosmic verification-needed-xenial
tags: added: verification-done
removed: verification-needed
Dariusz Gadomski (dgadomski) wrote :

I checked hwdata output in Unity Settings Displays menu with 2 different devices (vendors: LG and Dell) on LiveCDs for xenial, bionic, cosmic with the proposed patch installed (and with ubuntu-unity-desktop installed from universe in case of bionic and comsmic).

Worked as expected (i.e. in the Test Case section of the bug description).

Dariusz Gadomski (dgadomski) wrote :

It was brought to my attention by Dan that trusty is also worth fixing. The patch to hwdata is identical, however somewhere between trusty and xenial the make_display_name implementation has been moved from gnome-desktop to u-s-d.

Hence, despite display-name.c being almost identical in both cases for trusty patching g-d is needed instead of u-s-d.

Dariusz Gadomski (dgadomski) wrote :

hwdata SRU proposal for trusty

Dariusz Gadomski (dgadomski) wrote :

gnome-desktop SRU proposal for trusty

Dariusz Gadomski (dgadomski) wrote :

unity-settings-daemon should NOT be nominated for trusty, but I can't fix that.

Dan Streetman (ddstreet) on 2018-11-30
Changed in unity-settings-daemon (Ubuntu Trusty):
status: New → Invalid
Changed in hwdata (Ubuntu Xenial):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in hwdata (Ubuntu Bionic):
importance: Undecided → Low
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in hwdata (Ubuntu Cosmic):
assignee: nobody → Dariusz Gadomski (dgadomski)
importance: Undecided → Low
Changed in hwdata (Ubuntu Xenial):
importance: Undecided → Low
Changed in hwdata (Ubuntu Trusty):
importance: Undecided → Low
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in gnome-desktop3 (Ubuntu Trusty):
assignee: nobody → Dariusz Gadomski (dgadomski)
importance: Undecided → Low
status: New → In Progress
Changed in hwdata (Ubuntu Trusty):
status: New → In Progress
Changed in gnome-desktop3 (Ubuntu):
status: New → Fix Released
Dariusz Gadomski (dgadomski) wrote :

I have also verified unity-settings-daemon 15.04.1+16.04.20160701-0ubuntu3 for Xenial.

After connecting a faulty-EDID display - I saw the product name. With a display device with correct dimensions in EDID - screen diagonal in inches was displayed.

Dan Streetman (ddstreet) wrote :

uploaded hwdata and gnome-desktop3 to trusty, thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+16.04.20160701-0ubuntu3

---------------
unity-settings-daemon (15.04.1+16.04.20160701-0ubuntu3) xenial; urgency=medium

  [ Dariusz Gadomski ]
  * gnome-settings-daemon/display-name.c:
    - some vendors record the screen ratio (e.g 16/9) in the EDID instead
      of including the screen size, detect those cases and display
      the product name instead of the screen diagonal. (lp: #1755490)

 -- Sebastien Bacher <email address hidden> Tue, 20 Nov 2018 16:32:09 +0100

Changed in unity-settings-daemon (Ubuntu Xenial):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted gnome-desktop3 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-desktop3/3.8.4-0ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-desktop3 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-trusty
removed: verification-done
Changed in hwdata (Ubuntu Trusty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted hwdata into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hwdata/0.249-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Dariusz Gadomski (dgadomski) wrote :

I have verified the following packages on Trusty:
hwdata - 0.249-1ubuntu1
gnome-desktop-3 - 3.8.4-0ubuntu3.3

With the above packages installed from -proposed the labels presented in the 'Displays' panel of u-c-c are correct: when real size is available in EDID data diagonal is displayed, otherwise the model/product name is used.

In all cases vendor PNP codes were resolved to vendor names according to hwdata records.

tags: added: verification-done verification-done-trusty
removed: verification-needed verification-needed-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hwdata - 0.267-1ubuntu2

---------------
hwdata (0.267-1ubuntu2) xenial; urgency=medium

  * Change PNP vendor name for GSM to LG Electronics (LP: #1755490)
    Update pnp.ids file, which was missing from last change.

 -- Dariusz Gadomski <email address hidden> Tue, 27 Nov 2018 09:13:39 +0100

Changed in hwdata (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hwdata - 0.290-1ubuntu0.18.04.1

---------------
hwdata (0.290-1ubuntu0.18.04.1) bionic; urgency=medium

  * Change PNP vendor name for GSM to LG Electronics (LP: #1755490)

 -- Dariusz Gadomski <email address hidden> Tue, 27 Nov 2018 09:10:48 +0100

Changed in hwdata (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hwdata - 0.290-1ubuntu0.18.10.1

---------------
hwdata (0.290-1ubuntu0.18.10.1) cosmic; urgency=medium

  * Change PNP vendor name for GSM to LG Electronics (LP: #1755490)

 -- Dariusz Gadomski <email address hidden> Tue, 27 Nov 2018 09:05:24 +0100

Changed in hwdata (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers