zesty login screen is all black (with a cursor) [unity-settings-daemon: undefined symbol: gnome_settings_plugin_info_set_settings_prefix]

Bug #1675612 reported by Daniel van Vugt on 2017-03-24
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
Critical
Robert Ancell

Bug Description

zesty login screen is all black (with a cursor)

Started today after applying the latest updates.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: lightdm 1.21.5-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-13.15-generic 4.10.1
Uname: Linux 4.10.0-13-generic x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
Date: Fri Mar 24 10:35:47 2017
InstallationDate: Installed on 2016-11-03 (141 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161102)
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel van Vugt (vanvugt) wrote :
Changed in unity-greeter (Ubuntu):
importance: Undecided → Critical
tags: added: black-screen
Daniel van Vugt (vanvugt) wrote :

Log attached. Signal 10 is always bad...

Daniel van Vugt (vanvugt) wrote :

[+0.96s] DEBUG: Got signal 10 from process 1414

which is from:

root 1414 0.0 0.1 179968 31760 tty7 Ss+ 10:33 0:00 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Daniel van Vugt (vanvugt) wrote :

Rebooted and still a black screen.

Although ps reports the greeter is running:

lightdm 1881 0.0 0.0 4496 772 ? Ss 10:46 0:00 /bin/sh /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/unity-greeter
lightdm 1882 0.2 0.1 604308 30668 ? Sl 10:46 0:00 /usr/sbin/unity-greeter

and

root 1790 0.0 0.0 241512 8812 ? Sl 10:46 0:00 lightdm --session-child 16 19

Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :

$ /usr/lib/unity-settings-daemon/unity-settings-daemon
/usr/lib/unity-settings-daemon/unity-settings-daemon: symbol lookup error: /usr/lib/unity-settings-daemon/unity-settings-daemon: undefined symbol: gnome_settings_plugin_info_set_settings_prefix

Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Critical
Daniel van Vugt (vanvugt) wrote :
summary: - zesty login screen is all black (with a cursor)
+ zesty login screen is all black (with a cursor) [unity-settings-daemon:
+ undefined symbol: gnome_settings_plugin_info_set_settings_prefix]
Robert Ancell (robert-ancell) wrote :

15.04.1+17.04.20170322-0ubuntu1.1 uploaded with the merge reverted.

no longer affects: unity-greeter (Ubuntu)
no longer affects: lightdm (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
SamuelB. (bw-sammy) on 2017-03-24
Changed in unity-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
SamuelB. (bw-sammy) wrote :

accidently clicked on Fix Released. Sorry. How to revert this???

Changed in unity-settings-daemon (Ubuntu):
status: Fix Released → Fix Committed
Gunnar Hjalmarsson (gunnarhj) wrote :

I built the uploaded source locally and can confirm that it fixes the issue.

Steve Langasek (vorlon) on 2017-03-24
tags: removed: regression-update
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+17.04.20170322-0ubuntu1.1

---------------
unity-settings-daemon (15.04.1+17.04.20170322-0ubuntu1.1) zesty; urgency=medium

  * Revert drop updates plugin (LP: #1675612)

 -- Robert Ancell <email address hidden> Fri, 24 Mar 2017 16:40:30 +1300

Changed in unity-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
en (b21enu) wrote :

neither the update nor the workaround worked for me

Daniel van Vugt (vanvugt) wrote :

Seems to have missed "pre-release freeze" since the old broken version is still in zesty:
https://launchpad.net/ubuntu/+source/unity-settings-daemon

Or maybe just wait a few minutes?

en (b21enu) wrote :

I was able to boot to black screen with cursor symbol. Typing Ctrl+Alt+F1, logging in and then running startx I only did get desktop with nautilus, but apparently not unity.

Daniel van Vugt (vanvugt) wrote :

Then you are experiencing a different bug. Please log your issue here:
https://bugs.launchpad.net/ubuntu/+filebug

en (b21enu) wrote :

I've created https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1675689

After latest updates everything seems to work fine again! Thanks!

Confirmed - last updates fixed this issue for me.

stecklum (stecklum) wrote :

I was affected as well, thanks for the quick fix!

Khurshid Alam (khurshid-alam) wrote :

Even it it fixed the black screen, now I get gtk-greeter for lock screen and not the unity greeter. Not sure if it is a bug lightdm or settings-daemon

Daniel van Vugt (vanvugt) wrote :

Please log a new bug for that:
https://bugs.launchpad.net/ubuntu/+filebug

Khurshid Alam (khurshid-alam) wrote :

I did. Bug: 1677626

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers