unity-settings-daemon crashed with SIGABRT in g_assertion_message()

Bug #1542699 reported by Zed Burnett on 2016-02-06
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

16.04 nightly 2016-02-05

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: unity-settings-daemon 15.04.1+16.04.20160201-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
Date: Sat Feb 6 19:05:56 2016
ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon
InstallationDate: Installed on 2016-02-06 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160205)
ProcCmdline: /usr/lib/unity-settings-daemon/unity-settings-daemon
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/false
Signal: 6
SourcePackage: unity-settings-daemon
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 gsd_rr_config_load_current () from /usr/lib/x86_64-linux-gnu/libunity-settings-daemon.so.1
 gsd_rr_config_new_current () from /usr/lib/x86_64-linux-gnu/libunity-settings-daemon.so.1
 gsd_rr_config_load_filename () from /usr/lib/x86_64-linux-gnu/libunity-settings-daemon.so.1
Title: unity-settings-daemon crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Zed Burnett (chophshiy) wrote :

StacktraceTop:
 g_assertion_message () from /tmp/apport_sandbox_fUEYH1/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /tmp/apport_sandbox_fUEYH1/lib/x86_64-linux-gnu/libglib-2.0.so.0
 gsd_rr_config_load_current (config=config@entry=0x7f797c006c20, error=error@entry=0x7ffda7640cb0) at gsd-rr-config.c:661
 gsd_rr_config_new_current (screen=<optimized out>, error=error@entry=0x7ffda7640cb0) at gsd-rr-config.c:737
 gsd_rr_config_load_filename (result=result@entry=0x7f797c006ba0, filename=filename@entry=0x1efc3d0 "/var/lib/lightdm/.config/monitors.xml.backup", error=error@entry=0x7ffda7640cb0) at gsd-rr-config.c:677

Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Chris Coulson (chrisccoulson) wrote :

I'm seeing the same issue. What appears to be happening is that there are multiple outputs with the same name, but with different properties. After breaking in gsd_rr_config_match at the end of gsd_rr_config_load_current:

(gdb) p c1->priv->outputs[9]->priv->name
$54 = 0x1b3b370 "DP-3"
(gdb) p c1->priv->outputs[3]->priv->name
$55 = 0x1b3b2f0 "DP-3"
(gdb) p c1->priv->outputs[9]->priv->product
$56 = 0
(gdb) p c1->priv->outputs[3]->priv->product
$57 = 41150
(gdb) p c1->priv->outputs[3]->priv->vendor
$58 = "DEL"
(gdb) p c1->priv->outputs[9]->priv->vendor
$59 = "\000\000\000"
(gdb) p c1->priv->outputs[9]->priv->serial
$60 = 0
(gdb) p c1->priv->outputs[3]->priv->serial
$61 = 808666700

I assume these duplicates come from XRRGetScreenResources, which means it might be a driver issue.

Are you using the NVIDIA binary driver by any chance? (I am)

information type: Private → Public
Stefan Oesterreich (soballin93) wrote :

Yes I am using the Nvidia 361.42 (proprietary, tested). I was trying to get either HDMI and Displayport or HDMI and VGA working simultaneously, but was unable to do so. When trying to open display settings the entire system settings window would crash.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
andyczerwonka (andy-czerwonka) wrote :

Dell 7510 Laptop, M1000M NVidia Video, Intel Video

This happens to me under the following conditions.

1. Using NVidia driver only. This does not happen when using the Intel Prime profile.
2. Only when I plug in an external monitor into the mini displayport. If I boot up without the monitor attached, everything is fine and Unity runs well.

Note: The displayport monitor is not recognized.

andyczerwonka (andy-czerwonka) wrote :

Forgot to mention, I tried 3 different NVidia drivers, 340, 361 & 367. All exhibit the same issue. Also note that this started happening after my upgrade from 15.10 to 16.04. The driver worked fine under 15.10, I was able to use the external monitor under the NVidia driver and Unity did not crash.

Łukasz Zemczak (sil2100) wrote :

Will be sponsoring this through Bileto once the currently in-progress unity-settings-daemon ticket gets released.

Łukasz Zemczak (sil2100) wrote :

Related bileto ticket in-progress: https://bileto.ubuntu.com/#/ticket/2657

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+17.04.20170328-0ubuntu1

---------------
unity-settings-daemon (15.04.1+17.04.20170328-0ubuntu1) zesty; urgency=medium

  [ Chris Coulson ]
  * Filter out outputs that don't have any corresponding CRTCs or modes.
    (LP: #1542699)

 -- Łukasz Zemczak <email address hidden> Tue, 28 Mar 2017 08:18:02 +0000

Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers