/usr/lib/unity-settings-daemon/unity-settings-daemon:11:notify_have_shell:do_call:ffi_call_unix64:ffi_call:g_cclosure_marshal_generic

Bug #1501576 reported by errors.ubuntu.com bug bridge on 2015-10-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding unity-settings-daemon. This problem was most recently seen with version 15.04.1+15.10.20150917-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/011777db07324567e658727fb3ad45564df4e011 contains more details.

Related branches

Robert Ancell (robert-ancell) wrote :

Seems to be caused by us accidentally re-using the GNOME shell watch variable thus never destroying the shell watch correctly on cleanup.

Changed in unity-settings-daemon (Ubuntu):
status: New → Fix Released
status: Fix Released → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.10.20151001-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.10.20151001-0ubuntu1) wily; urgency=medium

  [ Robert Ancell ]
  * Fix shell watch callback not being destroyed. (LP: #1501576)

  [ William Hua ]
  * Don't call fcitx_input_method_activate (). It breaks fcitx' "extra
    key for trigger input method" shortcut. (LP: #1494331)

 -- Sebastien Bacher <email address hidden> Thu, 01 Oct 2015 09:45:25 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers