unity-settings-daemon crashed with SIGSEGV in XGetDeviceProperty() [after laptop is un-docked]

Bug #1439427 reported by Christopher Barrington-Leigh on 2015-04-01
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity Settings Daemon
Fix Released
Medium
unity-settings-daemon (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned

Bug Description

This used to happen under 14.10 too. When I undock my laptop (Lenovo X230T) from its dock (external monitor, wired network, etc) and then put it to sleep, when it wakes up I get this error and no keyboard shortcuts work, e.g. all my custom ones, Ctrl-Alt-T, etc.

Also, this time, maybe or not related, the wifi network stopped working (saw no networks). I killed NetworkManager. It didn't relaunch automatically. I restarted it, and then the network was fine.

My keyboard shortcuts return when I log out and back in.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: unity-settings-daemon 15.04.1+15.04.20150324.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.17-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 1 17:57:17 2015
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon
InstallationDate: Installed on 2015-03-28 (4 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150325)
ProcCmdline: /usr/lib/unity-settings-daemon/unity-settings-daemon
SegvAnalysis:
 Segfault happened at: 0x7fc0fcd9d3bc <XGetDeviceProperty+124>: mov (%r15),%rdx
 PC (0x7fc0fcd9d3bc) ok
 source "(%r15)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-settings-daemon
StacktraceTop:
 XGetDeviceProperty () from /usr/lib/x86_64-linux-gnu/libXi.so.6
 device_set_property () from /usr/lib/unity-settings-daemon-1.0/libgsdwacom.so
 ?? () from /usr/lib/unity-settings-daemon-1.0/libgsdwacom.so
 ?? () from /usr/lib/unity-settings-daemon-1.0/libgsdwacom.so
 ?? () from /usr/lib/unity-settings-daemon-1.0/libgsdwacom.so
Title: unity-settings-daemon crashed with SIGSEGV in XGetDeviceProperty()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip fuse lpadmin plugdev sambashare sudo

Related branches

StacktraceTop:
 XGetDeviceProperty (dpy=0x17eab70, dev=0x0, property=271, offset=0, length=4, delete=0, req_type=0, actual_type=0x7ffdaf2c3408, actual_format=0x7ffdaf2c3404, nitems=0x7ffdaf2c3410, bytes_after=0x7ffdaf2c3418, prop=0x7ffdaf2c3420) at ../../src/XGetDProp.c:64
 device_set_property (xdevice=0x0, device_name=0x1c51280 "Wacom Bamboo 2FG 4x5 Pen stylus", property=0x7ffdaf2c34a0) at gsd-input-helper.c:64
 wacom_set_property (device=device@entry=0x1c4b410, property=property@entry=0x7ffdaf2c34a0) at gsd-wacom-manager.c:170
 set_area (device=device@entry=0x1c4b410, value=0x7fc0f01e2330) at gsd-wacom-manager.c:235
 wacom_settings_changed (settings=0x1a03a60, key=0x19d553a "area", device=0x1c4b410) at gsd-wacom-manager.c:796

Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

the libinput tests seem to make usd hit that issue on xenial

information type: Private → Public
Sebastien Bacher (seb128) wrote :
Changed in unity-settings-daemon (Ubuntu):
importance: Medium → High
status: New → Triaged
Changed in unity-settings-daemon:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in unity-settings-daemon (Ubuntu):
status: Triaged → In Progress
summary: unity-settings-daemon crashed with SIGSEGV in XGetDeviceProperty()
+ [when laptop is un-docked]
summary: unity-settings-daemon crashed with SIGSEGV in XGetDeviceProperty()
- [when laptop is un-docked]
+ [after laptop is un-docked]
Changed in unity-settings-daemon:
status: Confirmed → Fix Released

The unity settings daemon crashes are still occurring for me, after all updates.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+16.10.20160613-0ubuntu1

---------------
unity-settings-daemon (15.04.1+16.10.20160613-0ubuntu1) yakkety; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * PowerManager: connect to keyboard BrightnessChanged signal to update
    the cached current value properly (LP: #1510344)
  * GsdPowerManager: don't cache kbd backlight current value (LP:
    #1583861)
  * common: backport g-s-d commits for having single shared dbus proxies
  * ScreensaverProxy: redirect supported calls to gnome screensaver APIs
    (LP: #1415265, #1584161)

  [ Robert Ancell ]
  * Correctly check value of XDG_CURRENT_DESKTOP.
  * Remove code for disabling plugin under GNOME Shell - they don't use
    u-s-d.
  * Drop print notifications - not used under Unity.

  [ Sebastien Bacher ]
  * power: '0' keyboard backlight is a valid value (LP: #1510344)
  * Don't hit an xerror when a device is removed while being configured
    (LP: #1503758)
  * wacom: don't segfault when a device is removed while being
    configured. (LP: #1439427)
  * power: fix crasher when the plugin is unloaded (LP: #1567116)
  * power: Add sound notification on power plug/unplug

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 13 Jun 2016 11:31:26 +0000

Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Released

This is not fixed for me. I'm using Ubuntu 16.04 and I've updated. After I undock, my computer often comes to a complete lock-up following the symptoms of this bug.
Will it be fixed on my distribution?

Hello Christopher, or anyone else affected,

Accepted unity-settings-daemon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-settings-daemon/15.04.1+16.04.20160701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-settings-daemon (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed

Thanks. I followed most of those directions, and think I've installed the
proposed unity-settings-daemon and added "Crash" to an Apport file. I could
not follow /understand this, though:

""
  Uploading your hardware profile
  To help us track the hardware test coverage, please upload your hardware
profile for the system you will run proposed on using the hardware
testing tool, found in the System -> Administration menu or with the
command checkbox-gtk.
"""
because I couldn't find either that command nor that "menu" item.

Thanks

On Tue, Jul 12, 2016 at 2:54 AM, Martin Pitt <email address hidden> wrote:

> Hello Christopher, or anyone else affected,
>
> Accepted unity-settings-daemon into xenial-proposed. The package will
> build now and be available at https://launchpad.net/ubuntu/+source
> /unity-settings-daemon/15.04.1+16.04.20160701-0ubuntu1 in a few hours,
> and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Also affects: unity-settings-daemon (Ubuntu Xenial)
> Importance: Undecided
> Status: New
>
> ** Changed in: unity-settings-daemon (Ubuntu Xenial)
> Status: New => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1439427
>
> Title:
> unity-settings-daemon crashed with SIGSEGV in XGetDeviceProperty()
> [after laptop is un-docked]
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/unity-settings-daemon/+bug/1439427/+subscriptions
>

Sebastien Bacher (seb128) wrote :

the update resolves the segfault, setting as verification-done

tags: added: verification-done
removed: verification-needed

I agree. So far I've not had this error any more, using the proposed package
Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+16.04.20160701-0ubuntu1

---------------
unity-settings-daemon (15.04.1+16.04.20160701-0ubuntu1) xenial; urgency=medium

  [ Robert Ancell ]
  * Correctly check value of XDG_CURRENT_DESKTOP.

  [ Marco Trevisan (Treviño) ]
  * PowerManager: connect to keyboard BrightnessChanged signal to update
    the cached current value properly (LP: #1510344)
  * GsdPowerManager: don't cache kbd backlight current value (LP:
    #1583861)
  * common: backport g-s-d commits for having single shared dbus proxies
  * ScreensaverProxy: redirect supported calls to gnome screensaver APIs
    (LP: #1415265, LP: #1584161)

  [ Sebastien Bacher ]
  * Don't hit an xerror when a device is removed while being configured
    (LP: #1503758)
  * wacom: don't segfault when a device is removed while being
    configured. (LP: #1439427)

  [ Marco Trevisan (Treviño) ]
  * GsdPowerManager: use proper return value for upower_kbd_toggle
    wherever we use it (LP: #1592816)

  [ Kai-Heng Feng ]
  * SettingsManager: Queue up signals before getting D-Bus connection.
    (LP: #1571640)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 01 Jul 2016 13:28:54 +0000

Changed in unity-settings-daemon (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity-settings-daemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.