unity-settings-daemon crashed with SIGSEGV in engine_update_composite_device()

Bug #1436861 reported by Dave Morley on 2015-03-26
52
This bug affects 5 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
High
Lars Karlitski

Bug Description

STEPS:
1. Burn vivid 64bit to dvd
2. On a system with UEFI boot the dvd
3. Select oem mode install
4. Complete the install
5. Restart
6. In oem mode select prepare to ship
7. Reboot
8. Input end user details
9. System crashes

EXPECTED:
System to complete End user setup and boot into the OS for the user

ACTUAL:
System crashes screen blanks, come to the desktop login with the user name (D in this case) and oem temporary user still in place.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: unity-settings-daemon 15.04.1+15.04.20150318-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
Date: Thu Mar 26 14:12:57 2015
ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon
InstallationDate: Installed on 2015-03-26 (0 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150325)
ProcCmdline: /usr/lib/unity-settings-daemon/unity-settings-daemon
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7f4a5c38d017: mov 0x8(%r13),%esi
 PC (0x7f4a5c38d017) ok
 source "0x8(%r13)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/unity-settings-daemon-1.0/libpower.so
 ?? () from /usr/lib/unity-settings-daemon-1.0/libpower.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-settings-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Dave Morley (davmor2) wrote :
description: updated
Dave Morley (davmor2) on 2015-03-26
information type: Private → Public
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1436861

tags: added: iso-testing

StacktraceTop:
 engine_update_composite_device (manager=0x1d3f200, original_device=0x7f4a5800f270) at gsd-power-manager.c:781
 device_properties_changed_cb (device=0x7f4a5800f270, pspec=0x50, manager=0x1d3f200) at gsd-power-manager.c:1631
 g_closure_invoke (closure=0x1db52a0, return_value=0x0, n_param_values=2, param_values=0x7fff028ab120, invocation_hint=0x7fff028ab0c0) at /build/buildd/glib2.0-2.43.92/./gobject/gclosure.c:768
 signal_emit_unlocked_R (node=node@entry=0x1cadbb0, detail=detail@entry=1247, instance=instance@entry=0x7f4a5800f270, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fff028ab120) at /build/buildd/glib2.0-2.43.92/./gobject/gsignal.c:3549
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fff028ab2b0) at /build/buildd/glib2.0-2.43.92/./gobject/gsignal.c:3305

Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: - unity-settings-daemon crashed with SIGSEGV in g_closure_invoke()
+ unity-settings-daemon crashed with SIGSEGV in
+ engine_update_composite_device()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
tags: added: wily
Sebastien Bacher (seb128) wrote :
Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → In Progress
importance: Medium → High
assignee: nobody → Lars Uebernickel (larsu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.10.20151021-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.10.20151021-0ubuntu1) wily; urgency=medium

  [ Lars Uebernickel ]
  * power: disconnect from device's "notify" signals (LP: #1436861)

 -- Sebastien Bacher <email address hidden> Wed, 21 Oct 2015 11:05:04 +0000

Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers