Battery hot key does not bring up the power management dialog in Trusty

Bug #1432976 reported by Po-Hsu Lin on 2015-03-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
unity-settings-daemon (Ubuntu)
Medium
Sebastien Bacher
Trusty
Undecided
Unassigned

Bug Description

* Impact
the battery hotkey doesn't do anything

* Test case:
On a laptop with a special key for battery info press fn+f3
-> the power info dialog should be displayed

* Regression potential
the action used before was buggy, having a valid one shouldn't create any issue

--------------------------------------

CID: 201209-11840 Dell L322X

The battery hotkey on this system (fn+f3) cannot bring up the power management dialog.
Also verified with 14.04.2 on LiveUSB, it's not working as well.
But it works with 12.04.5 on LiveUSB. (Maybe it's user-space related?)

It seems that the key event could be detected properly, it could pass our checkbox test (which will check the '0xe071,0xef1:Battery Info' signal)

ubuntu@201209-11840:~$ sudo showkey -k
kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode 28 release
keycode 240 press
keycode 240 release
keycode 238 press
keycode 238 release
keycode 29 press
^Ccaught signal 2, cleaning up...
ubuntu@201209-11840:~$

ubuntu@201209-11840:~$ sudo showkey -s
kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
0x9c
0xe0 0x71 0xe0 0xf1
^Ccaught signal 2, cleaning up...
ubuntu@201209-11840:~$

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-32-generic 3.13.0-32.57 [modified: boot/vmlinuz-3.13.0-32-generic]
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1568 F.... pulseaudio
CRDA:
 country TW:
  (2402 - 2472 @ 40), (3, 27)
  (5270 - 5330 @ 40), (3, 17), DFS
  (5735 - 5815 @ 40), (3, 30)
CurrentDesktop: Unity
Date: Tue Mar 17 03:29:53 2015
HibernationDevice: RESUME=UUID=de4c68b6-83dc-477e-98f1-1696b3233a48
InstallationDate: Installed on 2015-03-13 (3 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: Dell Inc. XPS L322X
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic.efi.signed root=UUID=4039eaa6-fdf4-423a-ace9-930a8911122e ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-32-generic N/A
 linux-backports-modules-3.13.0-32-generic N/A
 linux-firmware 1.127.5
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/28/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd08/28/2013:svnDellInc.:pnXPSL322X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: XPS L322X
dmi.sys.vendor: Dell Inc.

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :

This is the xev ouput when pressing the fn+f3 battery hotkey:

MappingNotify event, serial 39, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 248

FocusOut event, serial 39, synthetic NO, window 0x3e00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 40, synthetic NO, window 0x3e00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 40, synthetic NO, window 0x0,
    keys: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Verified with the latest 3.13 kernel (3.13.0-46), it's still not working.
Also not working with 14.10 LiveUSB, not working with the latest mainline kernel 4.0.0-rc4

Sebastien Bacher (seb128) wrote :
affects: linux (Ubuntu) → unity-settings-daemon (Ubuntu)
Changed in unity-settings-daemon (Ubuntu):
assignee: Anthony Wong (anthonywong) → Sebastien Bacher (seb128)
status: Confirmed → In Progress
description: updated
Changed in hwe-next:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.04.20150318-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.04.20150318-0ubuntu1) vivid; urgency=medium

  [ Ryan Tandy ]
  * Don't call XSyncQueryCounter with a null counter. Avoids a crash
    under FreeNX/X2Go which don't support the IDLETIME counter. (LP:
    #1416081)

  [ Sebastien Bacher ]
  * Open the battery info dialog when using the corresponding hotkey.
    The current code was trying to display a notification with the info
    but we don't have design on how that should look like with notify-
    osd so go back to what we were doing before (LP: #1432976)
  * Restore code that set the scaling factor according the screen dpi,
    but only when not under and Unity session. That was desactived in
    r4020 because Unity is handling those values, but this is not the
    case under ubiquity or unity-greeter. (LP: #1286878)
 -- CI Train Bot <email address hidden> Wed, 18 Mar 2015 12:07:44 +0000

Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Released

Hello Po-Hsu, or anyone else affected,

Accepted unity-settings-daemon into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-settings-daemon/14.04.0+14.04.20140606-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-settings-daemon (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Po-Hsu Lin (cypressyew) wrote :

Hello Brian,
Verified on 201209-11840 with unity-settings-daemon in Trusty proposed, it works.
Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.04.20140606-0ubuntu2

---------------
unity-settings-daemon (14.04.0+14.04.20140606-0ubuntu2) trusty; urgency=medium

  * plugins/media-keys/gsd-media-keys-manager.c:
    - Open the battery info dialog when using the corresponding hotkey.
    The current code was trying to display a notification with the info
    but we don't have design on how that should look like with notify-osd
    so go back to what we were doing before (lp: #1432976)
 -- Sebastien Bacher <email address hidden> Wed, 18 Mar 2015 15:36:20 +0100

Changed in unity-settings-daemon (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity-settings-daemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers