Error in `/usr/lib/unity-settings-daemon/unity-settings-daemon': free(): invalid pointer

Bug #1397135 reported by Ricardo Salveti on 2014-11-27
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
High
Iain Lane

Bug Description

Using vivid, unity-settings-daemon 15.04.1+15.04.20141127-0ubuntu1.

unity-settings-daemon crashes in loop after login, making it really hard to use unity.

Related branches

Ricardo Salveti (rsalveti) wrote :
Ricardo Salveti (rsalveti) wrote :
Download full text (3.4 KiB)

#0 0x00007fdef34f8e37 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt full
#0 0x00007fdef34f8e37 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
        resultvar = 0
        pid = 9423
        selftid = 9423
#1 0x00007fdef34fa528 in __GI_abort () at abort.c:89
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x7fffb0559d60, sa_sigaction = 0x7fffb0559d60}, sa_mask = {__val = {32097008, 755, 1, 0, 0, 0, 0, 1, 30538072, 140736151789040, 140595550913170, 0, 32097008, 408021893121, 4294967300, 30538320}},
          sa_flags = -203648753, sa_restorer = 0x7fffb0559d20}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2 0x00007fdef353ab04 in __libc_message (do_abort=do_abort@entry=1, fmt=fmt@entry=0x7fdef3643be0 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
        ap = {{gp_offset = 40, fp_offset = 0, overflow_arg_area = 0x7fffb0559f40, reg_save_area = 0x7fffb0559ed0}}
        fd = 2
        on_2 = <optimized out>
        list = <optimized out>
        nlist = <optimized out>
        cp = <optimized out>
        written = <optimized out>
#3 0x00007fdef3542116 in malloc_printerr (ptr=<optimized out>, str=0x7fdef363fcb9 "free(): invalid pointer", action=1) at malloc.c:4996
        buf = "00007fffb055a048"
        cp = <optimized out>
#4 _int_free (av=<optimized out>, p=<optimized out>, have_lock=0) at malloc.c:3840
        size = <optimized out>
        fb = <optimized out>
        nextchunk = <optimized out>
        nextsize = <optimized out>
        nextinuse = <optimized out>
        prevsize = <optimized out>
        bck = <optimized out>
        fwd = <optimized out>
        errstr = <optimized out>
        locked = <optimized out>
#5 0x00007fdee87ada1d in ?? () from /usr/lib/unity-settings-daemon-1.0/libpower.so
No symbol table info available.
#6 0x00007fdef3aef613 in g_timeout_dispatch (source=0x1e58d00, callback=<optimized out>, user_data=<optimized out>) at /build/buildd/glib2.0-2.42.1/./glib/gmain.c:4520
        timeout_source = 0x1e58d00
        again = <optimized out>
#7 0x00007fdef3aeeb6d in g_main_dispatch (context=0x1d5a670) at /build/buildd/glib2.0-2.42.1/./glib/gmain.c:3111
        dispatch = 0x7fdef3aef600 <g_timeout_dispatch>
        prev_source = 0x0
        was_in_call = 0
        user_data = 0x1e753e0
        callback = 0x7fdee87ad880
        cb_funcs = <optimized out>
        cb_data = 0x1ec18b0
        need_destroy = <optimized out>
        source = 0x1e58d00
        current = 0x1d9b300
        i = 1
#8 g_main_context_dispatch (context=context@entry=0x1d5a670) at /build/buildd/glib2.0-2.42.1/./glib/gmain.c:3710
No locals.
#9 0x00007fdef3aeef48 in g_main_context_iterate (context=0x1d5a670, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.42.1/./glib/gmain.c:3781
        max_priority = 2147483647
        timeout = 501
        some_ready = 1
        nfds = <optimized out>
        allocated_nfds = 9
        fds = 0x1fb7240
#10 0x00007fdef3aef272 in g_main_loop_run (loop=0x1e37d1...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → High
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.04.20141128-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.04.20141128-0ubuntu1) vivid; urgency=low

  [ Bastien Nocera ]
  * Remove recall check, upower doesn't support this any more and it was
    causing a crash. (LP: #1397135)
 -- Ubuntu daily release <email address hidden> Fri, 28 Nov 2014 09:48:43 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments