Activity log for bug #1394063

Date Who What changed Old value New value Message
2014-11-19 03:33:30 Nicholas Skaggs bug added bug
2014-11-19 03:33:30 Nicholas Skaggs attachment added udev-db.txt https://bugs.launchpad.net/bugs/1394063/+attachment/4263436/+files/udev-db.txt
2014-11-19 03:34:37 Nicholas Skaggs description Hardware keys on an inspirion 3138 for brightness don't work. Xev doesn't show a keypress event. Scan codes from evtest are shown below Event: time 1416367751.898584, -------------- EV_SYN ------------ Event: time 1416367754.952917, type 4 (EV_MSC), code 4 (MSC_SCAN), value 85 Event: time 1416367754.952917, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 1 Event: time 1416367754.952917, -------------- EV_SYN ------------ Event: time 1416367754.952946, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 0 Event: time 1416367754.952946, -------------- EV_SYN ------------ Event: time 1416367756.898936, type 4 (EV_MSC), code 4 (MSC_SCAN), value 86 Event: time 1416367756.898936, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 1 Event: time 1416367756.898936, -------------- EV_SYN ------------ Event: time 1416367756.898968, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 0 ProblemType: Bug DistroRelease: Ubuntu 15.04 Package: udev 215-5ubuntu2 ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4 Uname: Linux 3.16.0-24-generic x86_64 ApportVersion: 2.14.7-0ubuntu10 Architecture: amd64 CurrentDesktop: Unity Date: Tue Nov 18 22:16:25 2014 InstallationDate: Installed on 2014-06-04 (167 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417) MachineType: Dell Inc. Inspiron 3137 ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-24-generic.efi.signed root=UUID=0e352344-90e9-4cbe-acde-376a88cf5b47 ro quiet splash vt.handoff=7 SourcePackage: systemd UpgradeStatus: Upgraded to vivid on 2014-06-04 (167 days ago) dmi.bios.date: 12/25/2013 dmi.bios.vendor: Dell Inc. dmi.bios.version: A05 dmi.board.name: 0PRDX0 dmi.board.vendor: Dell Inc. dmi.board.version: A00 dmi.chassis.type: 8 dmi.chassis.vendor: Dell Inc. dmi.chassis.version: 0.1 dmi.modalias: dmi:bvnDellInc.:bvrA05:bd12/25/2013:svnDellInc.:pnInspiron3137:pvr:rvnDellInc.:rn0PRDX0:rvrA00:cvnDellInc.:ct8:cvr0.1: dmi.product.name: Inspiron 3137 dmi.sys.vendor: Dell Inc. Hardware keys on an inspirion 3137 for brightness don't work. Manually setting the backlight via /sys/class/backlight/intel_backlight/brightness works properly. This worked properly in vivid and has been broken since upgrade. Xev doesn't show a keypress event. Scan codes from evtest are shown below: Event: time 1416367751.898584, -------------- EV_SYN ------------ Event: time 1416367754.952917, type 4 (EV_MSC), code 4 (MSC_SCAN), value 85 Event: time 1416367754.952917, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 1 Event: time 1416367754.952917, -------------- EV_SYN ------------ Event: time 1416367754.952946, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 0 Event: time 1416367754.952946, -------------- EV_SYN ------------ Event: time 1416367756.898936, type 4 (EV_MSC), code 4 (MSC_SCAN), value 86 Event: time 1416367756.898936, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 1 Event: time 1416367756.898936, -------------- EV_SYN ------------ Event: time 1416367756.898968, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 0 ProblemType: Bug DistroRelease: Ubuntu 15.04 Package: udev 215-5ubuntu2 ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4 Uname: Linux 3.16.0-24-generic x86_64 ApportVersion: 2.14.7-0ubuntu10 Architecture: amd64 CurrentDesktop: Unity Date: Tue Nov 18 22:16:25 2014 InstallationDate: Installed on 2014-06-04 (167 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417) MachineType: Dell Inc. Inspiron 3137 ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-24-generic.efi.signed root=UUID=0e352344-90e9-4cbe-acde-376a88cf5b47 ro quiet splash vt.handoff=7 SourcePackage: systemd UpgradeStatus: Upgraded to vivid on 2014-06-04 (167 days ago) dmi.bios.date: 12/25/2013 dmi.bios.vendor: Dell Inc. dmi.bios.version: A05 dmi.board.name: 0PRDX0 dmi.board.vendor: Dell Inc. dmi.board.version: A00 dmi.chassis.type: 8 dmi.chassis.vendor: Dell Inc. dmi.chassis.version: 0.1 dmi.modalias: dmi:bvnDellInc.:bvrA05:bd12/25/2013:svnDellInc.:pnInspiron3137:pvr:rvnDellInc.:rn0PRDX0:rvrA00:cvnDellInc.:ct8:cvr0.1: dmi.product.name: Inspiron 3137 dmi.sys.vendor: Dell Inc.
2014-11-19 03:34:55 Nicholas Skaggs attachment added dmesg.log https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1394063/+attachment/4263448/+files/dmesg.log
2014-11-19 03:35:15 Nicholas Skaggs attachment added lsinput.log https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1394063/+attachment/4263449/+files/lsinput.log
2014-11-19 03:35:29 Nicholas Skaggs attachment added xkbcomp.txt https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1394063/+attachment/4263450/+files/xkbcomp.txt
2014-11-19 03:35:41 Nicholas Skaggs attachment added xkbmap.txt https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1394063/+attachment/4263451/+files/xkbmap.txt
2014-11-19 03:36:26 Nicholas Skaggs summary intel_backlight brightness keys fail Inspiron 3137 brightness keys aren't recognized
2014-11-19 07:17:03 Martin Pitt affects systemd (Ubuntu) unity-settings-daemon (Ubuntu)
2014-11-19 07:23:48 Martin Pitt summary Inspiron 3137 brightness keys aren't recognized [vivid regression] brightness keys aren't recognized
2014-11-19 07:25:03 Martin Pitt bug added subscriber Martin Pitt
2014-11-20 15:14:11 Nicholas Skaggs description Hardware keys on an inspirion 3137 for brightness don't work. Manually setting the backlight via /sys/class/backlight/intel_backlight/brightness works properly. This worked properly in vivid and has been broken since upgrade. Xev doesn't show a keypress event. Scan codes from evtest are shown below: Event: time 1416367751.898584, -------------- EV_SYN ------------ Event: time 1416367754.952917, type 4 (EV_MSC), code 4 (MSC_SCAN), value 85 Event: time 1416367754.952917, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 1 Event: time 1416367754.952917, -------------- EV_SYN ------------ Event: time 1416367754.952946, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 0 Event: time 1416367754.952946, -------------- EV_SYN ------------ Event: time 1416367756.898936, type 4 (EV_MSC), code 4 (MSC_SCAN), value 86 Event: time 1416367756.898936, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 1 Event: time 1416367756.898936, -------------- EV_SYN ------------ Event: time 1416367756.898968, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 0 ProblemType: Bug DistroRelease: Ubuntu 15.04 Package: udev 215-5ubuntu2 ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4 Uname: Linux 3.16.0-24-generic x86_64 ApportVersion: 2.14.7-0ubuntu10 Architecture: amd64 CurrentDesktop: Unity Date: Tue Nov 18 22:16:25 2014 InstallationDate: Installed on 2014-06-04 (167 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417) MachineType: Dell Inc. Inspiron 3137 ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-24-generic.efi.signed root=UUID=0e352344-90e9-4cbe-acde-376a88cf5b47 ro quiet splash vt.handoff=7 SourcePackage: systemd UpgradeStatus: Upgraded to vivid on 2014-06-04 (167 days ago) dmi.bios.date: 12/25/2013 dmi.bios.vendor: Dell Inc. dmi.bios.version: A05 dmi.board.name: 0PRDX0 dmi.board.vendor: Dell Inc. dmi.board.version: A00 dmi.chassis.type: 8 dmi.chassis.vendor: Dell Inc. dmi.chassis.version: 0.1 dmi.modalias: dmi:bvnDellInc.:bvrA05:bd12/25/2013:svnDellInc.:pnInspiron3137:pvr:rvnDellInc.:rn0PRDX0:rvrA00:cvnDellInc.:ct8:cvr0.1: dmi.product.name: Inspiron 3137 dmi.sys.vendor: Dell Inc. Hardware keys on an inspirion 3137 for brightness don't work. Manually setting the backlight via /sys/class/backlight/intel_backlight/brightness  works properly. This worked properly in utopic and has been broken since upgrade to vivid. Xev doesn't show a keypress event. Scan codes from evtest are shown below: Event: time 1416367751.898584, -------------- EV_SYN ------------ Event: time 1416367754.952917, type 4 (EV_MSC), code 4 (MSC_SCAN), value 85 Event: time 1416367754.952917, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 1 Event: time 1416367754.952917, -------------- EV_SYN ------------ Event: time 1416367754.952946, type 1 (EV_KEY), code 224 (KEY_BRIGHTNESSDOWN), value 0 Event: time 1416367754.952946, -------------- EV_SYN ------------ Event: time 1416367756.898936, type 4 (EV_MSC), code 4 (MSC_SCAN), value 86 Event: time 1416367756.898936, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 1 Event: time 1416367756.898936, -------------- EV_SYN ------------ Event: time 1416367756.898968, type 1 (EV_KEY), code 225 (KEY_BRIGHTNESSUP), value 0 ProblemType: Bug DistroRelease: Ubuntu 15.04 Package: udev 215-5ubuntu2 ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4 Uname: Linux 3.16.0-24-generic x86_64 ApportVersion: 2.14.7-0ubuntu10 Architecture: amd64 CurrentDesktop: Unity Date: Tue Nov 18 22:16:25 2014 InstallationDate: Installed on 2014-06-04 (167 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417) MachineType: Dell Inc. Inspiron 3137 ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-24-generic.efi.signed root=UUID=0e352344-90e9-4cbe-acde-376a88cf5b47 ro quiet splash vt.handoff=7 SourcePackage: systemd UpgradeStatus: Upgraded to vivid on 2014-06-04 (167 days ago) dmi.bios.date: 12/25/2013 dmi.bios.vendor: Dell Inc. dmi.bios.version: A05 dmi.board.name: 0PRDX0 dmi.board.vendor: Dell Inc. dmi.board.version: A00 dmi.chassis.type: 8 dmi.chassis.vendor: Dell Inc. dmi.chassis.version: 0.1 dmi.modalias: dmi:bvnDellInc.:bvrA05:bd12/25/2013:svnDellInc.:pnInspiron3137:pvr:rvnDellInc.:rn0PRDX0:rvrA00:cvnDellInc.:ct8:cvr0.1: dmi.product.name: Inspiron 3137 dmi.sys.vendor: Dell Inc.
2014-11-24 22:40:03 Jean-Baptiste Lallement bug added subscriber Jean-Baptiste Lallement
2014-11-25 08:12:04 Jean-Baptiste Lallement unity-settings-daemon (Ubuntu): importance Undecided High
2014-11-25 08:12:04 Jean-Baptiste Lallement unity-settings-daemon (Ubuntu): status New Confirmed
2014-11-26 01:20:08 Sean V Kelley bug added subscriber Sean V Kelley
2014-11-27 10:32:20 Launchpad Janitor branch linked lp:~laney/unity-settings-daemon/lp1394063
2014-11-27 12:08:54 Iain Lane bug added subscriber Iain Lane
2014-11-27 17:41:02 Launchpad Janitor unity-settings-daemon (Ubuntu): status Confirmed Fix Released
2014-11-27 17:48:08 Launchpad Janitor branch linked lp:ubuntu/unity-settings-daemon