microphone mute icon support

Bug #1389099 reported by TienFu Chen on 2014-11-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
Trusty
Undecided
Unassigned
unity-settings-daemon (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

When we press mic mute key(XF86AudioMicMute, in some HP's notebook, it's Fn+F8), the notification shows sound mute icon, not mic mute icon. To simulate XF86AudioMicMute, you can run "xdotool key XF86AudioMicMute".

My investigation:
In the file: gsd-media-keys-manager.c, there's no icons[] array for mic mute, there're only volume_icons, brightness_icons, kb_backlight_icons. We should add detection functions for mic volume.

Also we need icon files for mic volume. File name should be something like notification-audio-input-microphone-low-zero, notification-audio-input-microphone-high and located in /usr/share/notify-osd/icons/gnome/scalable/status (offered by notify-osd-icons package).

Packages:
unity-settings-daemon_14.04.0+14.04.20140414-0ubuntu1_amd64.deb

Related branches

TienFu Chen (ctf) on 2014-11-04
description: updated
TienFu Chen (ctf) on 2014-11-04
summary: - microphone mute support
+ microphone mute icon support
TienFu Chen (ctf) on 2014-11-05
description: updated
description: updated
TienFu Chen (ctf) on 2014-11-06
description: updated
description: updated
description: updated
TienFu Chen (ctf) on 2014-11-06
description: updated
Ara Pulido (ara) wrote :

Is this fixed in Vivid?

Changed in oem-priority:
status: New → Incomplete
TienFu Chen (ctf) wrote :

I don't think this is fixed in vivid, as the source file gsd-media-keys-manager.c is same between trusty and vivid.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu Trusty):
status: New → Confirmed
Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Anthony Wong (anthonywong) wrote :

Incidentally HWE engineer Wang Hui has also been working on this issue (LP: #1381856), I am linking his branch here as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.04.20150107-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.04.20150107-0ubuntu1) vivid; urgency=low

  [ Hui Wang ]
  * show correct microphone mute icon (LP: #1381856, #1389099)
 -- Ubuntu daily release <email address hidden> Wed, 07 Jan 2015 16:55:42 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) on 2015-01-16
Changed in oem-priority:
status: Incomplete → New
Bin Li (binli) wrote :

Hi, guys.

 When could we backport to trusty? Thanks!

Ara Pulido (ara) wrote :

Is this still needed in Trusty?

Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers