unity-settings-daemon crashed with SIGSEGV in _gdk_device_xi2_reset_scroll_valuators()

Bug #1380278 reported by Alexander Finn on 2014-10-12
216
This bug affects 30 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
High
Lars Karlitski

Bug Description

I don't know

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: unity-settings-daemon 14.04.0+14.10.20141010-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Uname: Linux 3.16.0-22-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.7-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Oct 12 16:07:07 2014
ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon
InstallationDate: Installed on 2014-09-21 (21 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140921)
ProcCmdline: /usr/lib/unity-settings-daemon/unity-settings-daemon
SegvAnalysis:
 Segfault happened at: 0x7f4aed57b3a4: mov 0x8(%rax),%edx
 PC (0x7f4aed57b3a4) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 gdk_display_get_event () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Title: unity-settings-daemon crashed with SIGSEGV in gdk_display_get_event()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Related branches

Alexander Finn (aaex) wrote :

StacktraceTop:
 _gdk_device_xi2_reset_scroll_valuators (device=0x24c4b10) at /build/buildd/gtk+3.0-3.12.2/./gdk/x11/gdkdevice-xi2.c:870
 handle_device_changed (ev=<optimized out>, device_manager=<optimized out>) at /build/buildd/gtk+3.0-3.12.2/./gdk/x11/gdkdevicemanager-xi2.c:775
 gdk_x11_device_manager_xi2_translate_event (translator=0x24c4b10, display=0x2490ec0, event=0x27fcde0, xevent=0x7fffe571b120) at /build/buildd/gtk+3.0-3.12.2/./gdk/x11/gdkdevicemanager-xi2.c:1168
 _gdk_x11_event_translator_translate (translator=0x2492ed0, display=0x24b2000, xevent=xevent@entry=0x7fffe571b120) at /build/buildd/gtk+3.0-3.12.2/./gdk/x11/gdkeventtranslator.c:51
 gdk_event_source_translate_event (xevent=0x7fffe571b120, event_source=0x24983f0) at /build/buildd/gtk+3.0-3.12.2/./gdk/x11/gdkeventsource.c:240

Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: - unity-settings-daemon crashed with SIGSEGV in gdk_display_get_event()
+ unity-settings-daemon crashed with SIGSEGV in
+ _gdk_device_xi2_reset_scroll_valuators()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Haw Loeung (hloeung) on 2014-10-14
information type: Private → Public
Tim Lunn (darkxst) wrote :

I haven't been able to reproduce this here yet,, but I do maybe have an idea for a fix. Is anyone affected by this able to check (using gdb) the value of 'device->scroll_valuators' in frame #0. Hopefully it is NULL?

This occurred at the same time as bug 1366351.

tags: added: bugpattern-needed
Chris J Arges (arges) on 2014-10-14
Changed in unity-settings-daemon (Ubuntu):
importance: Medium → High

I was typing a message in Hangouts (Chrome) when it crashed.

Lars Karlitski (larsu) on 2014-10-14
Changed in unity-settings-daemon (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
status: Confirmed → In Progress
Iain Lane (laney) wrote :

Would people please check the package in ppa:ci-train-ppa-service/landing-008 to see if the crashes go away?

Packages from ppa:ci-train-ppa-service/landing-008 fixed the crash for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.10.20141014-0ubuntu1

---------------
unity-settings-daemon (14.04.0+14.10.20141014-0ubuntu1) utopic; urgency=low

  [ Lars Uebernickel ]
  * Idle monitor: fix ref counting bugs (LP: #1380278)
 -- Ubuntu daily release <email address hidden> Tue, 14 Oct 2014 15:25:59 +0000

Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Released
jerrylamos (jerrylamos) wrote :

Got the crash,
Just did an update:
.....
Preparing to unpack .../libunity-settings-daemon1_14.04.0+14.10.20141014-0ubuntu1_amd64.deb ...
Unpacking libunity-settings-daemon1 (14.04.0+14.10.20141014-0ubuntu1) over (14.04.0+14.10.20141010-0ubuntu1) ...
Preparing to unpack .../unity-settings-daemon_14.04.0+14.10.20141014-0ubuntu1_amd64.deb ...
Unpacking unity-settings-daemon (14.04.0+14.10.20141014-0ubuntu1) over (14.04.0+14.10.20141010-0ubuntu1) ...
.....

Looks like the comment #12

Will reboot & see.

jerrylamos (jerrylamos) wrote :

Whoopsie, got another crash after the update in comment #14 which on the surface looks like comment #12......

So whatever may be in

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.10.20141014-0ubuntu1

after shutdown, boot I still got another crash....

Dirk Mcbratney (djmcbratney) wrote :

If #1380638 really is a duplicate of this bug, it's definitely still active. unity-settings-daemon not only crashes, but fails to relaunch from terminal unless I log out and log back in, making it not just frustrating, but extremely time consuming.

To post a comment you must log in.