Touchpad stops working after switching user

Bug #1362218 reported by Bruno Nova on 2014-08-27
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

I don't know what's the correct package for this bug.

I'm using an Acer laptop with a Synaptics touchpad, Ubuntu 14.04 (Unity and lightdm).
I also usually have a wireless mouse connected.
When I switch to another user (like a guest session) using the top right cog menu directly (or by locking the screen then "switch user" from there to return to lightdm then start another session there), the touchpad doesn't work, but the mouse still works.

TESTS THAT I DID

With the mouse connected:
1. Start a guest session from the cog menu.
   > The touchpad doesn't work. Mouse is working.
2. Return to first user (through cog menu or Ctrl+Alt+F7).
   > Touchpad and mouse work.

With mouse connected:
1. Lock the screen.
2. "Switch account" from the lock screen to return to lightdm.
   > Touchpad doesn't work. Mouse is working.
   > If the guest session is started from here, touchpad is still not working.
3. Return to first user.
   > Touchpad and mouse work.

With mouse disconnected:
1. Start a guest session from the cog menu, or lock > "switch account" > login from there.
   > Touchpad and mouse work.
2. Return to first user.
   > Touchpad and mouse still work.
   > However, there was one time where the touchpad didn't work when returning to the first user (but i could re-enable it using the mouse&touchpad settings), but I couldn't reproduce it now.

MORE INFO

I haven't checked this in every test, but it seems the touchpad only works if syndaemon is running for the current user.
In the last test (mouse disconnected) "ps aux | grep syndaemon" showed syndaemon running for both me and guest.

This bug is also reported in Ask Ubuntu: http://askubuntu.com/questions/459570/synaptics-touchpad-not-detected-while-switching-user-on-unity
The user presented the Xorg logs (which are similar to mine), and the important part for of Xorg.1.log is:
            [ 32380.253] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
            [ 32380.253] (**) SynPS/2 Synaptics TouchPad: always reports core events
            [ 32380.253] (**) Option "Device" "/dev/input/event17"
            [ 32380.260] (EE) synaptics: SynPS/2 Synaptics TouchPad: Synaptics driver unable to detect protocol
            [ 32380.260] (EE) PreInit returned 11 for "SynPS/2 Synaptics TouchPad"
            [ 32380.260] (II) UnloadModule: "synaptics"
            [ 32380.260] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
            [ 32380.260] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"

Bug #1247388 is similar (maybe the same), and the reporter says that running these commands as the second user (with admin privileges, so no guest session):
    sudo modprobe -r psmouse
    sudo modprobe pmouse
enables the touchpad for the second user, but disables it for the first. I confirm this.
I tried this with the guest session too, but executed the commands from a virtual console logged in as an administrator. It enabled the touchpad for both users. But that only occurs when the second user is the guest session.

From Bug #868400, running this command as root before switching users:
    modprobe -r psmouse && modprobe psmouse proto=imps
makes the touchpad work "for everyone", but breaks the touchpad settings (cursor speed, two-finger scrolling, etc).

If more information is needed, just ask.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity-settings-daemon 14.04.0+14.04.20140414-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
Uname: Linux 3.13.0-34-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Aug 27 15:50:24 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-06-17 (71 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: unity-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)

Bruno Nova (brunonova) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Henning Moll (drscott) wrote :
Henning Moll (drscott) wrote :

I did an temporary hack to overcome this problem. You can find it here: http://askubuntu.com/a/527239

Cameron Hart (bitshifternz) wrote :

I've run into this problem on two different laptops now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers